ia32-libs and Kingsoft OfficeCorel Aftershot Pro on 64bit

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
HoppityBob
Level 1
Level 1
Posts: 43
Joined: Sun Feb 14, 2010 1:59 pm

ia32-libs and Kingsoft OfficeCorel Aftershot Pro on 64bit

Post by HoppityBob » Sat Feb 08, 2014 9:23 am

Both these applications require ia32-libs which has apparently been deprecated. I've done a 'dpkg --add-architecture i386' then managed to install one, but that leaves me with broken packages so it's basically entirely useless as I can't even have both installed at the same time, let alone install/update anything else.

How has anyone else managed to resolve this or how can I install ia32-libs without breaking my system ? This is what I usually get..

The following packages have unmet dependencies.
ia32-libs : Depends: gstreamer0.10-plugins-good:i386 but it is not going to be installed
Depends: libasound2-plugins:i386 but it is not going to be installed
Depends: libesd0:i386 but it is not going to be installed
Depends: libglu1-mesa:i386 but it is not going to be installed
Depends: libpulse-mainloop-glib0:i386 but it is not going to be installed
Depends: libpulsedsp:i386 but it is not going to be installed
Depends: libqt4-opengl:i386 but it is not going to be installed
Depends: libqtwebkit4:i386 but it is not going to be installed
Depends: libsdl-image1.2:i386 but it is not going to be installed
Depends: libsdl-mixer1.2:i386 but it is not going to be installed
Depends: libsdl-net1.2:i386 but it is not going to be installed
Depends: libsdl-ttf2.0-0:i386 but it is not going to be installed
Depends: libsdl1.2debian:i386 but it is not going to be installed
Depends: libgl1-mesa-dri:i386 but it is not going to be installed
Depends: libgl1-mesa-glx:i386 but it is not going to be installed
kingsoft-office:i386 : Depends: libglu1-mesa:i386 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Monsta
Level 10
Level 10
Posts: 3016
Joined: Fri Aug 19, 2011 3:46 am

Re: ia32-libs and Kingsoft OfficeCorel Aftershot Pro on 64bi

Post by Monsta » Sat Feb 08, 2014 1:24 pm

Did you run apt update after adding the i386 architecture?

HoppityBob
Level 1
Level 1
Posts: 43
Joined: Sun Feb 14, 2010 1:59 pm

Re: ia32-libs and Kingsoft OfficeCorel Aftershot Pro on 64bi

Post by HoppityBob » Sat Feb 08, 2014 3:31 pm

Hi, yes I did the update then installed the app. Checking foreign architectures show's i386. This lets me install say Kingsoft Office and it works, but it's a broken package (I get this during install - "dpkg: dependency problems prevent configuration of kingsoft-office: kingsoft-office depends on libglu1-mesa" even though libglu1-mesa is installed and there are no other versions to force or anything. Ia32-libs completely fails to install.

Monsta
Level 10
Level 10
Posts: 3016
Joined: Fri Aug 19, 2011 3:46 am

Re: ia32-libs and Kingsoft OfficeCorel Aftershot Pro on 64bi

Post by Monsta » Sat Feb 08, 2014 4:27 pm

It suggests running apt-get -f install, so I'd do that (with sudo of course) just to make sure there are no breakages in the dependencies.
Then I'd try installing some packages from the list to get hints about why they are "not going to be installed". For example,

Code: Select all

apt install libglu1-mesa:i386

HoppityBob
Level 1
Level 1
Posts: 43
Joined: Sun Feb 14, 2010 1:59 pm

Re: ia32-libs and Kingsoft OfficeCorel Aftershot Pro on 64bi

Post by HoppityBob » Sat Feb 08, 2014 5:33 pm

Thanks so much for the help. I've tried that but I get this..

some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
libgl1-mesa-dri:i386 : Depends: libdrm-nouveau2:i386 (>= 2.4.38) but it is not going to be installed
Depends: libdrm-radeon1:i386 (>= 2.4.31) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Looking at those I see yet more packages which in turn refuse to install, it's turtles all the way down. I give up !

Monsta
Level 10
Level 10
Posts: 3016
Joined: Fri Aug 19, 2011 3:46 am

Re: ia32-libs and Kingsoft OfficeCorel Aftershot Pro on 64bi

Post by Monsta » Sun Feb 09, 2014 2:42 am

You give up too early. I'd trace it further down.

But if you don't want to do that... the other way is to use aptitude. It will offer some solutions for fixing broken dependencies.

Code: Select all

sudo aptitude install ia32-libs

HoppityBob
Level 1
Level 1
Posts: 43
Joined: Sun Feb 14, 2010 1:59 pm

Re: ia32-libs and Kingsoft OfficeCorel Aftershot Pro on 64bi

Post by HoppityBob » Sun Feb 09, 2014 2:37 pm

Many thanks for the help though, it's much appreciated ! Fyi I have just tried aptitude but it wants to remove 202 packages, basically all of X and Kde, gimp, totem etc, just to..

Install the following packages:
203) gcj-4.6-base [4.6.4-1ubuntu1 (saucy)]
204) gcj-4.6-jre [4.6.4-1ubuntu1 (saucy)]
205) gcj-4.6-jre-headless [4.6.4-1ubuntu1 (saucy)]
206) libgcj-common [1:4.8.1-2ubuntu3 (saucy)]
207) libgcj12 [4.6.4-1ubuntu1 (saucy)]
208) libgcj12-awt [4.6.4-1ubuntu1 (saucy)]

Keep the following packages at their current version:
209) ia32-libs [Not Installed]
210) libdrm-nouveau2:i386 [Not Installed]
211) libdrm-radeon1:i386 [Not Installed]
212) libgl1-mesa-dri:i386 [Not Installed]

Monsta
Level 10
Level 10
Posts: 3016
Joined: Fri Aug 19, 2011 3:46 am

Re: ia32-libs and Kingsoft OfficeCorel Aftershot Pro on 64bi

Post by Monsta » Sun Feb 09, 2014 2:48 pm

That's not good, but aptitude asks if you want to accept the solution or not, and if you answer 'n', it will offer another one, and so on.

HoppityBob
Level 1
Level 1
Posts: 43
Joined: Sun Feb 14, 2010 1:59 pm

Re: ia32-libs and Kingsoft OfficeCorel Aftershot Pro on 64bi

Post by HoppityBob » Mon Feb 10, 2014 4:49 am

Yup, but unfortunately every one of them want to uninstall basically everything same as that :-( Crazy, I cannot understand why I'm getting these sort of errors as I have no 3rd party ppa's enabled or anything.

Monsta
Level 10
Level 10
Posts: 3016
Joined: Fri Aug 19, 2011 3:46 am

Re: ia32-libs and Kingsoft OfficeCorel Aftershot Pro on 64bi

Post by Monsta » Mon Feb 10, 2014 2:38 pm

Then I'd return to apt-get and still try to trace the errors further down the dependency list. I remember a similar problem once happened in LMDE, and it all came down to the different versions of libc6 and libc6:i386, which essentially prevented the installation of any 32-bit packages. That problem has been solved successfully.

User avatar
jungle_boy
Level 7
Level 7
Posts: 1714
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest Land

Re: ia32-libs and Kingsoft OfficeCorel Aftershot Pro on 64bi

Post by jungle_boy » Tue Feb 11, 2014 8:57 am

I am running Kingsoft office in LM14 cinnamon, 64bit, with ia32-libs and ia32-libs-multiarch:i386 files installed. Running fine.

Post Reply

Return to “Software & Applications”