Page 1 of 1

[Solved]The applications shortcuts at main menu dissappeared

Posted: Sun Feb 23, 2014 2:48 pm
by epdiamantopoulos
After the installation of pyCharm (http://www.jetbrains.com/pycharm/) I experience an error message after each boot (see next image)
problem_after_installing_pyCharm.png
Message after initial boot.
while all applications shortcuts from the main menu of MATE just disappeared! (see next image)
problem_after_installing_pyCharm1.png
Where are the applications?
.

I would appreciate any suggestion about make them appear again!

Re: The applications shortcuts at main menu dissappeared

Posted: Sun Feb 23, 2014 3:03 pm
by Monsta
This is a known bug. It's not clear when the fix will be released, but you can fix it yourself:

  1. Run

    Code: Select all

    gksu pluma /usr/lib/linuxmint/mintMenu/plugins/easybuttons.py
    in the terminal.
  2. Go to line 282.
  3. Replace

    Code: Select all

    c = c_char_p(iconName.encode('ascii', 'ignore'))
    with

    Code: Select all

    c = c_char_p(iconName.decode('utf-8', 'ignore').encode('ascii', 'ignore'))
  4. Save the file.
  5. Log out and log in back.

Re: The applications shortcuts at main menu dissappeared

Posted: Sun Feb 23, 2014 8:07 pm
by epdiamantopoulos
Thank you for your advice however it seems that it is not solves the problem. Actually, after I tried
c = c_char_p(iconName.decode('utf-8', 'ignore').encode('ascii', 'ignore'))
I see
Screenshot.png


The funny thing is that I can not go in the previous situation since the change

c = c_char_p(iconName.encode('ascii', 'ignore'))

is not make any improvement. I also tried with

c = c_char_p(iconName.encode("ascii", "ignore"))

but in vein.

I guess, tommorow I will upgrade in LM Mate 16 (now I am running 15).

Re: The applications shortcuts at main menu dissappeared

Posted: Sun Feb 23, 2014 11:01 pm
by Monsta
Check the indentation, it must be exactly the same as before.

Re: The applications shortcuts at main menu dissappeared

Posted: Mon Feb 24, 2014 1:58 am
by epdiamantopoulos
Ok, probably the problem is that by copying - paste from your post some hidden character created a problem. By copying the line 401 of the same file I revert to the previous problematic situation, however it is still not possible to see the menu icons.

Re: The applications shortcuts at main menu dissappeared

Posted: Mon Feb 24, 2014 2:13 am
by Monsta
Try copying from here and pay attention to the indentation this time. There should be exactly 12 spaces before the code.

Re: The applications shortcuts at main menu dissappeared

Posted: Mon Feb 24, 2014 9:22 am
by epdiamantopoulos
Well done! Thank you for your help!