Lyx: what do I need to install to get it working properly?

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
bjhkjhkrdjbv
Level 1
Level 1
Posts: 33
Joined: Tue Aug 27, 2013 9:25 am

Lyx: what do I need to install to get it working properly?

Post by bjhkjhkrdjbv » Wed Apr 09, 2014 7:19 pm

I have used LyX under Win XP for a large project and now want to continue using it on Linux but I run into weird problems when trying to create pdfs with it. I solved some of them by installing missing parts of TeX that were in extra packages and not installed by default but problems remain, like vector graphics ending up as badly pixelated pictures in pdflatex and all other ways of making pdf blocked by errors about too large numbers and too big images (opening the same lyx file with LyX on WinXP works fine and creates a good pdf).

What packages do I need to install in order to get the full functionality that the standard installation of LyX for Windows has?

User avatar
killer de bug
Level 14
Level 14
Posts: 5415
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: Lyx: what do I need to install to get it working properl

Post by killer de bug » Thu Apr 10, 2014 12:46 pm

I would install

Code: Select all

texlive-latex-extra texlive-latex-recommended texlive-fonts-recommended texlive-latex-base texlive-base 
and depending on your language, you can chose which one you want:

Code: Select all

texlive-lang-english
If it ain't broke, fix it until it is.

bjhkjhkrdjbv
Level 1
Level 1
Posts: 33
Joined: Tue Aug 27, 2013 9:25 am

Re: Lyx: what do I need to install to get it working properl

Post by bjhkjhkrdjbv » Thu Apr 10, 2014 5:00 pm

Thank you.
I see I have all of these and quite a few more. I could try "texlive-full" but it contains lots of stuff I certainly don't need, weighs two gigabytes (a lot on a 16GB system partition) and can't be installed anyway because it hangs on a damaged half finished download. Any other ideas what it could be?

User avatar
killer de bug
Level 14
Level 14
Posts: 5415
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: Lyx: what do I need to install to get it working properl

Post by killer de bug » Thu Apr 10, 2014 5:55 pm

Code: Select all

 Here are some more packages NOT listed as "recommended" or "suggested" that you might want to add:

    qt4-qtconfig (allows customizing menu font/size and other parameters in LyX GUI)
    texlive (meta-package including the most common texlive packages),
    texlive-extra-utils,
    texlive-fonts-extra,
    texlive-formats-extra,
    texlive-generic-extra,
    texlive-latex-extra (here is the wrapfig latex package),
    texlive-math-extra (D. Knuth's beautiful Concrete font is here),
    texlive-science (if you use algoritm(ic) packages)
    texlive-lang-xyz (xyz is your local language which you can get from LANG) 
http://wiki.lyx.org/LyX/LyXOnUbuntu
If it ain't broke, fix it until it is.

bjhkjhkrdjbv
Level 1
Level 1
Posts: 33
Joined: Tue Aug 27, 2013 9:25 am

Re: Lyx: what do I need to install to get it working properl

Post by bjhkjhkrdjbv » Thu Apr 10, 2014 6:14 pm

Thank you.
I now have all of these and texlive-full too and it doesn't help the problem. I have asked the LyX mailing list too. I will update here if they have a solution.

User avatar
killer de bug
Level 14
Level 14
Posts: 5415
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: Lyx: what do I need to install to get it working properl

Post by killer de bug » Thu Apr 10, 2014 6:18 pm

Just to be sure, are you sure all LyX package are installed?

Do you have lyx-common installed?
If it ain't broke, fix it until it is.

bjhkjhkrdjbv
Level 1
Level 1
Posts: 33
Joined: Tue Aug 27, 2013 9:25 am

Re: Lyx: what do I need to install to get it working properl

Post by bjhkjhkrdjbv » Sat Apr 12, 2014 3:46 pm

Yes. LyX is dependent on it.

Post Reply

Return to “Software & Applications”