Multiple issues trying to install AUDACITY

Questions about applications and software
Forum rules
Before you post please read how to get help
dsotmb40
Level 1
Level 1
Posts: 6
Joined: Fri Apr 11, 2014 3:19 am

Multiple issues trying to install AUDACITY

Postby dsotmb40 » Fri Apr 11, 2014 3:23 am

So this is my chain of events, what is going on??? IMANOOB
$ sudo apt-get install audacity
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
audacity : Depends: audacity-data (= 1.3.13-5) but it is not going to be installed
Depends: libflac++6 (>= 1.2.1) but it is not going to be installed
Depends: libportsmf0 but it is not going to be installed
Depends: libvamp-hostsdk3 but it is not going to be installed
Depends: libwxbase2.8-0 (>= 2.8.11.0) but it is not going to be installed
Depends: libwxgtk2.8-0 (>= 2.8.11.0) but it is not going to be installed
wakeup : Depends: python-evolution but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
jay@jay-H61MU3 ~ $ sudo apt-get install subversion
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
subversion : Depends: libsvn1 (= 1.6.12dfsg-4ubuntu5.1) but it is not going to be installed
Depends: libapr1 (>= 1.2.7) but it is not going to be installed
wakeup : Depends: python-evolution but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
jay@jay-H61MU3 ~ $ svn checkout http://audacity.googlecode.com/svn/audacity-src/trunk/ audacity-read-only
The program 'svn' is currently not installed. You can install it by typing:
sudo apt-get install subversion
jay@jay-H61MU3 ~ $ sudo apt-get install subversion
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
subversion : Depends: libsvn1 (= 1.6.12dfsg-4ubuntu5.1) but it is not going to be installed
Depends: libapr1 (>= 1.2.7) but it is not going to be installed
wakeup : Depends: python-evolution but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
jay@jay-H61MU3 ~ $ apt-get -f install
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
jay@jay-H61MU3 ~ $
Last edited by Oscar799 on Fri Apr 11, 2014 3:29 am, edited 1 time in total.
Reason: Edited for language

User avatar
gtsfer
Level 7
Level 7
Posts: 1925
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: Multiple issues trying to install AUDACITY

Postby gtsfer » Fri Apr 11, 2014 10:59 am

Try these in order first, to make sure your "stuff" is all up to date and then to clean up and remove any unnecessary left over package dependencies not in use...

Code: Select all

sudo apt-get update
sudo apt-get upgrade
sudo apt-get autoclean
sudo apt-get autoremove


Assuming that works, go for it again...

Code: Select all

sudo apt-get audacity

I noticed your last command "apt-get -f install" was missing the "sudo" in front. That's why that failed to get a lock and permission denied. :)
Just an fyi.. you could also use Synaptic "Package Manager" or "Software Manager" to search for and install things. I think "audacity" is listed in there. These GUI font-end tools are sometimes easier than apt-get from terminal until you get the hand of what it all means.
"There is no gravity, the earth sucks." - Issac Newton @ 75
KDE & Cinnamon 18.1 & Win 10 - ASUS M5A99FX PRO MB, AMD FX-8370 Octo-Core CPU, 16GB RAM, AMD Radeon R7 240

dsotmb40
Level 1
Level 1
Posts: 6
Joined: Fri Apr 11, 2014 3:19 am

Re: Multiple issues trying to install AUDACITY

Postby dsotmb40 » Tue Apr 15, 2014 3:12 am

Thank you for the reply!! I'm trying this now..

~ $ sudo apt-get update
[sudo] password for jay:
Ign http://packages.linuxmint.com lisa InRelease
Ign http://ppa.launchpad.net oneiric InRelease
Get:1 http://packages.linuxmint.com lisa Release.gpg [198 B]
Get:2 http://ppa.launchpad.net oneiric Release.gpg [316 B]
Get:3 http://packages.linuxmint.com lisa Release [18.5 kB]
Get:4 http://packages.linuxmint.com lisa/main amd64 Packages [14.8 kB]
Get:5 http://packages.linuxmint.com lisa/upstream amd64 Packages [28.9 kB]
Hit http://ppa.launchpad.net oneiric Release
Ign http://ppa.launchpad.net oneiric Release
Get:6 http://packages.linuxmint.com lisa/import amd64 Packages [22.1 kB]
Ign http://ppa.launchpad.net oneiric/main Sources/DiffIndex
Ign http://ppa.launchpad.net oneiric/main amd64 Packages/DiffIndex
Ign http://ppa.launchpad.net oneiric/main i386 Packages/DiffIndex
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Get:7 http://packages.linuxmint.com lisa/main i386 Packages [14.8 kB]
Get:8 http://packages.linuxmint.com lisa/upstream i386 Packages [28.4 kB]
Hit http://ppa.launchpad.net oneiric/main Sources
Hit http://ppa.launchpad.net oneiric/main amd64 Packages
Hit http://ppa.launchpad.net oneiric/main i386 Packages
Get:9 http://packages.linuxmint.com lisa/import i386 Packages [22.0 kB]
Ign http://packages.linuxmint.com lisa/import TranslationIndex
Ign http://packages.linuxmint.com lisa/main TranslationIndex
Ign http://packages.linuxmint.com lisa/upstream TranslationIndex
Ign http://ppa.launchpad.net oneiric/main Translation-en_US
Ign http://ppa.launchpad.net oneiric/main Translation-en
Ign http://packages.linuxmint.com lisa/import Translation-en_US
Ign http://packages.linuxmint.com lisa/import Translation-en
Ign http://packages.linuxmint.com lisa/main Translation-en_US
Ign http://packages.linuxmint.com lisa/main Translation-en
Ign http://packages.linuxmint.com lisa/upstream Translation-en_US
Ign http://packages.linuxmint.com lisa/upstream Translation-en
Ign http://old-releases.ubuntu.com oneiric InRelease
Ign http://old-releases.ubuntu.com oneiric-updates InRelease
Ign http://old-releases.ubuntu.com oneiric-security InRelease
Hit http://old-releases.ubuntu.com oneiric Release.gpg
Hit http://old-releases.ubuntu.com oneiric-updates Release.gpg
Hit http://old-releases.ubuntu.com oneiric-security Release.gpg
Hit http://old-releases.ubuntu.com oneiric Release
Hit http://old-releases.ubuntu.com oneiric-updates Release
Hit http://old-releases.ubuntu.com oneiric-security Release
Hit http://old-releases.ubuntu.com oneiric/main amd64 Packages
Hit http://old-releases.ubuntu.com oneiric/restricted amd64 Packages
Hit http://old-releases.ubuntu.com oneiric/universe amd64 Packages
Hit http://old-releases.ubuntu.com oneiric/multiverse amd64 Packages
Hit http://old-releases.ubuntu.com oneiric-updates/main amd64 Packages
Hit http://old-releases.ubuntu.com oneiric-updates/restricted amd64 Packages
Hit http://old-releases.ubuntu.com oneiric-updates/universe amd64 Packages
Hit http://old-releases.ubuntu.com oneiric-updates/multiverse amd64 Packages
Hit http://old-releases.ubuntu.com oneiric-updates/main i386 Packages
Hit http://old-releases.ubuntu.com oneiric-updates/restricted i386 Packages
Hit http://old-releases.ubuntu.com oneiric-updates/universe i386 Packages
Hit http://old-releases.ubuntu.com oneiric-updates/multiverse i386 Packages
Hit http://old-releases.ubuntu.com oneiric-updates/main TranslationIndex
Hit http://old-releases.ubuntu.com oneiric-updates/multiverse TranslationIndex
Hit http://old-releases.ubuntu.com oneiric-updates/restricted TranslationIndex
Hit http://old-releases.ubuntu.com oneiric-updates/universe TranslationIndex
Hit http://old-releases.ubuntu.com oneiric-security/main amd64 Packages
Hit http://old-releases.ubuntu.com oneiric-security/restricted amd64 Packages
Hit http://old-releases.ubuntu.com oneiric-security/universe amd64 Packages
Hit http://old-releases.ubuntu.com oneiric-security/multiverse amd64 Packages
Hit http://old-releases.ubuntu.com oneiric-security/main i386 Packages
Hit http://old-releases.ubuntu.com oneiric-security/restricted i386 Packages
Hit http://old-releases.ubuntu.com oneiric-security/universe i386 Packages
Hit http://old-releases.ubuntu.com oneiric-security/multiverse i386 Packages
Hit http://old-releases.ubuntu.com oneiric-security/main TranslationIndex
Hit http://old-releases.ubuntu.com oneiric-security/multiverse TranslationIndex
Hit http://old-releases.ubuntu.com oneiric-security/restricted TranslationIndex
Hit http://old-releases.ubuntu.com oneiric-security/universe TranslationIndex
Hit http://old-releases.ubuntu.com oneiric-updates/main Translation-en
Hit http://old-releases.ubuntu.com oneiric-updates/multiverse Translation-en
Hit http://old-releases.ubuntu.com oneiric-updates/restricted Translation-en
Hit http://old-releases.ubuntu.com oneiric-updates/universe Translation-en
Hit http://old-releases.ubuntu.com oneiric-security/main Translation-en
Hit http://old-releases.ubuntu.com oneiric-security/multiverse Translation-en
Hit http://old-releases.ubuntu.com oneiric-security/restricted Translation-en
Hit http://old-releases.ubuntu.com oneiric-security/universe Translation-en
Fetched 150 kB in 15s (9,489 B/s)
W: GPG error: http://ppa.launchpad.net oneiric Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 5A9A06AEF9CB8DB0
W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/d ... ic/Release Unable to find expected entry 'partner/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.

dsotmb40
Level 1
Level 1
Posts: 6
Joined: Fri Apr 11, 2014 3:19 am

Re: Multiple issues trying to install AUDACITY

Postby dsotmb40 » Tue Apr 15, 2014 3:15 am

Then I tried....

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
wakeup : Depends: python-evolution but it is not installed
E: Unmet dependencies. Try using -f.

dsotmb40
Level 1
Level 1
Posts: 6
Joined: Fri Apr 11, 2014 3:19 am

Re: Multiple issues trying to install AUDACITY

Postby dsotmb40 » Tue Apr 15, 2014 3:17 am

Ok so I put sudo in front and I get this,,,,ugh

$ Sudo apt-get -f install
No command 'Sudo' found, did you mean:
Command 'sudo' from package 'sudo' (main)
Command 'sudo' from package 'sudo-ldap' (universe)
Command 'udo' from package 'udo' (universe)
Sudo: command not found

User avatar
eanfrid
Level 7
Level 7
Posts: 1861
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: Multiple issues trying to install AUDACITY

Postby eanfrid » Tue Apr 15, 2014 3:22 am

"Sudo" is not "sudo" :)
Main desktop: Debian GNU/Linux Jessie 64bit - MATE
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox

User avatar
administrollaattori
Level 12
Level 12
Posts: 4326
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Multiple issues trying to install AUDACITY

Postby administrollaattori » Tue Apr 15, 2014 3:23 am

Linux Mint Lisa has been obsolete since April 2013
http://www.linuxmint.com/oldreleases.php

dsotmb40
Level 1
Level 1
Posts: 6
Joined: Fri Apr 11, 2014 3:19 am

Re: Multiple issues trying to install AUDACITY

Postby dsotmb40 » Tue Apr 15, 2014 3:31 am

""Just an fyi.. you could also use Synaptic "Package Manager" or "Software Manager" to search for and install things. I think "audacity" is listed in there. ""( Yes software manager is what I have, I go to it it says not installed, I click on install, Mint asks for password to install or remove packages... then it just seems to stall and do nothing.. I clicked on the: link http://audacity.sourceforge.net
and installed compressed package that I expanded in downloads folder..try to install and this is where my post originated...

These GUI font-end tools are sometimes easier than apt-get from terminal until you get the hand of what it all means.[/quote] I'm pretty much just starting to use this computer proper..

dsotmb40
Level 1
Level 1
Posts: 6
Joined: Fri Apr 11, 2014 3:19 am

Re: Multiple issues trying to install AUDACITY

Postby dsotmb40 » Thu Apr 17, 2014 2:30 am

sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
python-evolution
The following NEW packages will be installed:
python-evolution
0 upgraded, 1 newly installed, 0 to remove and 369 not upgraded.
1 not fully installed or removed.
Need to get 0 B/78.2 kB of archives.
After this operation, 414 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
(Reading database ... 196221 files and directories currently installed.)
Unpacking python-evolution (from .../python-evolution_2.32.0-0ubuntu6_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/python-evolution_2.32.0-0ubuntu6_amd64.deb (--unpack):
trying to overwrite '/usr/lib/python2.7/dist-packages/gtk-2.0/evolution/ecal.la', which is also in package python-mate-desktop 1.0.2-1
Errors were encountered while processing:
/var/cache/apt/archives/python-evolution_2.32.0-0ubuntu6_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Return to “Software & Applications”