gnucash

Questions about applications and software
Forum rules
Before you post please read how to get help
Eldrick
Level 1
Level 1
Posts: 24
Joined: Sun Apr 13, 2014 5:11 am

Re: gnucash

Postby Eldrick » Wed Apr 16, 2014 3:06 pm

rb this is what I got now something similiar to previous outputs

Code: Select all

john@john-Latitude-D620 ~ $ sudo apt-get install gnucash
[sudo] password for john:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnucash : Depends: libaqbanking34 (>= 4.99.2) but it is not installable
           Depends: libdbi1 (>= 0.8.4) but it is not installable
           Depends: libgoffice-0.8-8 (>= 0.8.8) but it is not installable
           Depends: libgwengui-gtk2-0 (>= 3.99.16) but it is not installable
           Depends: libgwenhywfar60 (>= 3.99.1) but it is not installable
           Depends: libktoblzcheck1c2a (>= 1.19) but it is not installable
           Depends: libofx4 but it is not installable
           Depends: guile-2.0 but it is not installable
           Depends: libfinance-quote-perl but it is not installable
           Depends: libwww-perl but it is not installable
           Depends: libhtml-tree-perl but it is not installable
           Depends: libhtml-tableextract-perl but it is not installable
           Depends: libcrypt-ssleay-perl but it is not installable
           Depends: libdate-manip-perl but it is not installable
E: Unable to correct problems, you have held broken packages.

regards

rbmorse
Level 3
Level 3
Posts: 113
Joined: Mon Mar 07, 2011 11:56 pm
Location: Albuquerque, New Mexico USA

Re: gnucash

Postby rbmorse » Wed Apr 16, 2014 3:51 pm

Hummmmm. I'm afraid I've just run out of knowledge.

Not a suggestion, but if it were me and my machine I think my next course of action would be to use Synaptic and try to manually delete the files on the problem list. I think what is happening is that the version of Gnucash in the getdeb repository is newer than the version you last tried to install. The newer Gnucash needs newer versions of the support files than than the ones you have on the machine (the list of broken dependencies) but apt-get can't update them because the old ones are somehow "locked." But, that's just surmise on my part.

My real suggestion is to wait for someone who is smarter than I on how to deal with broken packages to help you through this. Sorry I can't get you going.
Hope is not a plan

Eldrick
Level 1
Level 1
Posts: 24
Joined: Sun Apr 13, 2014 5:11 am

Re: gnucash

Postby Eldrick » Thu Apr 17, 2014 4:28 am

rb thanks for your help and time I think I'll leave it for the moment and look for something else, here is last output from terminal.
hope you have a good Easter

Code: Select all

udo apt-get install gnucash
[sudo] password for john:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnucash : Depends: libaqbanking34 (>= 4.99.2) but it is not installable
           Depends: libdbi1 (>= 0.8.4) but it is not installable
           Depends: libgoffice-0.8-8 (>= 0.8.8) but it is not installable
           Depends: libgwengui-gtk2-0 (>= 3.99.16) but it is not installable
           Depends: libgwenhywfar60 (>= 3.99.1) but it is not installable
           Depends: libktoblzcheck1c2a (>= 1.19) but it is not installable
           Depends: libofx4 but it is not installable
           Depends: guile-2.0 but it is not installable
           Depends: libfinance-quote-perl but it is not installable
           Depends: libwww-perl but it is not installable
           Depends: libhtml-tree-perl but it is not installable
           Depends: libhtml-tableextract-perl but it is not installable
           Depends: libcrypt-ssleay-perl but it is not installable
           Depends: libdate-manip-perl but it is not installable
E: Unable to correct problems, you have held broken packages.


Return to “Software & Applications”