Issue with Synaptic after update in Mint 13

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
mark1mint
Level 3
Level 3
Posts: 143
Joined: Tue May 22, 2012 4:36 pm

Issue with Synaptic after update in Mint 13

Post by mark1mint » Fri May 09, 2014 1:50 pm

I've discovered that after the last updates in Mint 13 Mate,Synaptic isn't working properly:clicking its icon does nothing,so I've tried launching it from terminal by simply typing "synaptic",which sort of works,as Synaptic opens without administrative privileges,which is kinda expected,but then also prints to the terminal the following messages

Code: Select all

(synaptic:3771): GLib-GObject-CRITICAL **: g_object_set_data: assertion `G_IS_OBJECT (object)' failed

(synaptic:3771): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(synaptic:3771): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
I've also tried synaptic-pkexec,which prompts for the password

Code: Select all

==== AUTHENTICATING FOR com.ubuntu.pkexec.synaptic ===
Authentication is required to run the Synaptic Package Manager
Authenticating as: user,,, (user)
Password: 
but since I'm note sure of what is going on here,I've not entered it.

Does anyone has a clue on what is going on?
It must have been some of the latest updates,because I'm fairly sure that Synaptic used to work until now.

User avatar
administrollaattori
Level 15
Level 15
Posts: 5898
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Issue with Synaptic after update in Mint 13

Post by administrollaattori » Fri May 09, 2014 3:34 pm

You should run Synaptic using command

Code: Select all

gksu synaptic

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Issue with Synaptic after update in Mint 13

Post by austin.texas » Sat May 10, 2014 9:08 am

Alternatively, the command used in the Menu launcher is

Code: Select all

synaptic-pkexec
Just enter the password. There is no problem with that. Those GLib error messages are inconsequential.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

mark1mint
Level 3
Level 3
Posts: 143
Joined: Tue May 22, 2012 4:36 pm

Re: Issue with Synaptic after update in Mint 13

Post by mark1mint » Sun May 11, 2014 4:19 pm

Well,gksudo synaptic does indeed work (I forgot about that,thanks for reminding me),still I don't understand what is going on:the command field in the synaptic launchers I have in the menu looks indeed correct

Code: Select all

synaptic-pkexec
furthermore I'm reasonably sure I haven't modified anything here.

So why are those launchers not working all of a sudden?
This must have happened after some recent update,because I'm sure they worked until recently-the only thing that comes to mind,is that I have been doing the last updates from terminal instead of using either synaptic or MintUpdate,could this be the reason?

mark1mint
Level 3
Level 3
Posts: 143
Joined: Tue May 22, 2012 4:36 pm

Re: Issue with Synaptic after update in Mint 13

Post by mark1mint » Tue May 13, 2014 11:10 am

Just for peace of mind,I have no problem in changing the command field for the Synaptic launcher from

Code: Select all

synaptic-pkexec
to

Code: Select all

gksudo synaptic
I'd just need to be sure that is a glitch of some kind and not a sign of my system being somehow compromised.

mark1mint
Level 3
Level 3
Posts: 143
Joined: Tue May 22, 2012 4:36 pm

Re: Issue with Synaptic after update in Mint 13

Post by mark1mint » Wed May 14, 2014 3:33 am

And the weird thing is,after launching Synaptic a couple of times using gksudo synaptic,now the old launcher with synaptic-pkexec works again:anyone knows why?
Maybe something to do with permissions,after installing updates from a terminal instead of the GUI tools?

mark1mint
Level 3
Level 3
Posts: 143
Joined: Tue May 22, 2012 4:36 pm

Re: Issue with Synaptic after update in Mint 13

Post by mark1mint » Sat May 17, 2014 4:33 am

Even more weird:sometimes I can launch Synaptic from the GUI normally,i.e. I can click its icon in the menu and I get a prompt for the password,sometimes nothing happens,all other things been equal.
What is going on here?

I've checked ownership and permissions for synaptic

Code: Select all

-rwxr-xr-x 1 root root     43 Feb  6  2012 /usr/bin/synaptic-pkexec
-rwxr-xr-x 1 root root 770312 Apr  4 00:12 /usr/sbin/synaptic
are these correct?

When launching it successfully,here's what I seen in auth.log:

Code: Select all

mint13maya polkitd(authority=local): Operator of unix-session:/org/freedesktop/ConsoleKit/Session1 successfully authenticated as unix-user:mintuser13 to gain ONE-SHOT authorization for action com.ubuntu.pkexec.synaptic for unix-process:2575:144498 [/bin/sh /usr/bin/synaptic-pkexec] (owned by unix-user:mintuser13)
May 17 08:10:13 mint13maya pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
May 17 08:10:13 mint13maya pkexec: pam_ck_connector(polkit-1:session): cannot determine display-device
May 17 08:10:13 mint13maya pkexec[2576]: mint13: Executing command [USER=root] [TTY=unknown] [CWD=/home/mint13] [COMMAND=/usr/sbin/synaptic]
Is that OK? What about that "cannot determine display-device" line ?

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Issue with Synaptic after update in Mint 13

Post by austin.texas » Sat May 17, 2014 8:03 am

mark1mint wrote:I've checked ownership and permissions for synaptic

Code: Select all

-rwxr-xr-x 1 root root     43 Feb  6  2012 /usr/bin/synaptic-pkexec
-rwxr-xr-x 1 root root 770312 Apr  4 00:12 /usr/sbin/synaptic
are these correct?
These are correct. I have the same in Mint 17 Cinnamon and Mint 16 Mate.

It looks the same for me -
Using Menu launcher for synaptic:

Code: Select all

May 17 06:54:58 SkyNet polkitd(authority=local): Operator of unix-session:c1 successfully authenticated as unix-user:dan to gain ONE-SHOT authorization for action com.ubuntu.pkexec.synaptic for unix-process:4339:135987 [/bin/sh /usr/bin/synaptic-pkexec] (owned by unix-user:dan)
May 17 06:54:58 SkyNet pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
May 17 06:54:58 SkyNet pkexec: pam_ck_connector(polkit-1:session): cannot determine display-device
May 17 06:54:58 SkyNet pkexec[4342]: dan: Executing command [USER=root] [TTY=unknown] [CWD=/home/dan] [COMMAND=/usr/sbin/synaptic]
Using gksudo synaptic:

Code: Select all

May 17 06:56:34 SkyNet sudo:      dan : TTY=unknown ; PWD=/home/dan ; USER=root ; COMMAND=/usr/sbin/synaptic
May 17 06:56:34 SkyNet sudo: pam_unix(sudo:session): session opened for user root by (uid=0)
Using gksu synaptic:

Code: Select all

May 17 07:02:06 SkyNet sudo:      dan : TTY=unknown ; PWD=/home/dan ; USER=root ; COMMAND=/usr/sbin/synaptic
May 17 07:02:06 SkyNet sudo: pam_unix(sudo:session): session opened for user root by (uid=0)
However, when I enter synaptic-pkexec in a terminal, I get a different result for the TTY (they all work to start synaptic)

Code: Select all

May 17 07:06:23 SkyNet polkitd(authority=local): Operator of unix-session:c1 successfully authenticated as unix-user:dan to gain ONE-SHOT authorization for action com.ubuntu.pkexec.synaptic for unix-process:20497:204586 [/bin/sh /usr/bin/synaptic-pkexec] (owned by unix-user:dan)
May 17 07:06:23 SkyNet pkexec: pam_unix(polkit-1:session): session opened for user root by dan(uid=1000)
May 17 07:06:23 SkyNet pkexec: pam_ck_connector(polkit-1:session): cannot determine display-device
May 17 07:06:23 SkyNet pkexec[20498]: dan: Executing command [USER=root] [TTY=/dev/pts/0] [CWD=/home/dan] [COMMAND=/usr/sbin/synaptic]
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

mark1mint
Level 3
Level 3
Posts: 143
Joined: Tue May 22, 2012 4:36 pm

Re: Issue with Synaptic after update in Mint 13

Post by mark1mint » Mon May 19, 2014 3:55 pm

Thanks for following this weird issue,as of now everything seems back to normal,but goes without saying I'm not too confident about this thing-since it randomly happens that sometimes I can't launch Synaptic and sometimes I can,without modifying anything on my system,that brings up the (paranoic) customary question:is this computer somehow compromised?

That seems unlikely,I have no services requiring remote access enabled,and no other user shows up in the logs,but still...why would Synaptic all of a sudden misbehave like that?

mark1mint
Level 3
Level 3
Posts: 143
Joined: Tue May 22, 2012 4:36 pm

Re: Issue with Synaptic after update in Mint 13

Post by mark1mint » Tue Jun 10, 2014 12:05 pm

By any chance,does anybody have a clue about why sometimes I can normally launch synaptic from the GUI and sometimes I can't ?

This annoying issue has surfaced a couple of months ago and it's,by the looks of it,totally random:I can't isolate under which conditions it does or does not work.

Post Reply

Return to “Software & Applications”