Flash Not Working in Chromium Browser

Questions about applications and software
Forum rules
Before you post please read how to get help
WilhelmGGW
Level 1
Level 1
Posts: 39
Joined: Mon May 12, 2014 6:07 pm

Flash Not Working in Chromium Browser

Post by WilhelmGGW » Wed May 21, 2014 2:17 pm

I just made a clean install of Mint 17 and am running Cinnamon. Flash runs perfectly in the native Firefox. But I installed the chromium-browser (v 34) from the respository + the pepperflashplugin, as instructed, and flash still doesn't work in Chromium. I even installed the Adobe Flash plugin from Synaptic, and still nothing. Can someone tell me what I should do? Thanks so much.

Stevassall0
Level 1
Level 1
Posts: 1
Joined: Wed May 21, 2014 2:40 pm

Re: Flash Not Working in Chromium Browser

Post by Stevassall0 » Wed May 21, 2014 2:45 pm

I have the exact same problem, I installed the plugins as according to instructions and it only works on Firefox and not on Chromium

ClutchDisc
Level 5
Level 5
Posts: 634
Joined: Wed Mar 26, 2014 12:31 pm
Location: Detroit area

Re: Flash Not Working in Chromium Browser

Post by ClutchDisc » Wed May 21, 2014 2:49 pm

This is what worked for me on MInt MATE 17: pepperflashplugin-nonfree

Is that what you installed, or did you just install pepperflashplugin? (not sure if there is a difference between the two)
Custom build
OS: Linux Mint 18.1 Cinnamon
CPU: Intel Core i5 2.70GHz quad core
RAM: 8GB DDR4
OS drive: 120GB SSD
Data drive: 2TB HDD

WilhelmGGW
Level 1
Level 1
Posts: 39
Joined: Mon May 12, 2014 6:07 pm

Re: Flash Not Working in Chromium Browser

Post by WilhelmGGW » Wed May 21, 2014 3:05 pm

ClutchDisc wrote:This is what worked for me on MInt MATE 17: pepperflashplugin-nonfree
Is that what you installed, or did you just install pepperflashplugin? (not sure if there is a difference between the two)
No, I installed what you did -- following the instructions here: https://wiki.ubuntu.com/Chromium/Getting-Flash#help I got it from the respository; then, when that didn't work, I used the update in terminal. All to no avail. The pepper pluggin is still well installed [as far as I can tell]; it's just not working.

ClutchDisc
Level 5
Level 5
Posts: 634
Joined: Wed Mar 26, 2014 12:31 pm
Location: Detroit area

Re: Flash Not Working in Chromium Browser

Post by ClutchDisc » Wed May 21, 2014 3:26 pm

Hmmm.. Maybe a bug in the Cinnamon RC? Because it's working great for me in the Mate RC.

Have you closed and reopened your browser after installing pepperflashplugin-nonfree?
Custom build
OS: Linux Mint 18.1 Cinnamon
CPU: Intel Core i5 2.70GHz quad core
RAM: 8GB DDR4
OS drive: 120GB SSD
Data drive: 2TB HDD

WilhelmGGW
Level 1
Level 1
Posts: 39
Joined: Mon May 12, 2014 6:07 pm

Re: Flash Not Working in Chromium Browser

Post by WilhelmGGW » Wed May 21, 2014 3:45 pm

Yes, closed and reopened several times. Tried on different web sites, and so on. Just won't do the job. Keeps popping up the header that I need to install pepper. Maybe there's a good way to report the possible bug in Cinnamon? My wife won't be using Chromium till the next time we travel; but I still won't rest well till this runs as perfectly as everything else does on Mint.

User avatar
WinterTroubles
Level 6
Level 6
Posts: 1474
Joined: Fri Apr 11, 2014 6:25 am
Location: UK

Re: Flash Not Working in Chromium Browser

Post by WinterTroubles » Wed May 21, 2014 3:56 pm

Yesterday chrome updated to V35 using 'aura' and now only uses adobe flash player, on my box with pepperflash installed for firefox pepperflash no is longer recognised by chrome, when it was prior to the update. I have no idea how you would proceed with this information as chrome has updated my plugins recently and they work as they always did.

Edit.. Chrome's change to the 'aura' package is a reflection of chromium doing the same.
17.1Cinn/17.1Xfce

If solved please edit the subject line of your first post to include [Solved] so other users know there's a solution in the topic.

GNU Terry Pratchett

User avatar
WinterTroubles
Level 6
Level 6
Posts: 1474
Joined: Fri Apr 11, 2014 6:25 am
Location: UK

Re: Flash Not Working in Chromium Browser

Post by WinterTroubles » Wed May 21, 2014 4:48 pm

In this topic http://forums.linuxmint.com/viewtopic.php?f=90&t=167863 the problem of no flash in chrome when installed from the repositories was solved ny installing from the chrome website, I understand that many wish to use chromium and not chrome, but, this does suggest that possibly the current plugin versions in the repositories simply don't work in the new 'aura' versions of chrome and chromium and it may be a case of having to wait until the plugin versions in the repositories get updated. If this is the case then it is obviously unaceptable, as is an update that changes something as major as the introduction of a new code base without prior notification :|
17.1Cinn/17.1Xfce

If solved please edit the subject line of your first post to include [Solved] so other users know there's a solution in the topic.

GNU Terry Pratchett

User avatar
tdockery97
Level 14
Level 14
Posts: 5064
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon
Contact:

Re: Flash Not Working in Chromium Browser

Post by tdockery97 » Wed May 21, 2014 4:55 pm

I am able to install and use pepperflash in Chromium, but the plugin disappears periodically. If I go to Synaptic and select to reinstall pepperflash-plugin, then it reappears and works in Chromium. I think I'll have to go back to Google Chrome, but it seems buggy lately. If it continues then I may leave Cinnamon and return to MATE, as I had no problems there.
Peppermint OS 9

User avatar
WinterTroubles
Level 6
Level 6
Posts: 1474
Joined: Fri Apr 11, 2014 6:25 am
Location: UK

Re: Flash Not Working in Chromium Browser

Post by WinterTroubles » Wed May 21, 2014 5:05 pm

tdockery97

In my research over the last 24hrs I have come across mention of pepperflash working immediately after install, for some people with the new 'aura' version, but, the plugin being absent next time they either booted or restarted their browser (unclear which, possibly both). Downloading chrome from chrome may be the only option untill this issue is sorted out with both chrome and chromium. I originally installed from chrome direct and have seen none of the issues with plugins that others have seen when installed from the repositories.

For reference I'm running 64bit mint petra cinnamon.
17.1Cinn/17.1Xfce

If solved please edit the subject line of your first post to include [Solved] so other users know there's a solution in the topic.

GNU Terry Pratchett

User avatar
tdockery97
Level 14
Level 14
Posts: 5064
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon
Contact:

Re: Flash Not Working in Chromium Browser

Post by tdockery97 » Wed May 21, 2014 7:39 pm

After going back to Chrome, I still continued to have partial browser crashes relating to flash. I gave up and reinstalled Mint 17 MATE RC and Chrome is working perfectly. I feel like MATE is a more stable base for me, especially if I'm going to be using this LTS for the next 2 to 5 years.
Peppermint OS 9

User avatar
WinterTroubles
Level 6
Level 6
Posts: 1474
Joined: Fri Apr 11, 2014 6:25 am
Location: UK

Re: Flash Not Working in Chromium Browser

Post by WinterTroubles » Wed May 21, 2014 7:47 pm

Thats good news at least as I'm considering switching from cinnamon to mate when 17 hits final.
17.1Cinn/17.1Xfce

If solved please edit the subject line of your first post to include [Solved] so other users know there's a solution in the topic.

GNU Terry Pratchett

WilhelmGGW
Level 1
Level 1
Posts: 39
Joined: Mon May 12, 2014 6:07 pm

Re: Flash Not Working in Chromium Browser

Post by WilhelmGGW » Thu May 22, 2014 8:14 am

Maybe someone will get it fixed in Cinnamon before that happens. One HAS to think that's important to the developers!

obsidian_razor
Level 1
Level 1
Posts: 22
Joined: Thu May 22, 2014 7:56 am

Re: Flash Not Working in Chromium Browser

Post by obsidian_razor » Thu May 22, 2014 8:16 am

I'm having the exact same problem.

Has anyone been able to figure out a solution? It's very annoying :(

Thanks.

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Flash Not Working in Chromium Browser

Post by austin.texas » Thu May 22, 2014 10:06 am

I have been searching for the solution for many days and many hours, as you can see from this link -
http://code.google.com/p/chromium/issue ... ?id=373801

It is annoying. Videos always fail in Chrome and chromium, but play in VLC and the Seamonkey browser - so I might just have to switch to Seamonkey.

By the way, I just booted the Mint 16 Mate DVD, installed chromium (to ram) and the youtube video crashed. It also crashed in K-Ubuntu 14.04.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

ejazzkatt
Level 4
Level 4
Posts: 201
Joined: Sat Nov 30, 2013 10:03 am

Re: Flash Not Working in Chromium Browser

Post by ejazzkatt » Thu May 22, 2014 10:13 am

I don't know what the difference is between the Chrome Browser and the Chromium Browser but I also had problems with flash in the Chromium Browser. I installed the Chrome Browser based on some advice I saw here and flash works fine.

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Flash Not Working in Chromium Browser

Post by austin.texas » Thu May 22, 2014 10:29 am

ejazzkatt wrote:I don't know what the difference is between the Chrome Browser and the Chromium Browser but I also had problems with flash in the Chromium Browser. I installed the Chrome Browser based on some advice I saw here and flash works fine.
Mint 13? Mint 16?
Cinnamon? Mate?
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

ejazzkatt
Level 4
Level 4
Posts: 201
Joined: Sat Nov 30, 2013 10:03 am

Re: Flash Not Working in Chromium Browser

Post by ejazzkatt » Thu May 22, 2014 11:53 am

Mint 13. Sorry, I should have mentioned that.

pierre62
Level 1
Level 1
Posts: 10
Joined: Mon Jul 01, 2013 8:14 am

Re: Flash Not Working in Chromium Browser

Post by pierre62 » Thu May 22, 2014 5:16 pm

Someone already gave the answer in release post:

temp fix is to make this, at each boot....

Code: Select all

 sudo update-pepperflashplugin-nonfree --install
Hopefully, that will be fixed soon...

MyRay
Level 1
Level 1
Posts: 25
Joined: Tue May 20, 2014 7:54 pm
Location: USA

Re: Flash Not Working in Chromium Browser

Post by MyRay » Thu May 22, 2014 5:21 pm

Im in Chrome, running a flash game for the past few hours had no problem so far
I have mint 17 cinnamon
cant get the waterfox installed in wine, so was thinking of dl'g chromium, maybe i'll wait a few days ;)
Linux Mint 17 "Qiana" Cinnamon on Toshiba Satellite P855-S5200 Core i7 8GB DDR3 64-bit

Post Reply

Return to “Software & Applications”