WORKSFORME: Firefox keeps asking for quit confirmation

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
VinzC

WORKSFORME: Firefox keeps asking for quit confirmation

Post by VinzC » Wed May 28, 2014 10:26 am

Hi all.

I installed Mint Petra (x86_64 ) on my laptop and I noticed Firefox (the problem started with FF as of version 28, which was available when I installed Mint) doesn't remember to not confirm when I quit and there are multiple tabs open. I can tick the box, it keeps asking for a confirmation. I have already asked the question in Mozillazine but there hasn't been any sign of the beginning of a clue where to start looking. All I can say is that I have Firefox 28 on a Gentoo (amd64) machine and the problem does not occur there. It looks like a Linux-Mint/Ubuntu-Specific issue. But I haven't tried Ubuntu.

EDIT: Here's the topic on Mozillazine

Does anyone have a clue?

P.S.: I can always ask the question in Mozilla community forum but I'm afraid we spend time only to come to the conclusion I should ask Mint support since it happens only here. Hence my post.

EDIT: Thanks a lot to niowluka, Mint maintainers have added a global settings file (didn't even know it was possible!) /usr/lib/firefox/browser/defaults/preferences/vendor-firefox.js. I edited that file and commented out the line that sets browser.showQuitWarning to true. Now I can finally close Firefox without the hassle of a bloody confirmation box!
Last edited by VinzC on Sat Jun 07, 2014 4:30 am, edited 4 times in total.

User avatar
karlchen
Level 20
Level 20
Posts: 11074
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: PBM: Firefox keeps asking for quit confirmation

Post by karlchen » Wed May 28, 2014 1:49 pm

Hello, VinzC.

about:config in Firefox might be your friend:

Suspected options which may have influence:
+ browser.ShowQuitWarning - type Boolean - default value: True - you might try setting it to False
+ brwoser.tabs.WarnOnClose - type Boolean - default value: True - you might try setting it to False
+ browser.warnOnQuit - type Boolean - default value: True - you might try setting it to False

Kind regards,
Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.22a 64-bit
Windows? - 1 window in every room

VinzC

Re: PBM: Firefox keeps asking for quit confirmation

Post by VinzC » Wed May 28, 2014 4:09 pm

karlchen wrote:Hello, VinzC.

about:config in Firefox might be your friend[...]
Thanks Karl. Yeah, forgot to tell, that's what I've been hinted to on Mozillazine's forum. Didn't change anything. In fact it also happens with a blank user profile (read: create a user account in Linux Mint, log on, run firefox, open two tabs, close, check "Don't ask" and quit; run FF again, open two tabs and close: will ask confirmation).

VinzC

Re: PBM: Firefox keeps asking for quit confirmation

Post by VinzC » Fri May 30, 2014 7:30 am

It's definitely a Linux Mint specific issue. I did another installation of Mint 16 (Xfce) on another machine and the problem occurs there too.

VinzC

Re: UNSOLVED: Firefox keeps asking for quit confirmation

Post by VinzC » Wed Jun 04, 2014 1:47 pm

:evil: Heck! Am I the only one whom it happens? I cannot believe it! It happens with ALL ISO I've downloaded from Linux Mint if I run these inside a Qemu virtual machine. Means the problem WILL persist upon installation...

User avatar
eanfrid
Level 7
Level 7
Posts: 1859
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: UNSOLVED: Firefox keeps asking for quit confirmation

Post by eanfrid » Wed Jun 04, 2014 1:54 pm

You are no alone but... Once I did solve this problem, I did not write down exactly what I did. IIRC it has to do with in which order you setup the confirmation options via "about:config". I did not meet this problem since with other installations, however. Then I am not very helpful :(

Edit: I created a new firefox profile in order to test and it looks like that setting only "browser.tabs.WarnOnClose" to "false" makes the deal.
Main desktop: Debian GNU/Linux Jessie 64bit - MATE
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox

VinzC

Re: UNSOLVED: Firefox keeps asking for quit confirmation

Post by VinzC » Wed Jun 04, 2014 2:26 pm

eanfrid wrote:Then I am not very helpful :(
Oh but you are! Actually I started to believe nobody cares and it's just me and my bad luck that strike again so yes, you're helping. Thanks for the insight. That gives me some more crumbs to follow.

EDIT: And what you're saying is higly interesting. Given that I don't have that issue on Gentoo and it's the very same version of firefox that does that on Mint, I've come to the deduction compile-time optimizations might be responsible for changing the order of the operations that result from checking the "confirmation" box. Don't know if I'm making sense but I once thought of replacing Firefox binary in Mint with that on Gentoo. It didn't make much sense to me until now that I read your post.

niowluka
Level 5
Level 5
Posts: 730
Joined: Tue May 27, 2014 6:28 pm
Location: Krakow, Poland

Re: UNSOLVED: Firefox keeps asking for quit confirmation

Post by niowluka » Wed Jun 04, 2014 3:25 pm

browser.warnOnQuit false

EDIT

Sheesh ! Now Mint devs are really insisting on saving those tabs on exit ! :mrgreen:

There are 2 settings in Firefox:
browser.warnOnQuit - this toggles a warning on exit: false means no warning, true means one of the below:
browser.showQuitWarning - if this is true, the 'save tabs' window pops up; when this is false, a simple 'confirm you're closing N (where N>1) tabs' pops up, which is my preffered behaviour

I noticed that the latter gets reset every time I restart Firefox, regardless of whether I change it in about:config, or manually in prefs.js file. It turned out, this setting is set to true in:

/usr/lib/firefox/browser/defaults/preferences/vendor-firefox.js

... and overwrites your personal settings every time Firefox is restarted !! After a few trial and fails what I did was manually update that file and comment out the setting. I also changed it in prefs.js file while Firefox was not running. Now I get my coveted 'confirm' window. I also run 'chattr -i' on the default file for a good measure, in case I upgrade Firefox...

P.S. Suggestion: can that setting be removed from the default settings file ? I am going to take a wild guess someone left it by mistake, because I really do not see any justification in forcing this behaviour. Also thanks to VinzC, karlchen and eanfrid for leading me on to this.
Mint 17 Openbox (MATE) 64bit | Linux 4.1.6 (Vanilla)

Gigabyte GA-880GA-UD3H | AMD Phenom II X4 965 3.4Ghz | G.Skill 8GB DDR3-1600 RipjawsX, F3-12800CL8D-8GBXM | MSI R7 260X 2048 MB GDDR5 OC

VinzC

Re: UNSOLVED: Firefox keeps asking for quit confirmation

Post by VinzC » Fri Jun 06, 2014 11:16 am

niowluka wrote:browser.warnOnQuit false

EDIT

Sheesh ! Now Mint devs are really insisting on saving those tabs on exit ! :mrgreen:

There are 2 settings in Firefox:
browser.warnOnQuit - this toggles a warning on exit: false means no warning, true means one of the below:
browser.showQuitWarning - if this is true, the 'save tabs' window pops up; when this is false, a simple 'confirm you're closing N (where N>1) tabs' pops up, which is my preffered behaviour

I noticed that the latter gets reset every time I restart Firefox, regardless of whether I change it in about:config, or manually in prefs.js file. It turned out, this setting is set to true in:

/usr/lib/firefox/browser/defaults/preferences/vendor-firefox.js

... and overwrites your personal settings every time Firefox is restarted !! After a few trial and fails what I did was manually update that file and comment out the setting. I also changed it in prefs.js file while Firefox was not running. Now I get my coveted 'confirm' window. I also run 'chattr -i' on the default file for a good measure, in case I upgrade Firefox...

P.S. Suggestion: can that setting be removed from the default settings file ? I am going to take a wild guess someone left it by mistake, because I really do not see any justification in forcing this behaviour. Also thanks to VinzC, karlchen and eanfrid for leading me on to this.
OMG! You've made my day!

Will change that and hopefully I can stop pesting against firefox! [It's been annoying me for more than 6 months now!]

Thanks a zillion times!

stmcmurray
Level 1
Level 1
Posts: 9
Joined: Sun Mar 30, 2014 6:13 pm

Re: UNSOLVED: Firefox keeps asking for quit confirmation

Post by stmcmurray » Fri Jun 06, 2014 8:50 pm

I too have had this problem since mint16. I have tried every method mentioned above and none seem to work.
If only one tab is open, it does not ask.
If two or more tabs are open, it asks every time.
The best solution I found that works is just answer 'save and quit', with the "Do Not Ask Again" box checked.
Now it does not ask, and I've found it's not so bad opening the last tabs you were on.
Hope this info will help get you by until a fix is found.
I have also had many problems with automatic logins, including this forum.
Firefox does not log me in automatically on most site I visit. The one it does, all of a sudden won't about once a week.
I don't mean to thread jack, but since I believe,it too, is a Firefox issue, maybe someone has some imput.

VinzC

Re: UNSOLVED: Firefox keeps asking for quit confirmation

Post by VinzC » Sat Jun 07, 2014 4:09 am

stmcmurray wrote:I too have had this problem since mint16. I have tried every method mentioned above and none seem to work.
If only one tab is open, it does not ask.
If two or more tabs are open, it asks every time.
The best solution I found that works is just answer 'save and quit', with the "Do Not Ask Again" box checked.
Now it does not ask, and I've found it's not so bad opening the last tabs you were on.
Hope this info will help get you by until a fix is found.
Thanks to niowluka, I checked my Gentoo installation and there is absolutely NO such file as /usr/lib/firefox/browser/defaults/preferences/vendor-firefox.js which means you can safely delete it (being root of course).
stmcmurray wrote:I have also had many problems with automatic logins, including this forum.
Firefox does not log me in automatically on most site I visit. The one it does, all of a sudden won't about once a week.
I don't mean to thread jack, but since I believe,it too, is a Firefox issue, maybe someone has some imput.
That, I know, has to do with site cookies. If you delete *all* cookies (not just the recent ones) related to the sites you have troubles with and delete the browser cache completely it should work again. Also check if you have a privacy enforcer extension like noscript, adblock, EFF privacy checker aso. Maybe also if you delete the global settings file from firefox shared directory it'll have a positive impact. Don't hesitate to share your findings.

User avatar
Flemur
Level 17
Level 17
Posts: 7008
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: WORKSFORME: Firefox keeps asking for quit confirmation

Post by Flemur » Sat Jun 07, 2014 10:26 am

I noticed that the latter gets reset every time I restart Firefox, regardless of whether I change it in about:config, or manually in prefs.js file. It turned out, this setting is set to true in:
/usr/lib/firefox/browser/defaults/preferences/vendor-firefox.js


I'm using FF 24 ESR on Mint 16 and have never had the problems mentioned in this thread - I also DON'T have the file above, probably because FF wasn't installed via Mint (got it from https://ftp.mozilla.org/pub/mozilla.org ... /releases/, extracted into an empty /usr/lib/firefox directory); in fact I don't have the /usr/lib/firefox/browser/defaults directory at all:

Code: Select all

/usr/lib/firefox/browser : ls -a
.              chrome           crashreporter-override.ini  omni.ja
..             chrome.manifest  extensions                  searchplugins
blocklist.xml  components       icons
So perhaps try renaming that unnecessary directory to something else, then try FF.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

niowluka
Level 5
Level 5
Posts: 730
Joined: Tue May 27, 2014 6:28 pm
Location: Krakow, Poland

Re: WORKSFORME: Firefox keeps asking for quit confirmation

Post by niowluka » Sat Jun 07, 2014 11:22 am

Those are 'vendor specific' settings, i.e. Mint/Debian.

I agree with VinzC, you are safe to remove the file. Those settings have already been loaded when you first ran Firefox, no reason for them to be reloaded every single time overwriting your own preferences. Please do note however that this file will be restored everytime you update Firefox.
Mint 17 Openbox (MATE) 64bit | Linux 4.1.6 (Vanilla)

Gigabyte GA-880GA-UD3H | AMD Phenom II X4 965 3.4Ghz | G.Skill 8GB DDR3-1600 RipjawsX, F3-12800CL8D-8GBXM | MSI R7 260X 2048 MB GDDR5 OC

User avatar
tonywhelan
Level 1
Level 1
Posts: 32
Joined: Sun Jun 10, 2012 10:47 pm
Location: Canberra, Australia

Re: WORKSFORME: Firefox keeps asking for quit confirmation

Post by tonywhelan » Tue Jun 10, 2014 6:06 pm

Thanks folks for this information, the "save" prompt was driving me nuts but this advice fixed the problem nicely.

rhish
Level 1
Level 1
Posts: 4
Joined: Fri Jul 18, 2014 1:32 pm

Re: WORKSFORME: Firefox keeps asking for quit confirmation

Post by rhish » Sun Jul 20, 2014 5:02 pm

omg this is life saver.

This "feature" bothers me so much. And now I can rip it out of existence forever.

Thanks for doing the research for a Fix!!

VinzC

Re: WORKSFORME: Firefox keeps asking for quit confirmation

Post by VinzC » Wed Sep 17, 2014 10:23 am

Just an update to this chapter: with this fix I can no longer close multiple tabs, like "Close every other tab". This is a minor issue however and I can live with it since I'm no longer asked to confirm when I close the browser. "Partially solved" I'd say. Still, no such issue under Gentoo but there's no such global configuration file either.

AL1000
Level 1
Level 1
Posts: 10
Joined: Sun May 11, 2014 1:09 pm

Re: WORKSFORME: Firefox keeps asking for quit confirmation

Post by AL1000 » Tue Jan 06, 2015 6:06 am

Here is a (hopefully) permanent fix.

Ignore /usr/lib/firefox/browser/defaults/preferences/vendor-firefox.js

...and instead add the line:

Code: Select all

pref("browser.warnOnQuit", false);
to:

/etc/firefox/syspref.js

... and you shouldn't get any warning messages when closing Firefox with multiple tabs open again.
Mint 13 MATE

1.618
Level 5
Level 5
Posts: 590
Joined: Fri Jun 06, 2014 9:22 am
Location: Surfing a multidimensional wave of celestial intent
Contact:

Re: WORKSFORME: Firefox keeps asking for quit confirmation

Post by 1.618 » Tue Jan 06, 2015 6:30 am

About:config

browser.tabs.warnOnClose = false

browser.tabs.warnOnCloseOtherTabs = false

browser.WarnonQuit = False

browser.ShowQuitWarning = False



these 4 sorted it out for me

VinzC

Re: WORKSFORME: Firefox keeps asking for quit confirmation

Post by VinzC » Tue Jan 06, 2015 7:41 am

1.618 wrote:About:config

Code: Select all

browser.tabs.warnOnClose = false 
browser.tabs.warnOnCloseOtherTabs = false
browser.WarnonQuit = False
browser.ShowQuitWarning = False
these 4 sorted it out for me
That was the point: at the time of my post, it didn't work for me although it did for a number of us, users. So that definitely is not *the* fix.

Post Reply

Return to “Software & Applications”