[SOLVED] Qiana with unresolvable gedit dependencies

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
random_jc
Level 1
Level 1
Posts: 36
Joined: Sun Jun 01, 2014 10:30 am

[SOLVED] Qiana with unresolvable gedit dependencies

Post by random_jc » Sun Jun 01, 2014 10:49 am

Hi,

I've just installed (from scratch) the freshly released Qiana Cinnamon. It looks really great, but I'm struggling when I try to install some packages associated with gedit. If I try to install the package "gedit-plugins" (from the synaptic package manager or apt-get), I get the following message.

"The following packages have unresolvable dependencies. Make sure that all required repositories are added and enabled in the preferences.

gedit-plugins:
Depends: libgucharmap7 (>= 1:2.24.0) but it is not installable"

A similar (but longer) error message appears if I try to install, say, "gedit-latex-plugin". I guess there's a depository that I should add, but I cannot find which. Any idea?

Thanks a lot
Jc

EDIT: Xenopeek's solution made it all work nicely:

Code: Select all

apt purge gedit gedit-common
apt install gedit/trusty gedit-common/trusty
apt install gedit-plugins/trusty
Last edited by random_jc on Mon Jun 02, 2014 3:56 am, edited 1 time in total.

User avatar
xenopeek
Level 24
Level 24
Posts: 22897
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: new Qiana install with unresolvable dependencies

Post by xenopeek » Sun Jun 01, 2014 11:05 am

gedit-plugins is for Gedit version 3.x. Linux Mint installs Gedit version 2.x by default. Those don't go together. You have two options:

1> Install the gedit-plugins and other required packages for Gedit version 2.x. I have them added here: http://forums.linuxmint.com/viewtopic.p ... 58#p788466

2> Remove Gedit version 2.x and install Gedit version 3.x. It is going to quite different though. To do this run the following two commands on the terminal (this is specific for Linux Mint 17.x and doesn't work on older or newer releases!):

Code: Select all

apt purge gedit gedit-common
apt install gedit/trusty gedit-common/trusty
After that you should be able to install gedit-plugins also.
Image

pjhoyer
Level 1
Level 1
Posts: 4
Joined: Sun Jun 01, 2014 1:52 pm

Re: new Qiana install with unresolvable dependencies

Post by pjhoyer » Sun Jun 01, 2014 2:02 pm

E: Utgave «trusty» av «gedit-common» ble ikke funnet
means as much as trusty /geditcommon not found =(
som idea why :roll:

User avatar
xenopeek
Level 24
Level 24
Posts: 22897
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: new Qiana install with unresolvable dependencies

Post by xenopeek » Sun Jun 01, 2014 3:16 pm

pjhoyer wrote:E: Utgave «trusty» av «gedit-common» ble ikke funnet
means as much as trusty /geditcommon not found =(
som idea why :roll:
And are you using Linux Mint 17? Did you type the command exactly as above (preferably using copy & paste)? Any errors here are yours I think. Running the command "apt-cache policy gedit-common" returns nicely:

Code: Select all

gedit-common:
  Installed: 2.30.5+qiana
  Candidate: 2.30.5+qiana
  Version table:
     3.10.4-0ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
 *** 2.30.5+qiana 0
        700 http://packages.linuxmint.com/ qiana/upstream amd64 Packages
        100 /var/lib/dpkg/status
As in, gedit-common/qiana is installed and gedit-common/trusty is also available.

Tip for future: commands that you want to share the output of, please run those in English instead of your native language. You can do so by prefixing the command with "LC_ALL=C". As for example with the install command from above:

Code: Select all

LC_ALL=C apt install gedit/trusty gedit-common/trusty
Image

random_jc
Level 1
Level 1
Posts: 36
Joined: Sun Jun 01, 2014 10:30 am

Re: new Qiana install with unresolvable dependencies

Post by random_jc » Sun Jun 01, 2014 3:55 pm

thanks a lot Xenopeek for the quick answer. I ran the commands that you gave, which indeed installed Gedit 3.10.4. Then I successfully installed gedit-latex-plugin. But surprisingly, the package "gedit-plugins" itself still results in a bug, now reading

gedit-plugins : Depends: libgucharmap7 (>= 1:2.24.0) but it is not installable
Depends: gedit (>= 2.25.4) but it is not going to be installed

Any more ideas?

User avatar
xenopeek
Level 24
Level 24
Posts: 22897
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: new Qiana install with unresolvable dependencies

Post by xenopeek » Sun Jun 01, 2014 5:08 pm

Seems some more changes were done between 16 and 17... :oops: gedit-plugins is available both as the qiana version and as the trusty version. To install it for the newer version of Gedit that you now have, specifically install the trusty version:

Code: Select all

apt install gedit-plugins/trusty
Image

pjhoyer
Level 1
Level 1
Posts: 4
Joined: Sun Jun 01, 2014 1:52 pm

Re: new Qiana install with unresolvable dependencies

Post by pjhoyer » Sun Jun 01, 2014 5:12 pm

the failure was mine I had a corrupt installation. :oops:

random_jc
Level 1
Level 1
Posts: 36
Joined: Sun Jun 01, 2014 10:30 am

Re: new Qiana install with unresolvable dependencies

Post by random_jc » Mon Jun 02, 2014 3:54 am

Thanks a lot, this made it all work nicely. Gedit is an application I spend several hours per day working with, so your help really makes a difference. In case this sort of problem happens again, is there a relatively easy way for me to figure out what I should do by myself ?

User avatar
xenopeek
Level 24
Level 24
Posts: 22897
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: [SOLVED] Qiana with unresolvable gedit dependencies

Post by xenopeek » Mon Jun 02, 2014 4:35 am

apt-cache is your friendly investigative tool, usually giving clues but I guess it takes some experience to interpret. Perhaps there is an easier way, but I usually just use

Code: Select all

apt-cache policy packagename
and

Code: Select all

apt-cache show packagename
The first shows the installed and available versions of 'packagename'. The second shows details of 'packagename', like dependencies and such. See the manual aka manpage (man apt-cache) for more information.
Image

rbs
Level 1
Level 1
Posts: 5
Joined: Thu Jul 26, 2012 5:27 pm

Re: [SOLVED] Qiana with unresolvable gedit dependencies

Post by rbs » Tue Sep 16, 2014 9:42 pm

xenopeek - this is slightly off topic, but thanks so much for saving the gedit 2.x plugins (http://forums.linuxmint.com/viewtopic.p ... 58#p788466)

I had tried and tried to get the Session Saver plugin working with gedit 3.x but never could. It's still in the 2.x package and still works. And apt-cache, which I didn't know about, is both cool and useful.

Thanks again,

Randall

Post Reply

Return to “Software & Applications”