Page 1 of 1

Cannot install k3b "You have held broken packages"

Posted: Thu Jul 03, 2014 10:11 am
by sdim
Hi, everyone.
I'm trying to install k3b on Mint Qiana but in Terminal and Synaptic I get this message:

Code: Select all

E: Unable to correct problems, you have held broken packages.
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
I've tried solutions online but the problem remains.
Any ideas?

Re: Cannot install k3b "You have held broken packages"

Posted: Thu Jul 03, 2014 10:13 am
by WinterTroubles
Several topics on the same subject.. there is another one here http://forums.linuxmint.com/viewtopic.php?f=47&t=172179

Re: Cannot install k3b "You have held broken packages"

Posted: Thu Jul 03, 2014 10:23 am
by sdim
Many thanks.
There seems to be a problem with Kernel 3.13.2. Should I go back to 3.13?

Re: Cannot install k3b "You have held broken packages"

Posted: Thu Jul 03, 2014 10:32 am
by WinterTroubles
I've absolutely no idea, sorry, as I'm too much of a newbie.. Zero zero, in the other topic, seems to think that it may be a case of not all the updated files having arrived on the server yet, if I understand his post correctly, so maybe just wait a while and then refresh the updater to see if there are any further updates.

I really don't know enough to offer reliable advice though, sorry.

Re: Cannot install k3b "You have held broken packages"

Posted: Thu Jul 03, 2014 10:42 am
by sdim
Thank you for your help, my friend.
Lte me correct my previous post, I have Kernel 3.13.0.24 installed, so maybe I'll wait along with everyone else.

Re: Cannot install k3b "You have held broken packages"

Posted: Thu Jul 03, 2014 10:51 am
by WinterTroubles
:oops: I may have made an error in assuming your issue was the same as those with the update problem.. unless of course you have applied an update related to KDE today. I just tried installing K3B on my mint 17 Cinn 32bit and it installed just fine. That either means that the servers have been updated since you last tried.. or that I made a poor assumption, if it's the latter I apologise. If it is something other that the servers needing updating then I afraid I don't know enough to attempt a fix, sorry.

Re: Cannot install k3b "You have held broken packages"

Posted: Thu Jul 03, 2014 12:29 pm
by sdim
k3b installed fine on my machine as well, my friend, a few minutes ago.
Maybe the assumption that it was a server thing was right.
Thank you for the help, anyway.

Re: Cannot install k3b "You have held broken packages"

Posted: Thu Jul 03, 2014 12:49 pm
by WinterTroubles
WOW.. I made an assumption that turned out to be correct :shock: :lol:

Glad it's all sorted now :D