power manager icon does not show up in systray

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
hpmital
Level 1
Level 1
Posts: 22
Joined: Fri Oct 25, 2013 3:00 am
Location: Sydney or New Delhi

power manager icon does not show up in systray

Post by hpmital » Sun Jul 20, 2014 4:38 am

I am using Linux Mint Qiana. The power manager applet icon, which would normally show the battery charge percentage, does not show up in the system tray area. When I go to the applet configuration, and press the 'highlight' button, a white square spot shows up momentarily in the systray area somewhere where other icons are present. Can anyone please help in fixing this?

User avatar
PatH57
Level 13
Level 13
Posts: 4576
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: power manager icon does not show up in systray

Post by PatH57 » Sun Jul 20, 2014 4:43 am

how did you install the applet and what themes are you using?
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

hpmital
Level 1
Level 1
Posts: 22
Joined: Fri Oct 25, 2013 3:00 am
Location: Sydney or New Delhi

Re: power manager icon does not show up in systray

Post by hpmital » Sun Jul 20, 2014 6:54 am

I am using Linux Mint theme. The applet was installed by default. I reinstalled it by System Settings-Preferences- Applets- Restore to defaults. Against Power Manager I can see a lock and a green dot.

Hari P Mital

hpmital
Level 1
Level 1
Posts: 22
Joined: Fri Oct 25, 2013 3:00 am
Location: Sydney or New Delhi

Re: power manager icon does not show up in systray

Post by hpmital » Sun Jul 20, 2014 7:20 am

On further chacking, I find that when I click the mouse over the panel, where the power icon is meant to be (but is not visible), the label 'power settings' shows up. On further clicking, I find that the Pwer Management screen opens up, but under the heading "Battery", it is all blank.

Hari P Mital

hpmital
Level 1
Level 1
Posts: 22
Joined: Fri Oct 25, 2013 3:00 am
Location: Sydney or New Delhi

Re: power manager icon does not show up in systray

Post by hpmital » Fri Aug 15, 2014 12:24 am

The problem was apparently being caused by inappropriate driver for display hardware (Geforce 720M on my laptop). As shown by the driver manager, driver in use was the one shown as 'recommended' - it was nvidia-331(version 331.38-Oubuntu 7.1). Also shown in the list was nvidia-331(version 331.38-Oubuntu 7.1) updates, but using that also did not help. Finally, I had to reinstall Mint Qiana. During re-installation, the system automatically picked up drivers, which solved the problem. But the driver manager now shows the driver in use as xserver-xorg-video-nouveau, which is not marked as recommended. May be, it means that Mint 17 as it stands cannot make use of the nvidia geforce 720M hardware using nvidia drivers.

User avatar
PatH57
Level 13
Level 13
Posts: 4576
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: power manager icon does not show up in systray

Post by PatH57 » Fri Aug 15, 2014 3:02 am

May be, it means that Mint 17 as it stands cannot make use of the nvidia geforce 720M hardware using nvidia drivers
Doubt this would be the case as many people are using it and it would not affect an applet in this way, also the power management sensors are different then the graphic card drivers.
Something must have gone wrong when you decided to change drivers the first time or some settings you used may have affected the display of the applet...
Anyway glad it works now.
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

zippytex
Level 2
Level 2
Posts: 57
Joined: Mon Jul 11, 2011 3:22 pm

Re: power manager icon does not show up in systray

Post by zippytex » Tue Apr 21, 2015 9:58 pm

I calibrated the battery and now the battery icon does not show up in the panel. How can I get the applet to work. The applet shows a lock and green dot. Thanks, Mary The battery on my macbook shows 5 lights which is good. I have never had this problem before.

Post Reply

Return to “Software & Applications”