Precise repository failure on Mint 13 Maya

Questions about applications and software
Forum rules
Before you post please read how to get help
phoenix1963
Level 2
Level 2
Posts: 66
Joined: Tue Mar 27, 2012 3:47 pm

Precise repository failure on Mint 13 Maya

Post by phoenix1963 » Sat Oct 04, 2014 4:49 am

Does anyone know why I get the following when I try to update:

Code: Select all

Failed to fetch http://archive.canonical.com/ubuntu/dists/precise/partner/binary-amd64/Packages  404  Not Found [IP: 91.189.92.191 80]
Failed to fetch http://archive.canonical.com/ubuntu/dists/precise/partner/binary-i386/Packages  404  Not Found [IP: 91.189.92.191 80]
phoenix1963

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Precise repository failure on Mint 13 Maya

Post by austin.texas » Sat Oct 04, 2014 7:10 am

Please post the result of

Code: Select all

inxi -r
deb http://archive.canonical.com/ubuntu/ precise partner
should be all you need from canonical
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

phoenix1963
Level 2
Level 2
Posts: 66
Joined: Tue Mar 27, 2012 3:47 pm

Re: Precise repository failure on Mint 13 Maya

Post by phoenix1963 » Sat Oct 04, 2014 7:19 am

Hi austin,

Code: Select all

Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ maya main upstream import
           deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ precise partner
           Active apt sources in file: /etc/apt/sources.list.d/brandonsnider-cdrtools-precise.list
           deb http://ppa.launchpad.net/brandonsnider/cdrtools/ubuntu precise main
           deb-src http://ppa.launchpad.net/brandonsnider/cdrtools/ubuntu precise main
           Active apt sources in file: /etc/apt/sources.list.d/crass-ufraw-precise.list
           deb http://ppa.launchpad.net/crass/ufraw/ubuntu precise main
           deb-src http://ppa.launchpad.net/crass/ufraw/ubuntu precise main
           Active apt sources in file: /etc/apt/sources.list.d/ingo-ios7support-precise.list
           deb http://ppa.launchpad.net/ingo/ios7support/ubuntu precise main
           deb-src http://ppa.launchpad.net/ingo/ios7support/ubuntu precise main
           Active apt sources in file: /etc/apt/sources.list.d/nilarimogard-webupd8-precise.list
           deb http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu precise main
           deb-src http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu precise main
           Active apt sources in file: /etc/apt/sources.list.d/oibaf-graphics-drivers-precise.list
           deb http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu precise main
           deb-src http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu precise main
           Active apt sources in file: /etc/apt/sources.list.d/otto-kesselgulasch-gimp-precise.list
           deb http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu precise main
           deb-src http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu precise main
           Active apt sources in file: /etc/apt/sources.list.d/pmjdebruijn-darktable-release-precise.list
           deb http://ppa.launchpad.net/pmjdebruijn/darktable-release/ubuntu precise main
           deb-src http://ppa.launchpad.net/pmjdebruijn/darktable-release/ubuntu precise main
           Active apt sources in file: /etc/apt/sources.list.d/webupd8team-java-precise.list
           deb http://ppa.launchpad.net/webupd8team/java/ubuntu precise main
           deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu precise main
A fairly straightforward set I think.
Oddly, if I use a browser to look at http://archive.canonical.com/ubuntu/dis ... 6/Packages the packages seem there as gz files.

phoenix1963

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Precise repository failure on Mint 13 Maya

Post by austin.texas » Sat Oct 04, 2014 7:55 am

Everything looks OK so I cannot explain the error.
Maybe the server was temporarily busy?
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

phoenix1963
Level 2
Level 2
Posts: 66
Joined: Tue Mar 27, 2012 3:47 pm

Re: Precise repository failure on Mint 13 Maya

Post by phoenix1963 » Sat Oct 04, 2014 8:07 am

austin.texas wrote:Maybe the server was temporarily busy?
I don't think so, I've been getting this ever since early September, with one successful update a few days ago. Very odd.

I've been having slightly odd dns issues, but unrelated as this one is the server replying that it can't find the files.

phoenix1963

phoenix1963
Level 2
Level 2
Posts: 66
Joined: Tue Mar 27, 2012 3:47 pm

Re: Precise repository failure on Mint 13 Maya

Post by phoenix1963 » Sat Oct 04, 2014 8:13 am

Just to correct what I wrote earlier:
Oddly, if I use a browser to look at the parent directory http://archive.canonical.com/ubuntu/dis ... nary-i386/ the packages seem there as gz files.

But I know nothing about the format of repositories.

phoenix1963

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Precise repository failure on Mint 13 Maya

Post by austin.texas » Sat Oct 04, 2014 8:16 am

There is nothing wrong there - that is the default.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

phoenix1963
Level 2
Level 2
Posts: 66
Joined: Tue Mar 27, 2012 3:47 pm

Re: Precise repository failure on Mint 13 Maya

Post by phoenix1963 » Sat Oct 04, 2014 8:25 am

Thanks for looking at it austin.
I'm very surprised there aren't a load of other people with the same problem, after all Mint 13 is an LTS with 2.5 years to go.

phoenix1963

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Precise repository failure on Mint 13 Maya

Post by austin.texas » Sat Oct 04, 2014 9:44 am

I just now updated my Mint 13 (32bit) on an old laptop with no errors.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

phoenix1963
Level 2
Level 2
Posts: 66
Joined: Tue Mar 27, 2012 3:47 pm

Re: Precise repository failure on Mint 13 Maya

Post by phoenix1963 » Sat Oct 04, 2014 4:46 pm

And I've just tried it again, and it fails:

Code: Select all

W: Failed to fetch http://archive.canonical.com/ubuntu/dists/precise/partner/binary-amd64/Packages  404  Not Found
W: Failed to fetch http://archive.canonical.com/ubuntu/dists/precise/partner/binary-i386/Packages  404  Not Found
I notice if I look in the repository files, it's apps like adobe reader, skype etc.
austin, maybe you could post the relevant output from "sudo apt update" so I could compare?

phoenix1963

User avatar
karlchen
Level 20
Level 20
Posts: 11066
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Precise repository failure on Mint 13 Maya

Post by karlchen » Sat Oct 04, 2014 7:09 pm

Hello, phoenix1963.

Not that it explains why you keep on getting the 2 error messages, but I have not seen any of the 2 error messages on any of my Mint 13 systems. And there are
+ Mint 13 32-bit xfce
+ Mint 13 32-bit Cinnamon
+ Mint 13 64-bit Cinnamon
They all fetch their software lists without problems and download the available updates without problems.

Which Mint 13 edition exactly are you using? 32-bit or 64-bit? Run "inxi -Sx" if you are unsure about the answer.

Kind regards,
Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.22a 64-bit
Windows? - 1 window in every room

phoenix1963
Level 2
Level 2
Posts: 66
Joined: Tue Mar 27, 2012 3:47 pm

Re: Precise repository failure on Mint 13 Maya

Post by phoenix1963 » Sun Oct 05, 2014 7:40 am

Hi Karl, I'm running Linux Mint 13 64-bit Cinnamon (inxi -Sx says Gnome).
Can anyone running Mint 13 tell me whether they have the ubuntu partner repos in /etc/apt/sources.list , like this:

Code: Select all

deb http://archive.canonical.com/ubuntu/ precise partner
I know Mint 13 is an LTS, but is that any guarantee that Partner software gets maintained? Maybe it has all vanished?

phoenix1963

phoenix1963
Level 2
Level 2
Posts: 66
Joined: Tue Mar 27, 2012 3:47 pm

Re: Precise repository failure on Mint 13 Maya

Post by phoenix1963 » Sun Oct 05, 2014 8:04 am

An additional question: how do I use apt to find which packages are being requested when I run update?

phoenix1963

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Precise repository failure on Mint 13 Maya

Post by austin.texas » Sun Oct 05, 2014 11:42 am

I booted my usb hard drive with Mint 13 64bit installed. It worked with no errors, just as my Mint 13 32bit on the laptop did.
dan@dan1 ~ $ inxi -F
System: Host: dan1 Kernel: 3.2.0-23-generic x86_64 (64 bit) Desktop: Cinnamon 1.4.0 Distro: Linux Mint 13 Maya
Machine: Mobo: Gigabyte model: GA-A75-UD4H v: x.x Bios: Award v: F2 date: 06/08/2011
etc...

Code: Select all

dan@dan1 ~ $ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ maya main upstream import
           deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ precise partner
           Active apt sources in file: /etc/apt/sources.list.d/danielrichter2007-grub-customizer-precise.list
           deb http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu precise main
           deb-src http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu precise main
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb http://dl.google.com/linux/chrome/deb/ stable main

Code: Select all

dan@dan1 ~ $ sudo apt-get update
Ign http://dl.google.com stable InRelease
Ign http://packages.linuxmint.com maya InRelease                                                                                                          
Get:1 http://dl.google.com stable Release.gpg [198 B]                                                                                                     
Get:2 http://packages.linuxmint.com maya Release.gpg [198 B]                                                                                              
Get:3 http://dl.google.com stable Release [1,347 B]                                                                                                       
Ign http://security.ubuntu.com precise-security InRelease                                                                                                 
Get:4 http://packages.linuxmint.com maya Release [18.6 kB]                                                                                                
Ign http://archive.canonical.com precise InRelease                                                                                                        
Ign http://archive.ubuntu.com precise InRelease                                                                                                    
Get:5 http://security.ubuntu.com precise-security Release.gpg [198 B]                                                         
Ign http://archive.ubuntu.com precise-updates InRelease                                                                                                   
Ign http://ppa.launchpad.net precise InRelease                                                                                             
Get:6 http://dl.google.com stable/main amd64 Packages [1,206 B]                                                                            
Get:7 http://security.ubuntu.com precise-security Release [50.7 kB]                                                                                       
Get:8 http://packages.linuxmint.com maya/main amd64 Packages [18.2 kB]                                                                                    
Hit http://archive.ubuntu.com precise Release.gpg                                                                                                         
Get:9 http://archive.canonical.com precise Release.gpg [198 B]                                                             
Get:10 http://dl.google.com stable/main i386 Packages [1,225 B]                                                            
Ign http://dl.google.com stable/main TranslationIndex                                                                      
Hit http://ppa.launchpad.net precise Release.gpg                                                                                                   
Get:11 http://packages.linuxmint.com maya/upstream amd64 Packages [10.6 kB]                                                                      
Get:12 http://packages.linuxmint.com maya/import amd64 Packages [41.3 kB]                                                                                 
Get:13 http://archive.ubuntu.com precise-updates Release.gpg [198 B]                                                                                      
Get:14 http://archive.canonical.com precise Release [7,617 B]                                                                                             
Hit http://ppa.launchpad.net precise Release                                                                                                              
Hit http://archive.ubuntu.com precise Release                                                                                                             
Get:15 http://security.ubuntu.com precise-security/main amd64 Packages [426 kB]                                                                           
Get:16 http://packages.linuxmint.com maya/main i386 Packages [18.2 kB]                                                                             
Get:17 http://archive.ubuntu.com precise-updates Release [98.7 kB]                                                                                        
Hit http://ppa.launchpad.net precise/main Sources                                                                                                         
Get:18 http://archive.canonical.com precise/partner amd64 Packages [6,039 B]                                                                              
Get:19 http://packages.linuxmint.com maya/upstream i386 Packages [10.6 kB]                                                                                
Get:20 http://packages.linuxmint.com maya/import i386 Packages [41.5 kB]                                                                                  
Hit http://ppa.launchpad.net precise/main amd64 Packages                                                                                                  
Hit http://ppa.launchpad.net precise/main i386 Packages                                                                                                   
Ign http://ppa.launchpad.net precise/main TranslationIndex                                                                                         
Get:21 http://archive.canonical.com precise/partner i386 Packages [6,907 B]                                                                        
Get:22 http://archive.canonical.com precise/partner TranslationIndex [72 B]                                                                               
Ign http://packages.linuxmint.com maya/import TranslationIndex                                                                                            
Ign http://packages.linuxmint.com maya/main TranslationIndex                                                                                              
Ign http://packages.linuxmint.com maya/upstream TranslationIndex                                                                       
Ign http://dl.google.com stable/main Translation-en_US                                                                                 
Get:23 http://archive.canonical.com precise/partner Translation-en [3,978 B]                                                                              
Ign http://dl.google.com stable/main Translation-en                                                                                                       
Hit http://archive.ubuntu.com precise/main amd64 Packages                                                                                                 
Hit http://archive.ubuntu.com precise/restricted amd64 Packages                                                                       
Hit http://archive.ubuntu.com precise/universe amd64 Packages                  
Hit http://archive.ubuntu.com precise/multiverse amd64 Packages                
Hit http://archive.ubuntu.com precise/main i386 Packages                       
Hit http://archive.ubuntu.com precise/restricted i386 Packages                 
Hit http://archive.ubuntu.com precise/universe i386 Packages                   
Hit http://archive.ubuntu.com precise/multiverse i386 Packages                 
Hit http://archive.ubuntu.com precise/main TranslationIndex                    
Hit http://archive.ubuntu.com precise/multiverse TranslationIndex              
Hit http://archive.ubuntu.com precise/restricted TranslationIndex                                    
Hit http://archive.ubuntu.com precise/universe TranslationIndex                                      
Get:24 http://archive.ubuntu.com precise-updates/main amd64 Packages [837 kB]  
Ign http://packages.linuxmint.com maya/import Translation-en_US                                                
Ign http://packages.linuxmint.com maya/import Translation-en                                            
Ign http://packages.linuxmint.com maya/main Translation-en_US                                          
Get:25 http://security.ubuntu.com precise-security/restricted amd64 Packages [4,627 B]                                       
Get:26 http://security.ubuntu.com precise-security/universe amd64 Packages [98.1 kB]                                                     
Ign http://packages.linuxmint.com maya/main Translation-en                                                                              
Ign http://ppa.launchpad.net precise/main Translation-en_US                                                     
Ign http://packages.linuxmint.com maya/upstream Translation-en_US                          
Ign http://packages.linuxmint.com maya/upstream Translation-en                             
Get:27 http://security.ubuntu.com precise-security/multiverse amd64 Packages [2,447 B]     
Get:28 http://security.ubuntu.com precise-security/main i386 Packages [458 kB]                                   
Ign http://ppa.launchpad.net precise/main Translation-en                                                         
Get:29 http://security.ubuntu.com precise-security/restricted i386 Packages [4,620 B]                                                                     
Get:30 http://security.ubuntu.com precise-security/universe i386 Packages [104 kB]                                                                        
Get:31 http://security.ubuntu.com precise-security/multiverse i386 Packages [2,638 B]                                                                     
Get:32 http://security.ubuntu.com precise-security/main TranslationIndex [74 B]                                                                           
Get:33 http://security.ubuntu.com precise-security/multiverse TranslationIndex [72 B]                                                                     
Get:34 http://security.ubuntu.com precise-security/restricted TranslationIndex [72 B]                                                                     
Get:35 http://security.ubuntu.com precise-security/universe TranslationIndex [73 B]                                                                       
Get:36 http://security.ubuntu.com precise-security/main Translation-en [194 kB]                                                                           
Hit http://security.ubuntu.com precise-security/multiverse Translation-en                                                                                 
Hit http://security.ubuntu.com precise-security/restricted Translation-en                                                                                 
Get:37 http://security.ubuntu.com precise-security/universe Translation-en [60.4 kB]                                                                      
Get:38 http://archive.ubuntu.com precise-updates/restricted amd64 Packages [13.7 kB]                                                                      
Get:39 http://archive.ubuntu.com precise-updates/universe amd64 Packages [248 kB]                                                                         
Get:40 http://archive.ubuntu.com precise-updates/multiverse amd64 Packages [15.3 kB]                                                                      
Get:41 http://archive.ubuntu.com precise-updates/main i386 Packages [868 kB]                                                                              
Get:42 http://archive.ubuntu.com precise-updates/restricted i386 Packages [13.7 kB]                                                                       
Get:43 http://archive.ubuntu.com precise-updates/universe i386 Packages [255 kB]                                                                          
Get:44 http://archive.ubuntu.com precise-updates/multiverse i386 Packages [15.5 kB]                                                                       
Get:45 http://archive.ubuntu.com precise-updates/main TranslationIndex [3,564 B]                                                                          
Get:46 http://archive.ubuntu.com precise-updates/multiverse TranslationIndex [2,605 B]                                                                    
Get:47 http://archive.ubuntu.com precise-updates/restricted TranslationIndex [2,461 B]                                                                    
Get:48 http://archive.ubuntu.com precise-updates/universe TranslationIndex [2,850 B]                                                                      
Hit http://archive.ubuntu.com precise/main Translation-en                                                                                                 
Hit http://archive.ubuntu.com precise/multiverse Translation-en                                                                                           
Hit http://archive.ubuntu.com precise/restricted Translation-en                                                                                           
Hit http://archive.ubuntu.com precise/universe Translation-en                                                                                             
Get:49 http://archive.ubuntu.com precise-updates/main Translation-en [368 kB]                                                                             
Hit http://archive.ubuntu.com precise-updates/multiverse Translation-en                                                                                   
Hit http://archive.ubuntu.com precise-updates/restricted Translation-en                                                                                   
Get:50 http://archive.ubuntu.com precise-updates/universe Translation-en [144 kB]                                                                         
Fetched 4,481 kB in 19s (233 kB/s)                                                                                                                        
Reading package lists... Done
dan@dan1 ~ $ sudo apt-get upgrade
After downloading 167MB of updates and configuring, an hour later... finished with no errors
(it was my first update since April, 2012. The Mint 13 is only there on the usb hard drive for convenience, like if I ever want to boot the drive using someone else's computer - I can use Mint instead of <shudder> Windows.)
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Precise repository failure on Mint 13 Maya

Post by austin.texas » Sun Oct 05, 2014 12:05 pm

phoenix1963 wrote:An additional question: how do I use apt to find which packages are being requested when I run update?
When you run update, it lists them in the terminal.
Synaptic give you good info on what packages are being requested when installing, if that is what you mean.
apt-get will give you all the info, without doing the download and install (simulation) if you use the -s option:
sudo apt-get -s install ckeditor
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

User avatar
karlchen
Level 20
Level 20
Posts: 11066
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Precise repository failure on Mint 13 Maya

Post by karlchen » Sun Oct 05, 2014 4:37 pm

phoenix1963 wrote:

Code: Select all

deb http://archive.canonical.com/ubuntu/ precise partner
This was the first thing which very likely everybody who replied to you checked before replying. The entry is all right.
phoenix1963 wrote:I know Mint 13 is an LTS, but is that any guarantee that Partner software gets maintained? Maybe it has all vanished?
No, it has not. See my previous reply, all my Mint 13 systems were setup between May and July or August 2012 and they are all still alive and looking for updates regularly. If Canonical had closed the Partner repository or the partners had closed it, my systems would have noticed. And be assured there would have been an outcry in the Ubuntu forum and in the Mint forum, and you would not be the first one to be affected.
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.22a 64-bit
Windows? - 1 window in every room

phoenix1963
Level 2
Level 2
Posts: 66
Joined: Tue Mar 27, 2012 3:47 pm

Re: Precise repository failure on Mint 13 Maya

Post by phoenix1963 » Sun Oct 05, 2014 7:19 pm

Thanks for the answers, it's just I can't see a way of finding out which packages were trying to be updated when access to the repository fails - It could well be acroread, but it's a shame I can't figure out how to tell.
These two entries from austin are exactly the repos I'm always having problems with:

Code: Select all

Get:18 http://archive.canonical.com precise/partner amd64 Packages [6,039 B]    
Get:21 http://archive.canonical.com precise/partner i386 Packages [6,907 B] 
I presume I only need one of thesewith a Core2 processor, but why can't the server deliver them?

Weird,

I'll look tomorrow,

phoenix1963

User avatar
karlchen
Level 20
Level 20
Posts: 11066
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Precise repository failure on Mint 13 Maya

Post by karlchen » Mon Oct 06, 2014 7:30 pm

Hello, phoenix1963.

Whether your CPU is dual core or a quad core is irrelevant with respect to the question which repositories you have to query. You are using Mint 13 x64. This explains why http://archive.canonical.com/ubuntu/dis ... 4/Packages is being looked for. - 64-bit => amd64 (applies to AMD and Intel CPUs)
Presumably you have activated 32-bit support as well, and this is why http://archive.canonical.com/ubuntu/dis ... 6/Packages is being looked for.

The repository entry in your source list file /etc/apt/sources.list is correct. You can query the other Ubuntu repositories, just not the partner repository. This is weird. Still have got no real clue why.

Kind regards,
Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.22a 64-bit
Windows? - 1 window in every room

phoenix1963
Level 2
Level 2
Posts: 66
Joined: Tue Mar 27, 2012 3:47 pm

Re: Precise repository failure on Mint 13 Maya

Post by phoenix1963 » Mon Oct 20, 2014 5:13 pm

I did an apt autoclean to see if that would help...

It seems to be getting worse now, three missing ones rather than two:

Code: Select all

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/precise/restricted/binary-i386/Packages  404  Not Found
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/precise/universe/binary-i386/Packages  404  Not Found
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/precise/multiverse/binary-i386/Packages  404  Not Found
I still don't know how I find out what packages I have that are requesting updates.

Any thoughts?

phoenix1963

User avatar
karlchen
Level 20
Level 20
Posts: 11066
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Precise repository failure on Mint 13 Maya

Post by karlchen » Mon Oct 20, 2014 7:31 pm

Hello, phoenix1963.

This thread has been going on for more than 2 weeks now.
The only thing which seem to be clear after all this time are:
  • it is not the fault of the Ubuntu repository servers, else others would experience the problems sporadically or regularly, too.
  • it is not the fault of your sources list files
This means we nedd to look at other things and clear up other questions in order to make any progress:
  • Since when have you been experiencing the reported problem? For exactly 16 days now? Or for how long?
    What has changed between the day that "sudo apt-get update" still worked and the day that it started reporting errors?
  • Are you sitting behind some proxy server perhaps?
  • Can you ping the Ubuntu servers successfully? Without experiencing any packet loss? In a terminal run

    Code: Select all

    ping -c 100 archive.ubuntu.com
    ping -c 100 archive.canonical.com
    Note:
    In case you are behind a proxy, you will not be able to use ping commands, because a proxy is very unlikely to route ping packets into the internet.
I can.

Code: Select all

$ ping -c 100 archive.ubuntu.com
PING archive.ubuntu.com (91.189.92.200) 56(84) bytes of data.
64 bytes from obake.canonical.com (91.189.92.200): icmp_seq=1 ttl=57 time=27.2 ms
64 bytes from obake.canonical.com (91.189.92.200): icmp_seq=2 ttl=57 time=26.6 ms
[...lots of ping replies omitted to shorten post ...]
64 bytes from obake.canonical.com (91.189.92.200): icmp_seq=99 ttl=57 time=29.8 ms
64 bytes from obake.canonical.com (91.189.92.200): icmp_seq=100 ttl=57 time=27.4 ms

--- archive.ubuntu.com ping statistics ---
100 packets transmitted, 100 received, 0% packet loss, time 99123ms
rtt min/avg/max/mdev = 26.489/29.455/148.422/13.758 ms
$ 
As the summary confirms: no packet loss.

Code: Select all

$ ping -c 100 archive.canonical.com
64 bytes from sadalbari.canonical.com (91.189.92.191): icmp_seq=1 ttl=57 time=46.5 ms
64 bytes from sadalbari.canonical.com (91.189.92.191): icmp_seq=2 ttl=57 time=27.1 ms
[...lots of ping replies omitted to shorten post ...]
64 bytes from sadalbari.canonical.com (91.189.92.191): icmp_seq=99 ttl=57 time=26.8 ms
64 bytes from sadalbari.canonical.com (91.189.92.191): icmp_seq=100 ttl=57 time=27.1 ms

--- archive.canonical.com ping statistics ---
100 packets transmitted, 100 received, 0% packet loss, time 99149ms
rtt min/avg/max/mdev = 26.390/28.687/90.974/7.646 ms
$
As the summary confirms: no packet loss.


You may try these steps to improve the situation:
  • Clear the local apt-get cache. Perhaps it is the source of all the trouble.

    Code: Select all

    sudo apt-get clean
  • Of course we have to build up the local list of available software packages now.

    Code: Select all

    sudo apt-get update
  • Provided the previous command finished successfully you may get and install the available updates

    Code: Select all

    sudo apt-get upgrade
    Note:
    "sudo apt-get upgrade" will ask for your consent to actually upgrade your software. In case you answer n(o), it will not upgrade. But you will know what it would do if you consented.
    Provided the previous "sudo apt-get update" command succeeded, you might also leave the terminal alone and switch to the graphical Mint Update Manager. It should list all available software updates which "sudo apt-get update" has found.
    Exception:
    mintupdate will only display those updates that correspond to the safety levels which you have enabled. Default levels 1, 2 and 3. You may have changed this. You will know. Click on the [Install updates] button to accept and install the available updates.
Kind regards,
Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.22a 64-bit
Windows? - 1 window in every room

Post Reply

Return to “Software & Applications”