Page 1 of 1

openssl on Mint 17.0

Posted: Wed Nov 19, 2014 3:29 pm
by vlovjz
Hi everyone,

I'm having trouble building an application from source. You can find the source here, and the problem I'm having is documented here.

The author insists that the openssl that I installed from the repos is 32bit. How do I find out if this is true? If it is true, is why would it be the case?

Thanks for any input,

Regards

Re: openssl on Mint 17.0

Posted: Wed Nov 19, 2014 4:37 pm
by xenopeek
Files installed in /usr/lib/x86_64-linux-gnu/ aren't for 32 bit; as noted in the path they are for 64 bit. To get the 32 bit version you would have had to explicitly install libssl-dev:i386. A .a file is a static library; just an archive of compiled objects. Command file /usr/lib/x86_64-linux-gnu/libcrypto.a would have told you information about the file. Knowing it's an archive, and perhaps needing further proof, I just did these steps:

Code: Select all

mkdir test
cd test
ar x /usr/lib/x86_64-linux-gnu/libcrypto.a
file *
Created a temporary directory and extracted the contents of the libcrypto.a archive there. This is a long list of (.o) object files. Running file command again on these reports for all one of these two:
ELF 64-bit LSB relocatable, x86-64, version 1 (SYSV), stripped
ELF 64-bit LSB relocatable, x86-64, version 1 (SYSV), not stripped
Bit pointless exercise, but anyway there you have it--a file in /usr/lib/x86_64-linux-gnu/ is surprisingly a 64 bit file :)

Now how to solve your problem with compilation I don't immediately know. Perhaps the build script isn't multiarch aware, and doesn't know when compiling for x86-64 Linux architecture it should also look for libraries in /usr/lib/x86_64-linux-gnu/?

Re: openssl on Mint 17.0

Posted: Sun Nov 23, 2014 12:40 am
by vlovjz
Hi xenopeek,

Thanks for the clarification and the work you went into for the reply.

The history of the project is that it is a CLI program originally coded for Macs, and then ported by Matthew Motz (linwiz) on github (with the author's help) to build on linux. Matthew was able to build the application with no problems on a flavor of Debian working on Raspberry Pi, and another user on reddit told me that it he was able to build it on Gentoo.

If it was coded for Macs originally, I don't see why the 64 bit architecture would be a problem. Unless there's something that I'm still not understanding.

Also, Matthew suggested that I build using

Code: Select all

./build -L/usr/lib/x86_64-linux-gnu/
which he assumed would add that directory to the library search paths--but the exact same error seemed to occur.