[Solved] How to disable Alt Gr + Space shortcut

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
lau22
Level 1
Level 1
Posts: 20
Joined: Wed Dec 10, 2014 4:27 am

[Solved] How to disable Alt Gr + Space shortcut

Post by lau22 »

I sometime accidentally press Alt Gr + Space, instead of just Space. It prints what looks like a space character however it somehow different. At first it took me a while to figure out why when I was typing something like "git branch | sort", it would print "No command ' sort' found", eventually I found out it's this special "space" character.

I don't really know how or where (or WHY) this shortcut is setup. Is there any way to disable it?
Last edited by lau22 on Tue Oct 06, 2015 3:07 pm, edited 1 time in total.

1.618
Level 5
Level 5
Posts: 588
Joined: Fri Jun 06, 2014 9:22 am
Location: Surfing a multidimensional wave of celestial intent
Contact:

Re: How to disable Alt Gr + Space shortcut

Post by 1.618 »

Is it not in System > Keyboard shortcuts ?

lau22
Level 1
Level 1
Posts: 20
Joined: Wed Dec 10, 2014 4:27 am

Re: How to disable Alt Gr + Space shortcut

Post by lau22 »

I've just had look but I didn't see it there. I guess it's more like all the special letters that show up when pressing Alt Gr + Letter. For example, with "A", it's "â", with "E", it's "€". This is fine, but with space it gives this special space character, which often breaks my code or command lines.

Cosmo.
Level 23
Level 23
Posts: 17825
Joined: Sat Dec 06, 2014 7:34 am

Re: How to disable Alt Gr + Space shortcut

Post by Cosmo. »

I did enter AltGr-space inside a hex editor and only get hex 20 (as expected). So assume, that your shortcut-problem is not a system setting, but a setting or feature of your editor. Which do you use? Try it with another one.

lau22
Level 1
Level 1
Posts: 20
Joined: Wed Dec 10, 2014 4:27 am

Re: How to disable Alt Gr + Space shortcut

Post by lau22 »

It does it in both Terminator and the regular Mint Terminal, also in Sublime Text so I don't think it's something specific to an application.

I wonder if it could be related to my keyboard layout (French AZERTY), maybe some key combinations are setup on this layout but not on others?

Cosmo.
Level 23
Level 23
Posts: 17825
Joined: Sat Dec 06, 2014 7:34 am

Re: How to disable Alt Gr + Space shortcut

Post by Cosmo. »

I have a German keyboard layout. So differences will be there.

You could add some more keyboard layouts and switch between them for testing this out. Then you know, if there is the origin for the problem.

User avatar
WinterTroubles
Level 6
Level 6
Posts: 1473
Joined: Fri Apr 11, 2014 6:25 am
Location: UK

Re: How to disable Alt Gr + Space shortcut

Post by WinterTroubles »

I've found this Wikipedia article listing AltGr functions with all the standard regional keyboard layouts, https://en.wikipedia.org/wiki/AltGr_key#French ,the link I've posted takes you directly to the section on French keyboard layout, unfortunately it doesn't list anything for AltGr + Spacebar.

In fact the only mention I see ( I may have missed something) for AltGr + Spacebar is for the Finnish layout, where it adds a NonBreaking SPace, https://en.wikipedia.org/wiki/Non-breaking_space

I know this isn't necessarily useful, but, thought it might provide 'food for thought'.
17.1Cinn/17.1Xfce

If solved please edit the subject line of your first post to include [Solved] so other users know there's a solution in the topic.

GNU Terry Pratchett

Cosmo.
Level 23
Level 23
Posts: 17825
Joined: Sat Dec 06, 2014 7:34 am

Re: How to disable Alt Gr + Space shortcut

Post by Cosmo. »

Another finding:

I took a look into the keyboard settings. You can pop up (at least with Cinnamon) a preview window. Now I see the following:

Choosing French there is no label on the space key
Choosing French alternative there is a label nobreakspace on the top right of this key
Choosing French alternative old the same label is on the bottom right of the key.

I have no experience and no idea, what this means in practical terms, but for me it seems, as if a French keyboard setting and another French keyboard setting are not the same. Maybe a French user (i.e. lau22) can use this finding.

User avatar
WinterTroubles
Level 6
Level 6
Posts: 1473
Joined: Fri Apr 11, 2014 6:25 am
Location: UK

Re: How to disable Alt Gr + Space shortcut

Post by WinterTroubles »

Good thinking Cosmo, maybe I should have looked there before the net :lol:

Expanding on Cosmo's findings, with my english keyboard layout in cinnamon there is a button in the bottom right corner of the 'keyboard layout' tab of keyboard settings labeled 'options'.. one of the options in this section is the behaviour of spacebar regarding nobreaking space, there is an option to 'use a normal space at any level', which I think means never a nobreaking space.

Not knowing which desktop you are using lau22, I can't say where these options are on your system, but, I would expect them to be there.
17.1Cinn/17.1Xfce

If solved please edit the subject line of your first post to include [Solved] so other users know there's a solution in the topic.

GNU Terry Pratchett

lau22
Level 1
Level 1
Posts: 20
Joined: Wed Dec 10, 2014 4:27 am

Re: How to disable Alt Gr + Space shortcut

Post by lau22 »

Yes that was it - in the layout options, the option "Using space key to input non-breakable space character" was set to "Default". I've set it to "Usual space at any level" and now I always get a regular space character. Thanks a lot for the help! :)

User avatar
WinterTroubles
Level 6
Level 6
Posts: 1473
Joined: Fri Apr 11, 2014 6:25 am
Location: UK

Re: How to disable Alt Gr + Space shortcut

Post by WinterTroubles »

You are welcome Lau22 :)

Can please read the red line in my signature and mark your thread solved if you agree that it is, many thanks :)
17.1Cinn/17.1Xfce

If solved please edit the subject line of your first post to include [Solved] so other users know there's a solution in the topic.

GNU Terry Pratchett

aabharan
Level 1
Level 1
Posts: 2
Joined: Mon Dec 22, 2014 7:04 am

Re: How to disable Alt Gr + Space shortcut

Post by aabharan »

Pressing Alt Gr is the same as pressing Ctrl+Alt . ... Page Up; Shift + Space. Enjoy !

Post Reply

Return to “Software & Applications”