<SOLVED> Chrome Adblock Plus extension won't load to profile

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
lotharjade
Level 2
Level 2
Posts: 58
Joined: Thu Mar 10, 2011 5:43 pm
Location: Alaska

<SOLVED> Chrome Adblock Plus extension won't load to profile

Post by lotharjade »

I have Google Chrome and when I try to install Adblock Plus it posts an error message that says "Cannot move extension directly into Profile". How do I fix that and get Adblock Plus to install?

I previously had Adblock Plus installed in Chrome, but uninstalled it because it was updating to the site (opening a Adblock Update page each time), whenever I opened Chrome or a Chrome application shortcut (which was really annoying). It was suggested that uninstalling and re-installing the program was the solution to the problem. That just now prevents re-installation. What is preventing the Adblock Plus extension from being re-installed?

I have this running on a Linux Mint 17.1 Cinnamon 64-bit system that I recently upgraded to from Mint 15.
Last edited by lotharjade on Fri Jan 23, 2015 11:11 pm, edited 1 time in total.
Have you tried turning it off and on again, then hitting it repeatedly? :/

lotharjade
Level 2
Level 2
Posts: 58
Joined: Thu Mar 10, 2011 5:43 pm
Location: Alaska

Re:Chrome Adblock Plus ext. won't load to profile. <SOLVED>

Post by lotharjade »

No one answered my post, but I kept digging and another site mentioned something that solved my problem. To fix Adblock Plus (and possibly other extensions) not installing properly, do the following:

Step 0: (I assume you did this previously) Write down the extensions ID, and Uninstall Adblock Plus (or whatever extension it is). The ID can be found when you open the extensions page. ->Stettings -> Extensions. If you didn't get the ID, there is another way to find this info. My Id for Adblock Plus was ID: cfhdojbkjhnklbpkdaibdccddilifddb, and yours may be the same.

Then close Google Chrome.

Step 1: Delete the extension file. Go to your home folder in Nemo -> View -> select "View Hidden Files".
Then go to: ~/(your home folder)/.config/google-chrome/default/extensions -> look for the file with your Extension ID, verify it is for Adblock Plus (or your problem extension) and then delete it.
((I verified this was for adblock by opening the file, clicking past the next file (mine said 1.8.10_0, but yours may be different. I only had one option here), and then opening the file "Options.html" in a text editor (right click file -> open with -> text editor) and looking for it saying something about Adblock Plus near the top of the page. If you see that, you have the right folder.))

Step 2: Reopen browser, and re-install Adblock Plus. It should solve the problems that you may have been having. Adblock Plus should work now. :D
Have you tried turning it off and on again, then hitting it repeatedly? :/

Post Reply

Return to “Software & Applications”