Setting Static IP in Felicia?

Questions about applications and software
Forum rules
Before you post please read how to get help
User avatar
Old Marcus
Level 4
Level 4
Posts: 391
Joined: Sun Jun 08, 2008 4:51 pm
Location: Exeter, UK
Contact:

Setting Static IP in Felicia?

Postby Old Marcus » Sat Nov 15, 2008 12:49 pm

This seems to be a bug with NetworkManager 0.7, but anyway. Having set configuration from DHCP to manual I enter my IP address, Netmask and Gateway address:

192.168.1.47 - My Computer
192.168.1.1 - Router
255.255.255.0 - Gateway

These settings worked on Elyssa, using an older version of Network Manager. I may have mixed something up but after reboot, I can't connect to anything and the Netmask field in configuration has changed to a number such as 24. I look in ifconfig and My IP addr is fine, but Bcast and Mask are screwed. Any help? Should I roll back a version of Network Manager or is there a solution to this?

I posted in Software and Applications because this is a software problem more than a network problem. Currently on DHCP, so can connect.
Linux Mint 8 RC1 = Nice
'apt install' can be used on Linux Mint as a shortcut for 'sudo apt-get install'. 'apt x' can be used for various other apt commands as well.
When a problem is solved, please add [SOLVED] to your thread title.

User avatar
merlwiz79
Level 10
Level 10
Posts: 3475
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: Setting Static IP in Felicia?

Postby merlwiz79 » Sat Nov 15, 2008 1:05 pm

You could try making a new connection and just select it with the left click.
Image

User avatar
Old Marcus
Level 4
Level 4
Posts: 391
Joined: Sun Jun 08, 2008 4:51 pm
Location: Exeter, UK
Contact:

Re: Setting Static IP in Felicia?

Postby Old Marcus » Sat Nov 15, 2008 1:19 pm

I have, but the netmask setting keeps resetting to a different number each time.

EDIT: Screenshot:
Image
I put in my net mask, and it changes to this. Annoying, And I think this is the problem.
Linux Mint 8 RC1 = Nice
'apt install' can be used on Linux Mint as a shortcut for 'sudo apt-get install'. 'apt x' can be used for various other apt commands as well.
When a problem is solved, please add [SOLVED] to your thread title.

User avatar
merlwiz79
Level 10
Level 10
Posts: 3475
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: Setting Static IP in Felicia?

Postby merlwiz79 » Sat Nov 15, 2008 3:37 pm

Regards, Trygve wrote:This is not a bug.

Ref. http://en.wikipedia.org/wiki/Netmask

The 24 means it is a 24 bit subnetwork, which is just another way of saying 255.255.255.0.

https://bugs.launchpad.net/ubuntu/+bug/269910
Image

User avatar
Old Marcus
Level 4
Level 4
Posts: 391
Joined: Sun Jun 08, 2008 4:51 pm
Location: Exeter, UK
Contact:

Re: Setting Static IP in Felicia?

Postby Old Marcus » Sat Nov 15, 2008 3:42 pm

Cheers, but I still can't connect. I guess this has turned into a network problem I guess. would it be possible for a mod to move this to the network forum?
Linux Mint 8 RC1 = Nice
'apt install' can be used on Linux Mint as a shortcut for 'sudo apt-get install'. 'apt x' can be used for various other apt commands as well.
When a problem is solved, please add [SOLVED] to your thread title.

User avatar
Old Marcus
Level 4
Level 4
Posts: 391
Joined: Sun Jun 08, 2008 4:51 pm
Location: Exeter, UK
Contact:

Re: Setting Static IP in Felicia?

Postby Old Marcus » Sat Nov 15, 2008 4:09 pm

Solved: I set the DNS Server wrong, I set it to my IP address, instead of the router's Ip address. Thanks for your help anyway merlwiz. :)
Linux Mint 8 RC1 = Nice
'apt install' can be used on Linux Mint as a shortcut for 'sudo apt-get install'. 'apt x' can be used for various other apt commands as well.
When a problem is solved, please add [SOLVED] to your thread title.


Return to “Software & Applications”

Who is online

Users browsing this forum: doro, Google [Bot] and 6 guests