It's a pity Icecat browser is not in the repository

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
juansantiago
Level 1
Level 1
Posts: 22
Joined: Mon Mar 04, 2013 5:58 am
Contact:

It's a pity Icecat browser is not in the repository

Post by juansantiago »

It's a pity Icecat browser is not in the repository, I'm ddowloaded and I can run it without installing it, but, how I can install?
Lo malo de usar Linux es que si algo sale mal no le puedo echar la culpa a Bill, lo beuno es que casi nunca sucede.

User avatar
Pjotr
Level 21
Level 21
Posts: 14127
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: It's a pity Icecat browser is not in the repository

Post by Pjotr »

Icecat is simply just the GNU version of Firefox. So: why?
Tip: 10 things to do after installing Linux Mint 19.3 Tricia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
juansantiago
Level 1
Level 1
Posts: 22
Joined: Mon Mar 04, 2013 5:58 am
Contact:

Re: It's a pity Icecat browser is not in the repository

Post by juansantiago »

Pjotr wrote:Icecat is simply just the GNU version of Firefox. So: why?
It is not just a simply version, is a 100% free (libre) version.
Lo malo de usar Linux es que si algo sale mal no le puedo echar la culpa a Bill, lo beuno es que casi nunca sucede.

User avatar
Pjotr
Level 21
Level 21
Posts: 14127
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: It's a pity Icecat browser is not in the repository

Post by Pjotr »

Get Iceweasel: same thing, but the Debian way:
https://packages.debian.org/jessie/amd6 ... l/download

Linux Mint = based on Ubuntu = based on Debian.
Tip: 10 things to do after installing Linux Mint 19.3 Tricia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Tim-int
Level 1
Level 1
Posts: 46
Joined: Tue Nov 29, 2011 2:30 pm

Re: It's a pity Icecat browser is not in the repository

Post by Tim-int »

Not correct. Installing like that invokes the error:
iceweasel:
Depends: libhunspell-1.3-0 (>=1.3.3) but 1.3.2-6ubuntu2 is to be installed
Depends: libstdc++6 (>=4.9) but 4.8.4-2ubuntu1~14.04 is to be installed

So, I agree Mint should have IceWeasel alongside Firefox.

User avatar
Imagus
Level 3
Level 3
Posts: 125
Joined: Tue Aug 28, 2007 2:33 pm
Location: Belgium

Re: It's a pity Icecat browser is not in the repository

Post by Imagus »

I totally agree. I have spent all day trying to install either Icecat or Iceweasel but to no avail. When I tried to install Iceweasel from the terminal, it automatically installed Firefox - which I did NOT want. Why does Mint try to force us to use Firefox? Even if just wanted to install Icecat for no other reason than having the cute looking icons on my desktop, I should still be able to do so. I also downloaded the deb-package of Iceweasel but that gave me the same errors as mentioned above.

If anyone knows how to install the Ice-packages (Icecat, Iceweasel, Icedove etc.) on Mint 17, I'd really appreciate it if someone could tell me how to do it. The instructions I already found on the web did not work.

Post Reply

Return to “Software & Applications”