[SOLVED] pgadmin3 and Postgres9.4 LMDE installation broken

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
luandrea
Level 1
Level 1
Posts: 9
Joined: Fri Nov 28, 2014 4:25 am

[SOLVED] pgadmin3 and Postgres9.4 LMDE installation broken

Post by luandrea » Wed May 06, 2015 8:41 am

Hi all,
I've installed Postgres9.4 adding this repository in /etc/apt/sources.list.d/pgdg.list:
deb http://apt.postgresql.org/pub/repos/apt/ wheezy-pgdg main

After this, doing an

Code: Select all

apt-get upgrade
, I got a warning that told me that I had 4 non updated packages:
pgadmin3 pgadmin3-data postgresql-client-common postgresql-common

So I did an

Code: Select all

apt-get dist-upgrade
to remove them, but after this I cannot install anymore pgadmin3.

If I do

Code: Select all

apt-get install pgadmin3
I got this:

Code: Select all

The following packages have unmet dependencies:
 pgadmin3 : Depends: libwxbase3.0-0 (>= 3.0.2) but 3.0.0-1 is to be installed
            Depends: libwxgtk3.0-0 (>= 3.0.2) but 3.0.0-1 is to be installed
E: Unable to correct problems, you have held broken packages
I don't understand why pgadmin3 tries to install version 3.0.0-1 instead of 3.0.0. :?: :?:

The package info shows that it depends on libwxbase3.0-0 and libwxgtk3.0-0. I also tried to install this two packages and the install pgadmin3, but the error was the same. :roll:
Last edited by luandrea on Thu May 14, 2015 4:31 am, edited 1 time in total.

luandrea
Level 1
Level 1
Posts: 9
Joined: Fri Nov 28, 2014 4:25 am

Re: pgadmin3 and Postgres9.4 LMDE installation broken

Post by luandrea » Thu May 14, 2015 4:30 am

Nevermind,
I compiled it from the source downloading pgadmin3-1.20.0.tar.gz from postgres site and following the the INSTALL guide inside it. The only problem that i get was resolved restarting Mint, probably some packages needs it.

Post Reply

Return to “Software & Applications”