Ugly LibreOffice, no longer uses Cinnamon themes <Solved>

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
hpmc13
Level 3
Level 3
Posts: 153
Joined: Tue Jun 04, 2013 4:26 pm

Ugly LibreOffice, no longer uses Cinnamon themes <Solved>

Post by hpmc13 »

Although this problem has persisted for a while, I recently decided to try to correct it. It's not really broken, just annoying. For some time, all LibreOffice applications would have the same look and feel as everything else. Menus, dialogue boxes, dropdowns, etc, in the application were pretty much seamless. No longer.

The two attachments below show what LO looks like when opening a file, then what another application looks like.
LOOpen.jpg
FWopen.jpg
I recently did a clean install of 17.2, 64-bit, Cinnamon, and now all LO applications have their own, Windows 95 look to them. LibreOffice is version 4.4.3.2. After doing some reading here and other places, I tried some of the steps to correct this. I installed libreoffice-gnome, which also installed libreoffice-gtk. This is the result:
Calcdark.jpg
I reversed that change and soldiered on.

I read that I need to install libreoffice-style-human, but marking this in Synaptic requires the removal of mint-artwork-gnome, mint-meta-cinnamon, and mint-themes, all of which seem pretty important so I did not install it.

I tried LO's built in themes under Tools->Options->Personalization but that merely puts a Firefox Persona on the menu bar.

If anyone has any suggestions, I am forever in your debt.

Thanks!
Last edited by hpmc13 on Fri Jul 17, 2015 8:05 pm, edited 1 time in total.
Running LM 20 Cinnamon
Cosmo.
Level 23
Level 23
Posts: 17817
Joined: Sat Dec 06, 2014 7:34 am

Re: Ugly LibreOffice, no longer uses Cinnamon themes

Post by Cosmo. »

Did you preserve your home folder, when you installed LM 17.2?
hpmc13
Level 3
Level 3
Posts: 153
Joined: Tue Jun 04, 2013 4:26 pm

Re: Ugly LibreOffice, no longer uses Cinnamon themes

Post by hpmc13 »

I did preserve it. If I recall correctly, the ugly problem began before I reinstalled 17.2.
Running LM 20 Cinnamon
Cosmo.
Level 23
Level 23
Posts: 17817
Joined: Sat Dec 06, 2014 7:34 am

Re: Ugly LibreOffice, no longer uses Cinnamon themes

Post by Cosmo. »

Seems you have preserved the problem. :?

Try this:
Close LO completley, inclusive the quickstarter!
Open nemo and make hidden files visible.
Open the folder .config and rename the folder libreoffice to something else (e.g. libreoffice.bck)
Restart LO.
hpmc13
Level 3
Level 3
Posts: 153
Joined: Tue Jun 04, 2013 4:26 pm

Re: Ugly LibreOffice, no longer uses Cinnamon themes

Post by hpmc13 »

Fantastic!

I had to go back and install libreoffice-gnome and then it was fixed. A few personalizations to change and I am good to go.

Thank you!
Running LM 20 Cinnamon
hpmc13
Level 3
Level 3
Posts: 153
Joined: Tue Jun 04, 2013 4:26 pm

Re: Ugly LibreOffice, no longer uses Cinnamon themes <Solved

Post by hpmc13 »

As if I didn't feel like a big enough idiot before, or that I don't appreciate your fix, Cosmo, but I found the really easy fix. I was going through the options and found this:
openfix.jpg
Uncheck "Use LibreOffice dialogs" and it uses the Linux dialogs.

Again, I appreciate it, but I must have checked that some time before and forgotten. Reinstated the old .config folder and switched it back. All is well.

Thanks again!
Running LM 20 Cinnamon
Post Reply

Return to “Software & Applications”