SOLVED location bar/search settings in Firefox 43 ("visit")

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
fraxinus_63
Level 4
Level 4
Posts: 219
Joined: Fri Jan 01, 2010 2:25 pm

SOLVED location bar/search settings in Firefox 43 ("visit")

Post by fraxinus_63 » Sun Dec 20, 2015 12:58 pm

I am running Mint 13 MATE and updated to Firefox 43 a couple of days ago. I am noticing a number of little changes which I am adapting to - as a FF lover I have downloaded the Classic Theme Restorer add-on, in case it is useful in future for restoring old workflows.

One change irritates me, I'm afraid. Whenever I click the location bar and type the first character of a url, a website address from my history now appears prefixed with the word "visit". For example, if I type "f", I am served "visit facebook.com" above the list of other urls from my history beginning with "f" (which is valuable and useful). This new functionality is not useful to me. It's a small thing I know, but can anyone advise me on how to revert the way "predictive text" used to work in Firefox's location bar?
Last edited by fraxinus_63 on Mon Dec 21, 2015 8:20 am, edited 1 time in total.

User avatar
BigEasy
Level 6
Level 6
Posts: 1181
Joined: Mon Nov 24, 2014 9:17 am
Location: Chrząszczyżewoszyce, powiat Łękołody

Re: location bar/search settings in Firefox 43

Post by BigEasy » Sun Dec 20, 2015 1:24 pm

Windows assumes I'm stupid but Linux demands proof of it

fraxinus_63
Level 4
Level 4
Posts: 219
Joined: Fri Jan 01, 2010 2:25 pm

Re: location bar/search settings in Firefox 43

Post by fraxinus_63 » Sun Dec 20, 2015 1:42 pm

@BigEasy - thanks so much.

User avatar
xenopeek
Level 24
Level 24
Posts: 23193
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: location bar/search settings in Firefox 43

Post by xenopeek » Sun Dec 20, 2015 3:43 pm

it was annoying me as well; it's not consistently adding "visit" to the first result and the "visit" bar for the first result hides whether the URL is in your bookmarks or not. It's the last straw that it annoys you as well! Time to find how to revert this :)

I found it can be reverted by going to about:config and changing the setting browser.urlbar.unifiedcomplete to false. Then restart Firefox and it will behave just like Firefox 42 did.
Image

fraxinus_63
Level 4
Level 4
Posts: 219
Joined: Fri Jan 01, 2010 2:25 pm

Re: location bar/search settings in Firefox 43 ("visit")

Post by fraxinus_63 » Mon Dec 21, 2015 8:20 am

Thanks very much, xenopeek. For some reason my request for help appeared twice on this board - forum member BigEasy has also kindly supplied the answer, in response to my other thread: http://forums.linuxmint.com/viewtopic.php?f=47&t=211883. I find the new default behaviour very unhelpful and I am very pleased to be able to revert it!

Post Reply

Return to “Software & Applications”