Page 1 of 1

[Solved] Update wants to uninstall 214 packages

Posted: Thu Jan 07, 2016 10:38 am
by matthekc
I am on 17.2 64 bit and an update seems to want to uninstall an unusual amount of packages.
I have included a screenshot.

I'm not too worried about it, I will either upgrade to 17.3 or wait till 18 but I thought you guys might want to see this...
While I am asking questions, should I upgrade to 17.3?

Re: Update wants to uninstall 214 packages

Posted: Thu Jan 07, 2016 10:41 am
by Cosmo.
Impossible to read the text in the update manager window.

Re: Update wants to uninstall 214 packages

Posted: Thu Jan 07, 2016 11:44 am
by matthekc
Yeah I am not too thrilled with that screen either...

It's Installing Libpng and Pcsx2 and a few dependencies and removing well near everything best I can tell...
Not sure whats up with that.

Re: Update wants to uninstall 214 packages

Posted: Thu Jan 07, 2016 11:46 am
by matthekc
Ok I turned the quality up in Shutter's preferences, that is much better...

Re: Update wants to uninstall 214 packages

Posted: Thu Jan 07, 2016 11:50 am
by matthekc
Let me know if you guys want any more information from my end. Like I said, I really don't care those packages are not that critical to me and can wait till the next major upgrade.

Re: Update wants to uninstall 214 packages

Posted: Thu Jan 07, 2016 11:56 am
by matthekc
This might be useful :D
On a side note it would be nice to be able to export that from the GUI as a text file or something.

Re: Update wants to uninstall 214 packages

Posted: Thu Jan 07, 2016 12:00 pm
by Habitual
matthekc wrote:This might be useful :D
On a side note it would be nice to be able to export that from the GUI as a text file or something.
terminal >

Code: Select all

sudo apt-get upgrade -s | pastebin 
or possibly

Code: Select all

sudo apt-get dist-upgrade -s  | pastebin 
Paste either/both of those links here.

Re: Update wants to uninstall 214 packages

Posted: Thu Jan 07, 2016 12:48 pm
by matthekc
That's a new one for me, what is the application pastebin? A diagnostic tool that uploads to LM servers?

http://paste.linuxmint.com/view/e5bf/

Re: Update wants to uninstall 214 packages

Posted: Thu Jan 07, 2016 12:50 pm
by matthekc

Re: Update wants to uninstall 214 packages

Posted: Thu Jan 07, 2016 4:21 pm
by Cosmo.
I don't know the software playstation-emulator, but it is not in the official repositories. Also I have no idea, why this update wants to remove the half of your system an not already at the time, when you installed it. Perhaps somebody knows this emulator, but I would remove it.

Re: Update wants to uninstall 214 packages

Posted: Thu Jan 07, 2016 4:30 pm
by Habitual
I'd remove

Code: Select all

ppa for pcsx2 team:14.04/trusty
refresh,
check again,
Compare.

Re: [Solved] Update wants to uninstall 214 packages

Posted: Sat Jan 09, 2016 12:33 am
by matthekc
As this is a PPA issue I am marking it solved... thanks for the help with troubleshooting. I will probably give the PPA owner a shout.

Re: [Solved] Update wants to uninstall 214 packages

Posted: Mon Jan 11, 2016 12:33 pm
by Habitual
Glad to be of help.

Personally on such things, I usually give 'em 1 day, 2 tops, then I get a little itchy.

Happy New Year!

Re: [Solved] Update wants to uninstall 214 packages

Posted: Fri Jan 15, 2016 12:53 pm
by darkside
It's a problem with some mint 64b when you use a 386 software.
look like only linux mint 64b have this problem.

http://forums.pcsx2.net/Thread-Linux-Mi ... i638-issue

Yesterday for exemple, i saw a user with linux mint cinamon 64b whitch could not update.
After schearch the problem was an update with the official ppa of dolphin
witch certainly have graphical i386

Disable this ppa solved the problem, but this bug of multiarch with waylang-egl1 is still here.