very nasting problem with flash videos

Questions about applications and software
Forum rules
Before you post please read how to get help
linuxatico

very nasting problem with flash videos

Postby linuxatico » Wed Feb 11, 2009 3:30 pm

Hi, this is the first time i use this forum, and I wish someone can help me solving a problem that sucks so much.
Almost everytime i play a video on youtube, or I play any facebook game that needs flash.... or it simply blocks or it blocks and the video becomes gray. In both of the cases i need to refresh once or more till it works or I stop trying.....
Actually I tried to install\remove any package related to flash:
    flashplugin-nonfree, flashplugin-nonfree-extrasound, adobe-flashplugin
.....
now the best working package is flashplugin-nonfree and flashplugin-nonfree-extrasound because sometimes I can see a few seconds of videos, instead if i put adobe-flashplugin i get always This video is no longer avaiilable

please tell me what can I do, this problem happens with firefox, epiphany ecc

User avatar
shane
Level 6
Level 6
Posts: 1299
Joined: Sun Feb 25, 2007 11:15 pm
Contact:

Re: very nasting problem with flash videos

Postby shane » Thu Feb 12, 2009 8:40 am

first of all, purge all flash packages... (completely remove in spynaptic) then purge nspluginwrapper...

then reinstall flash.

or from command line the commands to run are...

Code: Select all

sudo aptitude purge flashplugin-nonfree flashplugin-nonfree-extrasound adobe-flashplugin nspluginwrapper


then

Code: Select all

sudo aptitude install flashplugin-nonfree

User avatar
garda
Level 5
Level 5
Posts: 743
Joined: Sat Aug 30, 2008 2:55 am
Location: /root

Re: very nasting problem with flash videos

Postby garda » Thu Feb 12, 2009 10:42 am

linuxatico,

I see similar symptom with Firefox on x64 versions of Ubuntu and Mint, and there seems to be no other way to remedy that if adobe-flashplugin -- provided all other flash packages have been purged as suggested by Shane -- does not do the trick. Your only options would be to use Opera or switch to x86 (32-bit) versions of the aforementioned distros and replace flashplugin-nonfree et al with adobe-flashplugin.

User avatar
shane
Level 6
Level 6
Posts: 1299
Joined: Sun Feb 25, 2007 11:15 pm
Contact:

Re: very nasting problem with flash videos

Postby shane » Thu Feb 12, 2009 11:11 am

i had the exact same problem as the OP... grayed out flash content. It was not limited to FF... i had it in Midori and Kazehakase.

the culprit here is nspluginwrapper... what i did solved the prob for me. no more gray outs.

Fader
Level 1
Level 1
Posts: 1
Joined: Sun Feb 15, 2009 2:14 pm

Re: very nasting problem with flash videos

Postby Fader » Mon Feb 16, 2009 2:53 pm

Thank you, thank you, thank you. This worked for me. I loved mint as soon as I saw its menu and style, but not having flash work was a deal breaker. Any site that has videos or audio uses flash and not having that work is inexcusable. I made the account to come on here and complain but thanks to this it works!!

shane wrote:first of all, purge all flash packages... (completely remove in spynaptic) then purge nspluginwrapper...

then reinstall flash.

or from command line the commands to run are...

Code: Select all

sudo aptitude purge flashplugin-nonfree flashplugin-nonfree-extrasound adobe-flashplugin nspluginwrapper


then

Code: Select all

sudo aptitude install flashplugin-nonfree

elija
Level 1
Level 1
Posts: 29
Joined: Sun Dec 21, 2008 9:30 am

Re: very nasting problem with flash videos

Postby elija » Fri Feb 20, 2009 8:28 am

shane wrote:first of all, purge all flash packages... (completely remove in spynaptic) then purge nspluginwrapper...

then reinstall flash.

or from command line the commands to run are...

Code: Select all

sudo aptitude purge flashplugin-nonfree flashplugin-nonfree-extrasound adobe-flashplugin nspluginwrapper


then

Code: Select all

sudo aptitude install flashplugin-nonfree


Well, I followed this advice and was left unable to play any Flash videos which was obviously not the intention. I reinstalled everything except flashplugin-nonfree-extrasound and (touch wood) it has all been fine since then. This is using Mint 5 and Opera in case it makes a difference.
less is more, but more more than more is, so more is less less, so use more less if you want less more, more or less.

Read my blog at the Fifth Continent
Over 50? Visit the Saga Zone
Registered Linux User: #459086

Dan42

Re: very nasting problem with flash videos

Postby Dan42 » Mon Feb 23, 2009 10:04 am

Thank you Shane. I had the same problem with my flash player. Your fix worked great. :D

mattyd.24
Level 1
Level 1
Posts: 46
Joined: Mon Mar 16, 2009 10:56 pm
Location: Australia

Re: very nasting problem with flash videos

Postby mattyd.24 » Mon Mar 16, 2009 11:18 pm

I've got the same problems as described; after 7 seconds of stuttery video (youtube, etc.) it freezes, the window goes dark and then it repeats.
I've tried all of these methods described as well as slightly different configurations and I still can't get flash video to work.
Can someone help?? I'm running LinuxMint 6 32-bit with plenty of grunt to play flash video and getting sick of watching videos in 7 second spurts.


Return to “Software & Applications”

Who is online

Users browsing this forum: No registered users and 6 guests