Exchange plugin installation for evolution fails !

Questions about applications and software
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Wed Feb 18, 2009 3:44 pm

Exchange plugin installation for evolution fails !

Postby user465 » Wed Feb 18, 2009 3:54 pm

Dear all,
Apologies for this question that looks trivial but some assistance would be grately appreciated.

According to the Evolution 2.24.3 user guide there should be an option for an exchange server. The installation however, did not contain this exchange plugin - sadly. Downloading the evolution-exchange package (2.24.3 as well) (see ... 7530.shtml) resulted into the following error:
checking pkg-config is at least version 0.9.0... yes
checking for GNOME_PLATFORM... yes
checking for EVOLUTION_DATA_SERVER... configure: error: Package requirements (libebook-1.2 >= 2.23.90
libecal-1.2 >= 2.23.90
libedataserver-1.2 >= 2.23.90
libedataserverui-1.2 >= 2.23.90
libegroupwise-1.2 >= 2.23.90
libebackend-1.2 >= 2.23.90
libexchange-storage-1.2 >= 2.23.90) were not met:

No package 'libebook-1.2' found
No package 'libecal-1.2' found
No package 'libedataserverui-1.2' found
No package 'libegroupwise-1.2' found
No package 'libebackend-1.2' found
No package 'libexchange-storage-1.2' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables EVOLUTION_DATA_SERVER_CFLAGS
and EVOLUTION_DATA_SERVER_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Trying to redefine..... export PKG_CONFIG_PATH=/usr/bin/pkg-config
did not help. When "reconfiguring" with ./configure it resulted into the same mess.

Any feedback whether
a) the approach to install the plugin is on the right track and
b) how to complete this would be appreciated.
Thank you

Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Exchange plugin installation for evolution fails !

Postby Husse » Sun Feb 22, 2009 2:55 pm

At least libebook exists in a default install and in a version high enough
It's in /usr/share and usr/lib
Don't fix it if it ain't broken, don't break it if you can't fix it


Re: Exchange plugin installation for evolution fails !

Postby user456 » Sun Feb 22, 2009 8:08 pm

Thank you for your reply.

I checked the directories you uggested and indeed in /usr/lib I could see the required files. But not in /usr/share. However, I'm afraid even if re-directing the EVOLUTION_DATA_SERVER variables to the /usr/lib did not help. I still get the same error.

Then I opened the script ./configure and found that indeed the associated script causing the mistake and I prefer not to start messing with it and try to resolve it ata higher level. So any further help would be appreciated. Some step-by-step instructions would be useful for many readers.
if test -n "$EVOLUTION_DATA_SERVER_LIBS"; then
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
{ ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"libebook-\$EDS_API_VERSION >= 2.23.90

Thanks agains

Return to “Software & Applications”