Page 1 of 1

Prevent program from autostarting

Posted: Wed Jul 06, 2016 7:43 am
by RVDowning
I am running LInux MInt 17.3. I can find no startup folder in System Settings or anywhere else. I am trying to prevent PSensor from autostarting. Is there any way to do it other than uninstalling the program?

Re: Prevent program from autostarting

Posted: Wed Jul 06, 2016 7:47 am
by Cosmo.
Open the startup program settings and disable psensor. (It adds itself automatically there.)

Re: Prevent program from autostarting

Posted: Wed Jul 06, 2016 8:00 am
by RVDowning
I see no such settings. However, I think I may have found the autostart in ./etc/xdg/autostart. I did a find for anything called "autostart". About to reboot to try it.

Re: Prevent program from autostarting

Posted: Wed Jul 06, 2016 8:13 am
by RVDowning
Yep, removing the .desktop file from ./etc/xdg/autostart (as root) did the trick. It seems there should be a more straightforward way to add or remove programs from autostarting than to have to search the system. But anyway, it worked.

Re: Prevent program from autostarting

Posted: Wed Jul 06, 2016 8:18 am
by Moem
It would be about 10 x easier to help you if you'd mentioned your desktop environment. There is very likely a more straightforward way to add or remove programs from autostart, but we can't direct you there without knowin that.

Re: Prevent program from autostarting

Posted: Wed Jul 06, 2016 8:25 am
by RVDowning
Sorry, KDE 4.14.2. But in looking at System Settings I can find nothing related to autostart.

Re: Prevent program from autostarting

Posted: Wed Jul 06, 2016 8:28 am
by Moem
Sorry, I know nothing about KDE. Apparently it's not in System Settings then, so it'll be somewhere else. Does KDE have a search box in the menu that you can type 'startup' in?

Re: Prevent program from autostarting

Posted: Wed Jul 06, 2016 8:35 am
by RVDowning
Ah, yes. I had never thought to search there. I was just using find in konsole. Got it. Thanks.

Re: Prevent program from autostarting

Posted: Wed Jul 06, 2016 8:41 am
by altair4
Menu > System Settings > Startup and Shutdowwn:
KDE-AutoStart.png
Don't know if your particular application is in the Autostart subsection or in the Session Management section or if it's a system wide default.

I am not a KDE user and I would suspect that KDE users are in the minority in this forum as they are in the Ubuntu forum so what you might want to do is put the fact that you are in your signature so that when you ask a question the folks here know.

Re: Prevent program from autostarting

Posted: Wed Jul 06, 2016 9:20 am
by RVDowning
I had looked in the Autostart subsection but didn't see the program listed. Maybe it should have been put there initially when autostart was desired, in which case removing it would probably have disabled autostart. Thanks for your help.

Re: Prevent program from autostarting

Posted: Wed Jul 06, 2016 10:38 am
by Cosmo.
RVDowning wrote:I think I may have found the autostart in ./etc/xdg/autostart
This path - with the leading dot - does not make sense. In case you mean /etc/xdg/autostart (without the dot): This is not the place, where you should play with.

Re: Prevent program from autostarting

Posted: Wed Jul 06, 2016 2:39 pm
by RVDowning
Well, it was the only autostart folder where I found the program, a .desktop file, so I removed it and all is well. I don't know what program puts stuff there.