update error

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Seth-666
Level 2
Level 2
Posts: 63
Joined: Sun Jun 10, 2012 11:33 am

update error

Post by Seth-666 »

Stupid me .... i tryed to install wordpress...removed everything that i installed apache2 ... rest ... after that i thought that is a god ideea to delete evething that is apache2 / mysql / php from hole system ... and now

Code: Select all

sudo apt-get upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up php7.0-fpm (7.0.4-7ubuntu2.1) ...
Error: The new file /usr/lib/php/7.0/php.ini-production does not exist!
dpkg: error processing package php7.0-fpm (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of php7.0:
 php7.0 depends on libapache2-mod-php7.0 | php7.0-fpm | php7.0-cgi; however:
  Package libapache2-mod-php7.0 is not installed.
  Package php7.0-fpm is not configured yet.
  Package php7.0-cgi is not installed.

dpkg: error processing package php7.0 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 php7.0-fpm
 php7.0
E: Sub-process /usr/bin/dpkg returned an error code (1)
PLs help me i don't want to reinstall my system again ..
User avatar
Fred Barclay
Level 12
Level 12
Posts: 4218
Joined: Sat Sep 13, 2014 11:12 am
Location: USA primarily

Re: update error

Post by Fred Barclay »

Try removing the offending packages:

Code: Select all

sudo apt-get --purge autoremove php7.0-fpm php7.0
BTW: sudo apt-get upgrade is not recommended on Mint due to the risk that updates can bring. You're much better off using the Update Manager. ;)
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein
Seth-666
Level 2
Level 2
Posts: 63
Joined: Sun Jun 10, 2012 11:33 am

Re: update error

Post by Seth-666 »

Fred Barclay wrote:Try removing the offending packages:

Code: Select all

sudo apt-get --purge autoremove php7.0-fpm php7.0
BTW: sudo apt-get upgrade is not recommended on Mint due to the risk that updates can bring. You're much better off using the Update Manager. ;)
thx you ... done... :)
Elizine
Level 1
Level 1
Posts: 29
Joined: Wed Feb 10, 2016 11:29 pm

Re: update error

Post by Elizine »

You have an error in php-fpm.conf as stated in the logs you posted (stripped timestamps):

Code: Select all

ERROR: [/etc/php/7.0/fpm/php-fpm.conf:127] value is NULL for a ZEND_INI_PAR
PHP:  syntax error, unexpected '$' in Unknown on line 1
ERROR: failed to load configuration file '/etc/php/7.0/fpm/php-fpm.conf'
ERROR: FPM initialization failed
Fix your php-fpm.conf and run to test the syntax:

Code: Select all

$ sudo /usr/sbin/php-fpm7.0 --test
Post Reply

Return to “Software & Applications”