[SOLVED] WICKR Secure Messenger Software & Mint 18?

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Clever Name
Level 1
Level 1
Posts: 49
Joined: Tue Mar 29, 2016 9:25 am

[SOLVED] WICKR Secure Messenger Software & Mint 18?

Post by Clever Name » Tue Aug 02, 2016 9:32 pm

Can anyone confirm that the current release of WICKR will install on Mint 18 Sarah Cinnamon?

I used this text messenger successfully under 17.3, but after a fresh install of Mint 18, an attempt to download and install "wickr-me_2.6.0_amd64.deb" from the WICKR website results in an status: Error - "Dependency is not satisfiable libicu52".

The release notes on the WICKR site indicates the following:
Linux 64 Bit
System Requirements:
-64 bit (amd64) Ubuntu desktop system, version 14.04 (Long Term Supported Release)

Could it be that they need to update their software to support the current Ubuntu release... Or, does my system need to be tweaked?
Last edited by Clever Name on Fri Aug 05, 2016 12:40 pm, edited 1 time in total.

User avatar
xenopeek
Level 24
Level 24
Posts: 23117
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: WICKR Secure Messenger Software & Mint 18?

Post by xenopeek » Thu Aug 04, 2016 7:16 am

Linux Mint 18 is based on Ubuntu 16.04 LTS. Those have the package libicu55 with version 55.1-7 of this software. So yes, ideally WICKR would update their package to support Ubuntu 16.04 LTS and libicu55.

As a workaround you can manually install libicu52 from Ubuntu 14.04 LTS and it should install alongside libicu55 without problems. You can download it from here http://packages.ubuntu.com/trusty/libicu52 (take the amd64 for 64 bit; i386 for 32 bit -- you may want to install both on a 64 bit installation). Double-click the file in your file manager after downloading will launch the installer. Mind that you won't get updates for libicu52 so you will have to keep an eye on it yourself if there are any security issues with it on Ubuntu 14.04 LTS that you should upgrade it for, though I doubt that will happen.
Image

Clever Name
Level 1
Level 1
Posts: 49
Joined: Tue Mar 29, 2016 9:25 am

Re: WICKR Secure Messenger Software & Mint 18?

Post by Clever Name » Thu Aug 04, 2016 1:39 pm

Thanks so much for the assist. I was able to load the libicu52 package without issue.

Now the WICKR software errors on "Dependency is not satisfiable: libavutil52 | libavutil54 "

I begin to suspect that this may be a continuing string of errors simply because obsolete files are called.

I'm thinking I should perhaps wait for the Wickr organization to update the linux version of their product to the current version of Ubuntu. These errors possibly could run deep, and while I really like the features Wickr offers, I'm not willing to risk problems which I don't have the skills to reverse.

I did reach out to their support group, but to this point, I'm hearing nothing but crickets.

Thanks again.

User avatar
xenopeek
Level 24
Level 24
Posts: 23117
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: WICKR Secure Messenger Software & Mint 18?

Post by xenopeek » Thu Aug 04, 2016 3:06 pm

Did you reach out to linux-support@wickr.com?

Anyway, here are the dependencies from the package:

Code: Select all

Depends: libsqlcipher0, libuuid1, libicu52, libavutil52|libavutil54, libc6, libssl1.0.0, libx264-142, libglib2.0-0, libpulse0, libxrender1, libgl1-mesa-glx
Recommends: libnotify-bin, gstreamer-plugins0.10-good, gstreamer-plugins0.10-bad, gstreamer-plugins0.10-ugly
From the dependencies on Linux Mint 18 it is missing: libicu52, libavutil52|libavutil54, and libx264-142. From the recommends all the gstreamer ones can't be found on Linux Mint 18.

You can install libavutil52 and libx264-142 again from Ubuntu LTS 14.04 and that should suffice to then install WICKR. Given the package name for those libraries is different from the ones on Ubuntu LTS 16.05 you should be able to without problems install these alongside each other in the same way as you did with the other one. Links where you can download them:
http://packages.ubuntu.com/trusty/libavutil52
http://packages.ubuntu.com/trusty/libx264-142
Image

Clever Name
Level 1
Level 1
Posts: 49
Joined: Tue Mar 29, 2016 9:25 am

{SOLVED} Re: WICKR Secure Messenger Software & Mint 18?

Post by Clever Name » Fri Aug 05, 2016 12:39 pm

Success! Wickr version 2.6.0 is up and running on Mint 18.

Thanks so much for the assistance.

Just to follow up in a single post, the following files were added to my system to allow Mint 18 to run Wickr version 2.6.0.
libicu52
libavutil52 | libavutil54
libx264-142

Thanks for your time and expertise!

Now, on to trying to get a Fitbit dongle recognized and syncing!

Timmi
Level 3
Level 3
Posts: 145
Joined: Tue Mar 10, 2009 1:04 pm

Re: [SOLVED] WICKR Secure Messenger Software & Mint 18?

Post by Timmi » Fri Jun 15, 2018 5:03 pm

update, as someone pointed me here:

The latest WICKR 4.x (3.x onwards) requires Ubuntu 16.04,
but the fact that Mint is based on it holds no cred with Wickr's tech support staff over at zendesk.
See https://support.wickr.com/hc/en-us/requests/37266.
I had it working perfectly on Mint 18.3, and it stopped working, and they wouldn't help, citing that it's not Ubuntu.

So, it works... but if something breaks, there's no help.

Wire is another good alternative - have you tried it? You also have disappearing messages, but you can also make them persist, and have groups admin (which are all paid features in Wickr). https://wire.com/en/download/

Post Reply

Return to “Software & Applications”