[FIXED] Calibre e-book Application Installation Problems.

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
chris_debian
Level 2
Level 2
Posts: 93
Joined: Fri Sep 24, 2010 5:14 am

[FIXED] Calibre e-book Application Installation Problems.

Post by chris_debian »

Hi, all,

I'm running LM Sarah Xfce, and all packages are up to date. I am trying to install Calibre (the e-book tool), and Synaptic, etc, is unable to install it, due to dependency problems.
The output follows:

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 calibre : Depends: python-pyqt5 (>= 5.4.2+dfsg-1ubuntu1) but it is not going to be installed
           Depends: python-pyqt5.qtwebkit but it is not going to be installed
           Depends: python-pyqt5.qtsvg but it is not going to be installed
           Depends: calibre-bin (>= 2.38.0+dfsg-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Has anyone else seen this?

Cheers,

Chris.
Last edited by chris_debian on Sun Aug 14, 2016 11:37 am, edited 1 time in total.
Reasons why you may want to try GNU/Linux:

http://www.whylinuxisbetter.net/

User avatar
richyrich
Level 19
Level 19
Posts: 9063
Joined: Mon May 04, 2009 8:31 pm

Re: Calibre e-book Application Installation Problems.

Post by richyrich »

E: Unable to correct problems, you have held broken packages.
I'm still running Mint 17, but when I see this, my suggestion is always this; :)

Synaptic Package Manager > Menu > Edit > Fix broken packages.

chris_debian
Level 2
Level 2
Posts: 93
Joined: Fri Sep 24, 2010 5:14 am

Re: Calibre e-book Application Installation Problems.

Post by chris_debian »

Hi, Richy.

Thanks for your reply; I should have said, I have already done this, but will try again.

Cheers,

Chris.
Reasons why you may want to try GNU/Linux:

http://www.whylinuxisbetter.net/

User avatar
richyrich
Level 19
Level 19
Posts: 9063
Joined: Mon May 04, 2009 8:31 pm

Re: Calibre e-book Application Installation Problems.

Post by richyrich »

If you installed Calibre from the Repositories, you may want to google "calibre ubuntu 16.04" to see if others have had the same issue . . :)

chris_debian
Level 2
Level 2
Posts: 93
Joined: Fri Sep 24, 2010 5:14 am

Re: Calibre e-book Application Installation Problems.

Post by chris_debian »

Good idea!
Reasons why you may want to try GNU/Linux:

http://www.whylinuxisbetter.net/

Laurent85
Level 16
Level 16
Posts: 6285
Joined: Tue May 26, 2015 10:11 am

Re: Calibre e-book Application Installation Problems.

Post by Laurent85 »

To diagnose the source of the problem post the command results:

Code: Select all

inxi -Srx
apt held
apt search ?broken
apt policy calibre python-pyqt5 python-pyqt5.qtwebkit python-pyqt5.qtsvg calibre-bin
Image

User avatar
eatenimpinia
Level 3
Level 3
Posts: 146
Joined: Thu Sep 10, 2015 9:29 pm

Re: Calibre e-book Application Installation Problems.

Post by eatenimpinia »

What I usually see on the Calibre forums:

http://www.mobileread.com/forums/forumd ... order=desc

is the advice to NOT install from the repositories. The versions there are too old. Instead, go to the Calibre Downloads page and follow the instructions there:

https://calibre-ebook.com/download_linux

Perhaps that version will get around the dependency issues.
Distro: (back to) Linux Mint 17.3 Rosa, Kernel: 4.4.0-51-generic x86_64 (64 bit), Desktop: Cinnamon 2.8.8

chris_debian
Level 2
Level 2
Posts: 93
Joined: Fri Sep 24, 2010 5:14 am

Re: Calibre e-book Application Installation Problems.

Post by chris_debian »

Thanks, Lauren:

inxi -Srx

Code: Select all

System:    Host: aslan Kernel: 4.4.0-21-generic x86_64 (64 bit gcc: 5.3.1)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18 Sarah
Repos:     Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://www.mirrorservice.org/sites/packages.linuxmint.com/packages sarah main upstream import backport
           deb http://ubuntu.positive-internet.com/ubuntu xenial main restricted universe multiverse
           deb http://ubuntu.positive-internet.com/ubuntu xenial-updates main restricted universe multiverse
           deb http://ubuntu.positive-internet.com/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
apt held= Nothing found

apt search ?broken= Nothing found

apt policy calibre python-pyqt5 python-pyqt5.qtwebkit python-pyqt5.qtsvg calibre-bin

Code: Select all

calibre:
  Installed: (none)
  Candidate: 2.38.0+dfsg-1
  Version table:
     2.38.0+dfsg-1 500
        500 http://ubuntu.positive-internet.com/ubuntu xenial/universe amd64 Packages
        500 http://ubuntu.positive-internet.com/ubuntu xenial/universe i386 Packages
python-pyqt5:
  Installed: (none)
  Candidate: 5.5.1+dfsg-3ubuntu2
  Version table:
     5.5.1+dfsg-3ubuntu2 500
        500 http://ubuntu.positive-internet.com/ubuntu xenial/universe amd64 Packages
python-pyqt5.qtwebkit:
  Installed: (none)
  Candidate: 5.5.1+dfsg-3ubuntu2
  Version table:
     5.5.1+dfsg-3ubuntu2 500
        500 http://ubuntu.positive-internet.com/ubuntu xenial/universe amd64 Packages
python-pyqt5.qtsvg:
  Installed: (none)
  Candidate: 5.5.1+dfsg-3ubuntu2
  Version table:
     5.5.1+dfsg-3ubuntu2 500
        500 http://ubuntu.positive-internet.com/ubuntu xenial/universe amd64 Packages
calibre-bin:
  Installed: (none)
  Candidate: 2.38.0+dfsg-1
  Version table:
     2.38.0+dfsg-1 500
        500 http://ubuntu.positive-internet.com/ubuntu xenial/universe amd64 Packages
Does this help?
Reasons why you may want to try GNU/Linux:

http://www.whylinuxisbetter.net/

Laurent85
Level 16
Level 16
Posts: 6285
Joined: Tue May 26, 2015 10:11 am

Re: Calibre e-book Application Installation Problems.

Post by Laurent85 »

chris_debian wrote: calibre:
Installed: (none)
Candidate: 2.38.0+dfsg-1
Version table:
2.38.0+dfsg-1 500
500 http://ubuntu.positive-internet.com/ubuntu xenial/universe amd64 Packages
500 http://ubuntu.positive-internet.com/ubuntu xenial/universe i386 Packages
python-pyqt5:
Installed: (none)
Candidate: 5.5.1+dfsg-3ubuntu2
Version table:
5.5.1+dfsg-3ubuntu2 500
500 http://ubuntu.positive-internet.com/ubuntu xenial/universe amd64 Packages
python-pyqt5.qtwebkit:
Installed: (none)
Candidate: 5.5.1+dfsg-3ubuntu2
Version table:
5.5.1+dfsg-3ubuntu2 500
500 http://ubuntu.positive-internet.com/ubuntu xenial/universe amd64 Packages
python-pyqt5.qtsvg:
Installed: (none)
Candidate: 5.5.1+dfsg-3ubuntu2
Version table:
5.5.1+dfsg-3ubuntu2 500
500 http://ubuntu.positive-internet.com/ubuntu xenial/universe amd64 Packages
calibre-bin:
Installed: (none)
Candidate: 2.38.0+dfsg-1
Version table:
2.38.0+dfsg-1 500
500 http://ubuntu.positive-internet.com/ubuntu xenial/universe amd64 Packages[/code]
Available Calibre version in Mint 18 is 2.55.0+dfsg-1. Mirror ubuntu.positive-internet.com is broken or not up to date :!: Change mirror in the software sources and refresh the repository lists. Then installing Calibre should work.
Image

chris_debian
Level 2
Level 2
Posts: 93
Joined: Fri Sep 24, 2010 5:14 am

Re: Calibre e-book Application Installation Problems.

Post by chris_debian »

Repos updated, Calibre installed. Perfect, well spotted.

Many thanks, Lauren.

Chris.
Reasons why you may want to try GNU/Linux:

http://www.whylinuxisbetter.net/

Post Reply

Return to “Software & Applications”