Intermittent Mouse Failure At X11 Startup

Questions about applications and software
Forum rules
Before you post please read how to get help
pmgant
Level 1
Level 1
Posts: 36
Joined: Sat Mar 01, 2008 1:24 pm

Intermittent Mouse Failure At X11 Startup

Postby pmgant » Wed Mar 04, 2009 5:24 am

I have a VERY intermittent problem with the current Mint distro, when X11 starts there is no mouse movement and none of the mouse buttons work. The LED in the USB mouse is still lit and I have tried another USB port. Other notes are as follows:

1) Cntl-Alt-F5 followed by Cntl-Alt-F7 does not restore operation.

2) Unplugging the mouse then reconnecting it does not restore operation.

3) Cntl-Alt-Backspace to reset X Windows DOES restore operation

Mouse settings in xorg.conf are as follows:

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"

Any ideas? This is not urgent as it happens once every twenty or thirty boots and for now I'm prepared to just restart X11 each time. Any clues would be welcome though.

P M Gant

Husse
Level 23
Level 23
Posts: 19593
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Intermittent Mouse Failure At X11 Startup

Postby Husse » Fri Mar 06, 2009 9:42 am

I'm inclined to say that it's hardware failure of sorts
When this happens look in the logs (System logs) and run dmesg (dmesg -tail)
See if you find anything that looks out of the order - in the System logs you can compare with error free boot (not dmesg)
This is the most difficult to troubleshoot
Image
Don't fix it if it ain't broken, don't break it if you can't fix it


Return to “Software & Applications”

Who is online

Users browsing this forum: No registered users and 20 guests