How to get ffdiaporama on Mint 18?

Questions about applications and software
Forum rules
Before you post please read how to get help
sterremos
Level 1
Level 1
Posts: 4
Joined: Wed Sep 07, 2016 1:47 am

How to get ffdiaporama on Mint 18?

Post by sterremos » Wed Sep 07, 2016 1:58 am

Hello,

i am a newbie, and went about a half year ago from windows to mint 17. everything working well. i work also with the ffdiaporama movie maker, its simple and working fine, in mint 17 I had version 2.1 .
Last week i make the upgrade from mint 17 to 18, try to install ffdiaporama again, through the install process i get version 1.5. and its not working well. so i want to upgrade it again to version 2.1 , this version working fine./


It wont install i have a issue ppa xenial issue ffdiaporama .
how can i get the 2.1 version?

Ron

User avatar
xenopeek
Level 24
Level 24
Posts: 22762
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: How to get ffdiaporama on Mint 18?

Post by xenopeek » Wed Sep 07, 2016 3:32 am

Both PPAs for ffdiaporama are unchanged since early 2014. In fact ffdiaporama has seen no changes since early 2014. Hence no software is available for newer-than-2014 operating systems.

You can try to download the .deb packages from their website http://ffdiaporama.tuxfamily.org/?page_id=10472. Click on "Ubuntu / Linux Mint (Ubuntu based)" to find the downloads. You can try downloading the "Ubuntu 14.04 LTS (Trusty Tahr) / Linux Mint 17" packages. Download 32-bit or 64-bit installer file, whichever matches your architecture. As needed download the openclipart and texturemate packages.

After downloading them double-click them in your file manager to launch the installer. It will warn you if the software is incompatible with Linux Mint 18.
Image

User avatar
phd21
Level 16
Level 16
Posts: 6758
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: How to get ffdiaporama on Mint 18?

Post by phd21 » Wed Sep 07, 2016 1:54 pm

Hi "sterremos",

Welcome to the wonderful world of Linux Mint and its excellent forum !

It would help to know more about your system setup. If you run "inxi -Fxzd" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.

I just read your post and the good replies to it. Here are my thoughts on this as well.

Apparently a superb program that I love to use called "FFdiaporama" version 2.1 or 2.2 for slideshows and movies has not been ported to Linux Mint 18 in either 32-bit or 64-bit versions. I have tested many slideshow and movie makers for people in this forum and for myself, and "FFdiaporama" is the best one I have found. When I was testing LM18 Cinnamon and Mate (32-bit Ubuntu versions), I could not install version 2.1 (or 2.2) of this wonderful application using the PPA or the ".deb" files.

The link below contains someone (JonasCz) who managed to compile version 2.2 of FFdiaporama using a 32-bit machine and has graciously provided links to the easy to install Linux ".deb" files. But unfortunately like me, this user does not have a 64-bit computer to use the QT development environment to compile it for 64-bit computers for Linux Mint 18 users. The 32-bit version would probably work on 64-bit computers now, but I have not yet tested this 32-bit version, and I cannot test the 64-bit version because I do not have a 64-bit computer :( . Version 2.1 might also be more stable than the development version 2.2, there are a couple minor little quirks, read the link below. And, I have another Linux Mint user friend with a 64-bit system that I have asked to compile and install this, then create an easy to install ".deb" file for everyone else to use. Of course, if you have a 64-bit computer and the 64 bit QT development environment installed, and go to this link, then you could compile it yourself and install it. It would be great to have 32-bit and 64-bit versions of the easy to install Linux ".deb" files for versions 2.1 and 2.2 of FFdiaporama for all Linux Mint users.

https://github.com/JonasCz/ffdiaporama-1604-builds


Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

sterremos
Level 1
Level 1
Posts: 4
Joined: Wed Sep 07, 2016 1:47 am

Re: How to get ffdiaporama on Mint 18?

Post by sterremos » Thu Sep 08, 2016 10:36 am

Hi Xenopeek, i have tried this already but it wont be install it on mint 18.

Hi PDH21, indeed its a nice program, i make a one movie on mint 17, works fine , so i like to go futher with it, pitty that it wont works now. :( the version v1.5 don't working well in mint 18.

this is the information from FXZd

This are the results

ystem: Host: wij-SVF1521A7EW Kernel: 4.4.0-21-generic x86_64 (64 bit gcc: 5.3.1)
Desktop: Cinnamon 3.0.6 (Gtk 3.18.9-1ubuntu3)
Distro: Linux Mint 18 Sarah
Machine: System: Sony product: SVF1521A7EW v: C10KR7XV
Mobo: Sony model: VAIO Bios: Insyde v: R0220DA date: 11/18/2013
CPU: Dual core Intel Pentium 2117U (-MCP-) cache: 2048 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7183
clock speeds: max: 1800 MHz 1: 896 MHz 2: 809 MHz
Graphics: Card: Intel 3rd Gen Core processor Graphics Controller
bus-ID: 00:02.0
Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1366x768@60.00hz
GLX Renderer: Mesa DRI Intel Ivybridge Mobile
GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio: Card Intel 7 Series/C210 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
Network: Card-1: Broadcom BCM43142 802.11b/g/n driver: wl bus-ID: 07:00.0
IF: wlp7s0 state: up mac: <filter>
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 0e:00.0
IF: enp14s0 state: down mac: <filter>
Drives: HDD Total Size: 500.1GB (4.6% used)
ID-1: /dev/sda model: HGST_HTS545050A7 size: 500.1GB
Optical: /dev/sr0 model: MATSHITA DVD-RAM UJ8E2
rev: 1.00 dev-links: cdrom,cdrw,dvd,dvdrw
Features: speed: 24x multisession: yes
audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition: ID-1: / size: 455G used: 18G (5%) fs: ext4 dev: /dev/sda2
ID-2: swap-1 size: 4.17GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 50.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 289 Uptime: 21:29 Memory: 1423.7/3830.3MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.421) inxi: 2.2.35


I so also the wy to put it on like the way on https://github.com/JonasCz/ffdiaporama-1604-builds but has no results yet.

the first part going well, the second give a issue
i get the following note

wij@wij-SVF1521A7EW ~ $ qmake ffDiaporama.pro /PREFIX=/usr
Cannot find file: ffDiaporama.pro.


ron

User avatar
phd21
Level 16
Level 16
Posts: 6758
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: How to get ffdiaporama on Mint 18?

Post by phd21 » Thu Sep 08, 2016 7:35 pm

Hi "sterremos", and Anyone Else Interested in this,

A Linux Mint forum friend "Fred Barclay" compiled the 64 bit versions of FFdiaporama which are available for download in the link below:

FFdiaporama 64-bit for Ubuntu 16.04 and Linux Mint 18.

Direct link to 64-bit: ffdiaporama_2.2-1_amd64.deb
https://docs.google.com/uc?id=0B7SC-EcW ... t=download

Direct link to 64-bit: ffdiaporama-rsc_2.2-1_amd64.deb
https://docs.google.com/uc?id=0B7SC-EcW ... t=download

I tried the 32-bit debs for FFdiaporama version 2.2 Dev. in Linux Mint 18 Cinnamon which worked from the link below, click the "Clone Download" button in the upper right to download the archive file and then right click that, extract it to get to the 32-bit ".deb" files. Or, just click the direct shared links below of copies I made to my Google Drive.

Builds of ffDiaporama 2.2 for Ubuntu 16.04 (& Linux Mint 18)
https://github.com/JonasCz/ffdiaporama-1604-builds

Direct link to 32-bit: ffdiaporama_2.2-20160801-1_i386.deb
https://docs.google.com/uc?id=0B7SC-EcW ... t=download

Direct link to 32-bit: ffdiaporama-data_2.2-1_i386.deb
https://docs.google.com/uc?id=0B7SC-EcW ... t=download

When I installed the 32-bit edition of v2.2 devel., It removed my "mint-meta-codecs" (Multi-Media codecs) and installed 61 other dependencies which I hope replaced the important ones from the mint-meta-codecs. And, I did run a quick test on it. I also noticed transition examples were too fast, and the final video test which included some images, and a video, with a sound track mp3, was off; the sound track went off and on, and the final video was erratic. The same video test components worked perfectly in FFdiaporama version 2.1 on Linux Mint 17.3 KDE. But, I am using an ancient 32-bit single core computer with only 2gb ram and a lousy video card, and that was my first test.

I would still like to have the ".deb" files for FFdiaporama stable version 2.1 for Ubuntu 16.04 & Linux Mint 18.

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

sterremos
Level 1
Level 1
Posts: 4
Joined: Wed Sep 07, 2016 1:47 am

Re: How to get ffdiaporama on Mint 18?

Post by sterremos » Fri Sep 09, 2016 8:45 am

Hi,

perhaps it mine bad english , but iwhat i tried still not working in mint 18.
think i must go bck to mint 17.
don't know wh it wont work ,,,,

ron

joemat
Level 1
Level 1
Posts: 1
Joined: Tue Dec 27, 2016 1:25 pm

Re: How to get ffdiaporama on Mint 18?

Post by joemat » Tue Dec 27, 2016 1:29 pm

Hi sterremos,

I had the same problem - because of missing dependencies the current version of ffdiaporama is not working on newer version of Mint.
I created a docker container to solve the problem. Maybe this is also a solution for you.
If you're interested see https://hub.docker.com/r/joemat/docker-ffdiaporama/

joemat

sterremos
Level 1
Level 1
Posts: 4
Joined: Wed Sep 07, 2016 1:47 am

Re: How to get ffdiaporama on Mint 18?

Post by sterremos » Sun Apr 02, 2017 2:38 pm

I have going back to mint 7 for FFdiaporama to use,
i have installed the 2.1 now, i have photos from mine holiday ans i want to make a movie of then.

now have the issue that be converting the file to a 720 or other movie the program closes it at 5 % ,

can someone have a solution for it?

Ron

User avatar
racer-x
Level 4
Level 4
Posts: 256
Joined: Sun Oct 02, 2016 9:05 am
Location: Area 51

Re: How to get ffdiaporama on Mint 18?

Post by racer-x » Sun Apr 02, 2017 3:14 pm


User avatar
phd21
Level 16
Level 16
Posts: 6758
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: How to get ffdiaporama on Mint 18?

Post by phd21 » Thu Jun 21, 2018 10:27 pm

Hi Everyone,

Because ffDiaporama v2.1 is one of my favorite applications and in my opinion still the best and fastest Linux movie-maker and slideshow application, I decided to try and simplify installing ffDiaporama v2.2 and v2.1 in Linux Mint 18.x or newer. Linux Mint 17.x users can just use their PPA. If someone knows how to create an AppImage for this, that would be better. Unfortunately, nobody has taken over this project nor has anyone that knows QT5 updated and compiled ffDiaporama for Linux Mint 18.x Ubuntu 16.04 or newer.


How To install ffDiaporama v2.2 and v2.1 in Linux Mint 18.x or newer
- in order to use v2.1 you must install v2.2 first.

*** If you have already installed ffDiaporama v1.x from the Software Manager or Synaptic Package Manager (SPM), it must be removed completely first through the Software Manager or Synaptic Package Manager (SPM) or using the command below.

Code: Select all

sudo apt purge ffdiaporama ffdiaporama-data
Step 1: Save the archive file "ffDiaporama_v2.2_and_v2.1.tar.gz" from the link below to your Home folder, or move it there before using these instructions, and then right-click the file select extract here.

Download link to "ffDiaporama_v2.2_and_v2.1.tar.gz"
https://mega.nz/#!hdVSHKBa!yT8t6qGKMMj6 ... 5bcchpVPTc

FYI: In the "ffDiaporama_v2.2_and_v2.1.tar.gz" archive file are the installation deb files for
ffDiaporama v2.2 developement both 64-bit and 32-bit and the custom archive folder for ffDiaporama v2.1 stable.

Step 2: install these packages that are required for ffDiaporama to run from the "Synaptic Package Manager (SPM)" or using the console terminal command below, and it would probably be a good idea to restart your system.

Code: Select all

sudo apt-get install kde-runtime libqt5help5 libqt5multimedia5 libqt5multimedia5-plugins libqt5multimediawidgets5
Step 3: Install ffDiaporama v2.2, there are 2 files to install from the ""ffDiaporama_v2.2_and_v2.1" folder or in your Home folder.

64-bit install in this order, just double-click the first one, afterward double-click the second one

ffdiaporama-rsc_2.2-1_amd64.deb
ffdiaporama_2.2-1_amd64.deb

OR
32-bit install in this order, just double-click the first one, afterward double-click the second one

ffdiaporama-data_2.2-1_i386.deb
ffdiaporama_2.2-20160801-1_i386.deb


*** If you have a problem after running the commands and ffDiaporama v2.2 does not show up in your menu, you can bring up a console terminal prompt and type in or copy and paste in the command below for your system:

64-bit

Code: Select all

sudo dpkg --force-all -i ffdiaporama_2.2-1_amd64.deb
or
32-bit

Code: Select all

sudo dpkg --force-all -i ffdiaporama_2.2-20160801-1_i386.deb

Step 4: To install ffDiaporama v2.1 after installing v2.2, make sure the "ffdiapo-2.1.tar.gz" archive file is in your home folder, if it is under ""ffDiaporama_v2.2_and_v2.1" folder move or copy it to your Home folder, the then just right-click this file and choose extract here which will create "ffdiapo-2.1" folder.

Step 5: In that folder are two options for launching and creating a desktop launcher to ffDiaporama v2.1, there is a "ffDiaporama-v21.desktop" file which you can double-click or copy to your "Desktop" folder, and there is a startup script file called "start_ffDiaporama_v2.1.sh" that you can double-click or right-click your Desktop and create a new launcher shortcut and next to the command box browse to this file, click apply and ok, then you can double-click the desktop icon shortcut launcher to run it.


Hope this helps ...
.
ffDiaporama_1.jpg
File Manager showing the archive file and installation files
.
ffDiaporama_2.jpg
File Manager showing ffDiaporama v2.1 folder
.
ffDiaporama_21.jpg
ffDiaporama v2.1 movie maker slide show maker
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
phd21
Level 16
Level 16
Posts: 6758
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: How to get ffdiaporama on Mint 18?

Post by phd21 » Wed Jul 04, 2018 5:32 pm

Hi Everyone,

For Linux Mint 19 users, "ffDiaporama" version 2.1 stable is available in the Software Manager or Synaptic Package Manager (SPM), yeah... I had to restart or at least logout and log back in, but it works!

I don't know who to thank for getting "ffDiaporama v2.1" into the Linux Mint 19 software repositories, but whoever it is, Thank you.

Is it possible to add ffDiaporama v2.1 to the Mint 18.x repos now?
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

avb12
Level 1
Level 1
Posts: 12
Joined: Sat Jul 07, 2018 1:03 am

Re: How to get ffdiaporama on Mint 18?

Post by avb12 » Sat Jul 07, 2018 1:25 am

In my Linux Mint 19 Cinnamon the ffDiaporama 2.1 program from the package Manager does not start because of the error of reading the ffDiaporama.xml file. ffDiaporama 2.2 requires libavformat-ffmpeg56, which is not present in LinuxMint 19. That's sad.

User avatar
phd21
Level 16
Level 16
Posts: 6758
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: How to get ffdiaporama on Mint 18?

Post by phd21 » Sat Jul 07, 2018 1:44 am

HI avb12,

For Linux Mint 19 users, you have to install "ffmpeg", "x264", "x265" from the "Synaptic Package Manager (SPM)" for "ffDiaporama" and it is used by many other software packages as well. You do not need to install "ffDiaporama 2.2" at all like Linux Mint 18.x users currently have to do in order to run "ffDiaporama 2.1".

The Linux Mint 19 "ffDiaporama 2.1" was compiled with QT v5.9 and Linux Mint 18 still uses QT v5.6, so It would be nice for whoever compiled "ffDiaporama 2.1" for Linux Mint 19.x (Ubuntu 18.04) using QT v5.9 to also compile it under Linux Mint 18.x (Ubuntu 16.04) with QT v5.6 and provide those deb installation files.

I have "ffDiaporama v2.1" (64-bit) installed and working in Linux Mint 19 Cinnamon from its "Synaptic Package Manager (SPM)", so maybe there is another package that needs to be installed regarding your "xml" message that I already have installed. If you bring up a console terminal prompt and run "ffDiaporama" from that, copy and paste the results back here, that should help tell us what additional package(s) need to be installed that you might be missing.

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

avb12
Level 1
Level 1
Posts: 12
Joined: Sat Jul 07, 2018 1:03 am

Re: How to get ffdiaporama on Mint 18?

Post by avb12 » Sat Jul 07, 2018 3:06 am

Yes, I have "ffmpeg", "x264", "x265"installed. Here's what's in the terminal:
avb@avb-VirtualBox:~$ ffDiaporama
[09:48:42.941:INFO] QT Version:5.9.5
[09:48:43.017:INFO] StartupDir /home/avb
[09:48:43.017:INFO] Application not found in directory /home/avb/BUILDVERSION.txt
[09:48:43.017:INFO] Application not found in directory /../../ffDiaporama/BUILDVERSION.txt
[09:48:43.017:INFO] Application not found in directory /../ffDiaporama/BUILDVERSION.txt
[09:48:43.017:INFO] Application not found in directory /opt/share/ffDiaporama/BUILDVERSION.txt
[09:48:43.034:INFO] Application found in directory /usr/share/ffDiaporama/BUILDVERSION.txt
[09:48:43.034:INFO] Set working path to /usr/share/ffDiaporama
[09:48:43.041:INFO] Start ffDiaporama 2.1 (20140209) ...
qt5ct: using qt5ct plugin
[09:48:43.679:INFO] Parse command line ...
[09:48:43.679:INFO] Set LogLevel to INFORMATION
[09:48:43.679:INFO] Start GUI ...
[09:48:43.743:INFO] Start ...
libpng warning: iCCP: known incorrect sRGB profile
[09:48:43.826:INFO] Init home user database...
QSqlDatabase: QSQLITE driver not loaded
QSqlDatabase: available drivers:
[09:48:43.878:INFO] Init translations...
[09:48:43.878:INFO] Language "ru" not found : switch to english
[09:48:43.878:INFO] Read configuration file /usr/share/ffDiaporama/ffDiaporama.xml
[09:48:43.914:INFO] Read configuration file /usr/share/ffDiaporama/Devices.xml
[09:48:43.958:INFO] Read configuration file /home/avb/.ffDiaporama/ffDiaporama.xml
[09:48:43.958:WARNING] Error reading configuration file /home/avb/.ffDiaporama/ffDiaporama.xml
Ошибка сегментирования (стек памяти сброшен на диск) - sergmentation fault

avb12
Level 1
Level 1
Posts: 12
Joined: Sat Jul 07, 2018 1:03 am

Re: How to get ffdiaporama on Mint 18?

Post by avb12 » Sat Jul 07, 2018 3:35 am

Strange, same problem with the liveCD of linux mint 19 cinnamon in VirtualBox

User avatar
phd21
Level 16
Level 16
Posts: 6758
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: How to get ffdiaporama on Mint 18?

Post by phd21 » Sat Jul 07, 2018 3:38 am

HI avb12,

You could try removing "ffDiaporama" completely (purging) and re-installing it. Looks Like you have a corrupted setup file, or it does not like your default language, or maybe even a hardware issue with "segmentation fault". I just tried it in Linux Mint 19 Cinnamon 64-bit, and it is working great. Maybe install "kde-runtime" which is safe to do in all editions of Linux Mint and restart then retry it.

avb12 wrote:[09:48:43.958:WARNING] Error reading configuration file /home/avb/.ffDiaporama/ffDiaporama.xml
Ошибка сегментирования (стек памяти сброшен на диск) - sergmentation fault
Command to edit the file

Code: Select all

xed ~/.ffDiaporama/ffDiaporama.xml
Here is the content of my "ffDiaporama.xml" file which you can edit your existing file and delete what is in it and paste the text below into that one, save the file, and retry ffDiaporama.

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE ffDiaporama>
<Configuration>
    <GlobalPreferences Crop1088To1080="1" RasterMode="1" OpenWEBNewVersion="0" Smoothing="1" CheckConfigAtStartup="0" RememberLastDirectories="1" RestoreWindow="1" Deinterlace="0" DisableTooltips="0" ForceLanguage=""/>
    <CacheMemory MemCacheMaxValue="512"/>
    <EditorOptions WindowDisplayMode="0" UseNetworkProxy="0" RandomTransition="1" DefaultTransitionDuration="1000" NetworkProxyUser="" NetworkProxy="" PreviewFPS="12.500000" AppendObject="0" FramingRuler="1" DefaultTransitionSubType="1" NetworkProxyPort="0" AskUserToRemove="1" PreviewSamplingRate="44100" PartitionMode="0" NetworkProxyPWD="" SDLAudioOldMode="0" DlgSlideRuler="255" MaxVideoPreviewHeight="360" NewTimelineHeight="144" DefaultTransitionFamilly="0" DisplayUnit="1" WikiFollowInterface="1" ThumbRuler="221" DefaultFraming="2"/>
    <ProjectDefault DefaultAuthor="" ID3V2Comptatibility="0" ShortDateFormat="MM/dd/yyyy" DistanceUnit="0" NoShotDuration="6000" FixedDuration="3000" DefaultTitleFilling="0" DefaultTransitionSpeedWave="0" DefaultBlockAnimSpeedWave="0" DefaultAlbum="" ImageGeometry="1" DefaultImageAnimSpeedWave="0">
        <DefaultBlock_Text BackGST="###GLOBALSTYLE###:6" ShapeST="###GLOBALSTYLE###:1" AutoLocking="0" TextST="###GLOBALSTYLE###:0" AutoSizePos="5"/>
        <DefaultBlockSL_IMG ShapeST="###GLOBALSTYLE###:1" TextST="###GLOBALSTYLE###:4">
            <IMG_GEO_1 AutoCompo="2" AutoFraming="14"/>
            <IMG_GEO_2 AutoCompo="2" AutoFraming="8"/>
            <IMG_GEO_3 AutoCompo="2" AutoFraming="4"/>
            <IMG_GEO_4 AutoCompo="2" AutoFraming="4"/>
            <IMG_GEO_5 AutoCompo="2" AutoFraming="4"/>
            <IMG_GEO_6 AutoCompo="2" AutoFraming="4"/>
        </DefaultBlockSL_IMG>
        <DefaultBlockBA_IMG ShapeST="###GLOBALSTYLE###:1" TextST="###GLOBALSTYLE###:4">
            <IMG_GEO_1 AutoCompo="5" AutoFraming="14"/>
            <IMG_GEO_2 AutoCompo="5" AutoFraming="8"/>
            <IMG_GEO_3 AutoCompo="1" AutoFraming="4"/>
            <IMG_GEO_4 AutoCompo="1" AutoFraming="4"/>
            <IMG_GEO_5 AutoCompo="1" AutoFraming="4"/>
            <IMG_GEO_6 AutoCompo="1" AutoFraming="4"/>
        </DefaultBlockBA_IMG>
    </ProjectDefault>
    <RenderDefault DefaultSmartphoneType="0" DefaultSmartphoneModel="25" DefaultExportThumbnail="1" VideoBitRate="2500" DefaultSoundtrackFormat="5" DefaultSoundtrackBitRate="128000" DefaultMultimediaModel="8" DefaultSoundtrackFreq="44100" DefaultForTheWEBType="0" DefaultLossLess="7" DefaultExportXBMCNfo="1" DefaultSoundtrackAudioCodec="libmp3lame" VideoCodec="MPEG4" AudioCodec="aac" ImageSize="2" DefaultMultimediaType="0" AudioFreq="0" Format="4" AudioBitRate="160" Language="und" DefaultNameProjectName="1" Standard="0" DefaultForTheWEBModel="15"/>
    <Models ThumbnailModelsIndex="190000" DefaultThumbnailName="100000"/>
    <RecentFiles/>
</Configuration>

Hope this helps...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

avb12
Level 1
Level 1
Posts: 12
Joined: Sat Jul 07, 2018 1:03 am

Re: How to get ffdiaporama on Mint 18?

Post by avb12 » Sat Jul 07, 2018 4:03 am

Hi phd21

Alas, the result is the same, even in linux mint 19 Xfce laptop. That's a puzzle :roll:

avb12
Level 1
Level 1
Posts: 12
Joined: Sat Jul 07, 2018 1:03 am

Re: How to get ffdiaporama on Mint 18?

Post by avb12 » Sat Jul 07, 2018 7:41 am

Hurray, it works.
A miracle happened.
Not for good reason today 7 07.
I tried to compile the program as specified in the readme file from the source and has installed for this all the libraries that are specified for this. The compilation failed due to a problem with the stdlib.h, however, after that the program installed from the Synaptic started. We have to figure out which libraries were really needed.

User avatar
phd21
Level 16
Level 16
Posts: 6758
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: How to get ffdiaporama on Mint 18?

Post by phd21 » Sat Jul 07, 2018 4:20 pm

HI avb12,

That's cool you have it working.

Were you able to compile it? All you had to do was install the "stdlib.h" (libpython-stdlib, python2-stdlib, python3-stdlib, etc...) from the "Synaptic Package Manager (SPM)" and it worked? I must have had those packages already installed when I installed other software.

I still do not know of any other Linux "movie makers" or "Slideshow" software packages that are as simple to use and as fully featured as "ffDiaporama v2.1", so it is worth any hassles to install it at least for me.

All the video editors can make videos and some have built-in slideshow makers, but none are as simple or as well designed as "ffDiaporama". It is too bad the original developers are not still working on this, or that others skilled in this type of software have not taken over this project.

FYI: There are a couple of Linux deb files for additional "texture" and "clipart" that can be installed after installing the main application. They can also be extracted and copied into the "ffDiaporama" folder. These are already in the archive file I provided for Linux Mint 18.x users and I guess people could add their own as well.

ffdiaporama-openclipart
http://ffdiaporama.tuxfamily.org/script ... .1_all.deb

ffdiaporama-texturemate
http://ffdiaporama.tuxfamily.org/script ... .1_all.deb
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

avb12
Level 1
Level 1
Posts: 12
Joined: Sat Jul 07, 2018 1:03 am

Re: How to get ffdiaporama on Mint 18?

Post by avb12 » Sat Jul 07, 2018 5:52 pm

Hi phd21,

I still stay with linux mint KDE 18.3, but I think move to Cinnamon, so I watch what and how it works in VirtualBox.

Yes, ffDiaporama is one of the best video applications and it is a pity that it is no longer developed.

Yes, I wanted to compile version 2.1 from sources, I installed as required a lot of packages from synaptyc, but at the make stage I got a message about the absence of stdlib.h, although there were four of them in the system. Then I decided to run again the previously installed ffDiaporama2.1 and it worked. Then run a liveCd of linux mint and 19 were sequentially set different packages until I found one that ffDiaporama has started. This is the libqt5sql5-sqlite package. I wrote about this on forum (viewtopic.php?f=47&t=272650&sid=50c68cd ... d3de756a1f). I believe this package should be in the ffdiaporama 2.1 dependencies when installed via synaptic.

Post Reply

Return to “Software & Applications”