URLs slow to open in the browser.

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
draconicrose
Level 1
Level 1
Posts: 40
Joined: Sun Sep 29, 2013 1:53 pm
Location: Portugal
Contact:

URLs slow to open in the browser.

Post by draconicrose » Sat Oct 01, 2016 7:33 pm

Whenever I click a link on any application (Skype, Discord, a pdf, as long as it's not within Chrome), it takes between a few seconds to nearly half a minute for the browser to respond and open a new tab (page loading then proceeds at normal speeds). This happens with both Chrome and Firefox, which leads me to believe that it isn't a browser problem. I've tried googling, but no matter how I word it I can't find anything related to this. I'm currently using Chrome 53.

Code: Select all

System:    Host: DragonNest Kernel: 4.4.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.0.7 (Gtk 3.18.9-1ubuntu3.1)
           Distro: Linux Mint 18 Sarah
Machine:   Mobo: Intel model: DG41RQ v: AAE54511-202
           Bios: Intel v: RQG4110H.86A.0011.2009.0626.1639 date: 06/26/2009
CPU:       Dual core Intel Core2 Duo E8400 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 12000
           clock speeds: max: 2997 MHz 1: 1998 MHz 2: 1998 MHz
Graphics:  Card: NVIDIA GK208 [GeForce GT 730] bus-ID: 01:00.0
           Display Server: X.Org 1.18.3 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz, 1280x1024@60.02hz
           GLX Renderer: GeForce GT 730/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 361.42 Direct Rendering: Yes
Audio:     Card-1 Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GK208 HDMI/DP Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-3 JMTek LLC. audio controller
           driver: USB Audio usb-ID: 005-002
           Sound: Advanced Linux Sound Architecture v: k4.4.0-38-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 500.1GB (30.2% used)
           ID-1: /dev/sda model: WDC_WD5000AAKS size: 500.1GB
Partition: ID-1: / size: 202G used: 134G (70%) fs: ext4 dev: /dev/sda4
           ID-2: swap-1 size: 8.39GB used: 1.49GB (18%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 44.0C mobo: 33.0C gpu: 0.0:55C
           Fan Speeds (in rpm): cpu: 1205 fan-1: 0 fan-3: 0 fan-4: 0 fan-5: 0
Info:      Processes: 206 Uptime: 9:35 Memory: 3263.2/3947.6MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.421) inxi: 2.2.35 

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: URLs slow to open in the browser.

Post by Cosmo. » Sun Oct 02, 2016 6:55 am

Create a fresh new user account. Same there?

draconicrose
Level 1
Level 1
Posts: 40
Joined: Sun Sep 29, 2013 1:53 pm
Location: Portugal
Contact:

Re: URLs slow to open in the browser.

Post by draconicrose » Mon Oct 17, 2016 4:42 am

Sorry to take so long to reply. A fresh user account doesn't seem to have this problem, but I would prefer not to start fresh with a new user.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: URLs slow to open in the browser.

Post by Cosmo. » Mon Oct 17, 2016 6:16 am

This was a test to find out, if the culprit is in your system or in the account.

We will at first see, if the exist ownership problems:
Mark the following command and press ctrl-c

Code: Select all

find $HOME ! -user $USER -type f
open a terminal and press ctrl-shift-V
Mark the complete result inclusive the command with the mouse and press ctrl-shift-C
In the forum click the Code-button above the text box, than press ctrl-v.

Report in case, that there is no output.

User avatar
Pjotr
Level 21
Level 21
Posts: 13161
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: URLs slow to open in the browser.

Post by Pjotr » Mon Oct 17, 2016 6:21 am

Apart from Cosmo.'s advice: disable as many add-ons and extensions as you can reasonably miss:
https://sites.google.com/site/easylinux ... stmas-tree
(item 7, right column)
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

draconicrose
Level 1
Level 1
Posts: 40
Joined: Sun Sep 29, 2013 1:53 pm
Location: Portugal
Contact:

Re: URLs slow to open in the browser.

Post by draconicrose » Mon Oct 17, 2016 5:41 pm

Cosmo. wrote:-snip-

Code: Select all

draconicrose@DragonNest ~ $ find $HOME ! -user $USER -type f
find: ‘/home/draconicrose/.cache/dconf’: Permission denied
find: ‘/home/draconicrose/.gconf/apps/gnome-settings’: Permission denied
find: ‘/home/draconicrose/.gconf/apps/gedit-2’: Permission denied
/home/draconicrose/.gnome2/gedit/gedit-2
/home/draconicrose/.gnome2/accels/gedit
find: ‘/home/draconicrose/.config/enchant’: Permission denied
/home/draconicrose/.local/share/gvfs-metadata/root-e1653c67.log
/home/draconicrose/.local/share/gvfs-metadata/root
/home/draconicrose/.local/share/Trash/files/python3/Python-3.5.2/build/scripts-3.5/2to3-3.5
/home/draconicrose/.local/share/Trash/files/python3/Python-3.5.2/build/scripts-3.5/pyvenv-3.5
/home/draconicrose/.local/share/Trash/files/python3/Python-3.5.2/build/scripts-3.5/idle3.5
/home/draconicrose/.local/share/Trash/files/python3/Python-3.5.2/build/scripts-3.5/pydoc3.5
/home/draconicrose/.local/share/Trash/files/python3/Python-3.5.2/Lib/encodings/__pycache__/koi8_r.cpython-35.opt-1.pyc
/home/draconicrose/.local/share/Trash/files/python3/Python-3.5.2/Lib/encodings/__pycache__/koi8_r.cpython-35.opt-2.pyc
/home/draconicrose/.local/share/Trash/files/python3/Python-3.5.2/Lib/encodings/__pycache__/cp1252.cpython-35.opt-1.pyc
/home/draconicrose/.local/share/Trash/files/python3/Python-3.5.2/Lib/encodings/__pycache__/cp1252.cpython-35.opt-2.pyc
/home/draconicrose/.local/share/Trash/files/python3/Python-3.5.2/Lib/ensurepip/__pycache__/__main__.cpython-35.pyc
/home/draconicrose/.local/share/Trash/files/Player.4.log
find: ‘/home/draconicrose/.gvfs’: Permission denied

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: URLs slow to open in the browser.

Post by Cosmo. » Mon Oct 17, 2016 5:43 pm

As expected. To correct the wrong ownership:
Mark the following command completely and make sure, that you do not miss any sign, than press ctrl-c

Code: Select all

find /home/$SUDO_USER ! -user $SUDO_USER -exec chown $SUDO_USER:$SUDO_USER '{}' \;
Open a terminal and enter

Code: Select all

sudo -i
and press the Enter-key; you get prompted for your password, enter it.
Now still in the same terminal press ctrl-shift-V
Run this command and wait until it has finished. It does not produce a readable output.
Press twice ctrl-d
Immediately log off and back into your account.

draconicrose
Level 1
Level 1
Posts: 40
Joined: Sun Sep 29, 2013 1:53 pm
Location: Portugal
Contact:

Re: URLs slow to open in the browser.

Post by draconicrose » Mon Oct 17, 2016 6:48 pm

The command is still running. In the meanwhile, could you explain why the permissions were wrong? None of the files it said permission denied on seemed to have anything to do with chrome or what application opens what.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: URLs slow to open in the browser.

Post by Cosmo. » Tue Oct 18, 2016 5:18 am

Wrong ownership has nearly always the same reason: Wrong usage of the command sudo. You must never launch any(!) graphical program via sudo, but only - and only, if really needed - via gksudo. Doing this wrong will create files and folders with wrong ownership, which can lead to several kind of problems - until to the point, that you can possibly not even log in into your account.

User avatar
Pjotr
Level 21
Level 21
Posts: 13161
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: URLs slow to open in the browser.

Post by Pjotr » Tue Oct 18, 2016 7:00 am

As Cosmo. says. The problem is, that there are so many Ubuntu how-to's on the web, which contain sudo gedit. One of the nasty consequences of the decision by the Ubuntu developers, several years ago, to drop gksu..... :(
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

draconicrose
Level 1
Level 1
Posts: 40
Joined: Sun Sep 29, 2013 1:53 pm
Location: Portugal
Contact:

Re: URLs slow to open in the browser.

Post by draconicrose » Tue Oct 18, 2016 9:07 am

Right. I used to do sudo until I learned better. Still don't know how it relates to opening links though. Fixing the permissions seems to have made it better but there's still a noticeable delay.

Note that it doesn't happen on Windows, my laptop, or a new user account. (So I'm definitely rejecting the "too many add-ons" theory)

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: URLs slow to open in the browser.

Post by Cosmo. » Tue Oct 18, 2016 9:46 am

draconicrose wrote:Right. I used to do sudo until I learned better. Still don't know how it relates to opening links though. Fixing the permissions seems to have made it better but there's still a noticeable delay.
We take a look, if the FF-profile is giving the remaining problem:
To find this out do the following:
Close FF.
Open your file-manager and make hidden files visible (press ctrl-h).
Rename the folder .mozilla to .mozilla.bck
Start FF, this will create automatically a new FF-profile.
Check.

To get back to your old profile:
Close FF.
Delete the new folder .mozilla
Rename the folder .mozila.bck back to .mozilla
Start FF. Done.

draconicrose
Level 1
Level 1
Posts: 40
Joined: Sun Sep 29, 2013 1:53 pm
Location: Portugal
Contact:

Re: URLs slow to open in the browser.

Post by draconicrose » Tue Oct 18, 2016 2:18 pm

I barely use Firefox. My main browser is chrome.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: URLs slow to open in the browser.

Post by Cosmo. » Tue Oct 18, 2016 4:49 pm

I have read "Firefox" in the starting post.

draconicrose
Level 1
Level 1
Posts: 40
Joined: Sun Sep 29, 2013 1:53 pm
Location: Portugal
Contact:

Re: URLs slow to open in the browser.

Post by draconicrose » Tue Oct 18, 2016 4:51 pm

Yes because I tried to see if the problem was chrome. I didn't mention it as a main browser. In fact I pointed out that I'm currently using chrome 53. I appreciate your help, but please read what I wrote.

Post Reply

Return to “Software & Applications”