[Solved] Cinnamon 18 - Macbook pro 13" has problems recovering from standby/suspend/sleep

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
ulusu
Level 1
Level 1
Posts: 10
Joined: Wed Jun 06, 2012 6:15 pm
Location: Dreiländereck Saar-Lor-Lux

[Solved] Cinnamon 18 - Macbook pro 13" has problems recovering from standby/suspend/sleep

Post by ulusu » Sun Oct 16, 2016 3:58 pm

Hello all

I'm sorry if this is not the right place for this topic.

After quite some time now I decided to install a Mint Cinnamon edition again. I use now a Macbook pro 13" with OSX Mavericks, Windows 10 and Kubuntu 14.04 and when I installed Linux Mint 18 Cinnamon along with the others it was a very good experience. Even the temperature is a dream compared to the other OS's.

Then I began to use the standby mode by closing the lid and I saw that the Mac has problems to recover from standby. The screen is dark (but I can see the login screen in the dark) and after closing and opening the lid two or three times it is back again but flickering. Then after login everything is back to normal until the next standby.

I hope for some help.

Regards,
ulusu
Last edited by ulusu on Sun Nov 06, 2016 3:37 pm, edited 2 times in total.

ulusu
Level 1
Level 1
Posts: 10
Joined: Wed Jun 06, 2012 6:15 pm
Location: Dreiländereck Saar-Lor-Lux

Re: Cinnamon 18 - Macbook pro 13" has problems recovering from standby/suspend/sleep

Post by ulusu » Sun Nov 06, 2016 3:35 pm

After reading a lot of threads I found the solutions for my problem. I applied two different settings. One to tell GRUB were to resume from suspend and the other one to disable all usb devices which could wake up my Macbook and therefor interfere with the suspend/sleep action.

Tell GRUB were to resume from suspend
viewtopic.php?f=90&t=143909

Code: Select all

cat /etc/initramfs-tools/conf.d/resume
will output something similar to this:

Code: Select all

RESUME=UUID=111x1xxx-11xx-1x111-11x1-1111111xxxxx
then check grub:

Code: Select all

cat /etc/default/grub |grep GRUB_CMDLINE
if the output looks like this:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
then edit grub:

Code: Select all

sudo nano /etc/default/grub

Code: Select all

GRUB_CMDLINE_LINUX="RESUME=UUID=111x1xxx-11xx-1x111-11x1-1111111xxxxx"
Disable all usb devices which could wake up my Macbook
viewtopic.php?t=151127

Code: Select all

cat /proc/acpi/wakeup
in my case it will have this output:

Code: Select all

Device	S-state	  Status   Sysfs node
P0P2	  S3	*disabled  pci:0000:00:01.0
PEG1	  S3	*disabled
EC	  S4	*disabled  platform:PNP0C09:00
GMUX	  S3	*disabled  pnp:00:03
HDEF	  S3	*disabled  pci:0000:00:1b.0
RP01	  S3	*disabled  pci:0000:00:1c.0
GIGE	  S3	*disabled  pci:0000:01:00.0
SDXC	  S3	*disabled  pci:0000:01:00.1
RP02	  S3	*disabled  pci:0000:00:1c.1
ARPT	  S3	*disabled  pci:0000:02:00.0
RP03	  S3	*disabled  pci:0000:00:1c.2
EHC1	  S3	*disabled  pci:0000:00:1d.0
EHC2	  S3	*disabled  pci:0000:00:1a.0
XHC1	  S3	*enabled   pci:0000:00:14.0
ADP1	  S4	*disabled  platform:ACPI0003:00
LID0	  S4	*enabled   platform:PNP0C0D:00
so I disabled the 3 usb devices:

Code: Select all

sudo nano /etc/rc.local

Code: Select all

#!/bin/sh -e
#
# rc.local
# 
echo "EHC1" > /proc/acpi/wakeup
echo "EHC2" > /proc/acpi/wakeup
echo "XHC1" > /proc/acpi/wakeup 
exit 0
The Macbook will be waked up by opening the lid.
As this solution has worked for me I would like to share it with other users.

Best regards,
ulusu

ulusu
Level 1
Level 1
Posts: 10
Joined: Wed Jun 06, 2012 6:15 pm
Location: Dreiländereck Saar-Lor-Lux

Re: [Solved] Cinnamon 18 - Macbook pro 13" has problems recovering from standby/suspend/sleep

Post by ulusu » Wed Nov 09, 2016 6:16 pm

After some time the issue was back.

I modified /etc/default/grub according to this thread
http://unix.stackexchange.com/questions ... om-suspend

So I removed the resume command

Code: Select all

#GRUB_CMDLINE_LINUX="RESUME=UUID=54aa1dd5-1e7b-4280-8d77-06e3caac42e8"
and restored the original line

Code: Select all

GRUB_CMDLINE_LINUX=""
then I added the acpi command in the following line

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=Linux acpi_backlight=vendor quiet splash"
I still left the /etc/rc.local file edited as it was in order to disable the wake up by the usb devices.
Until now resume from suspend works like it should.

Regards,
ulusu

ulusu
Level 1
Level 1
Posts: 10
Joined: Wed Jun 06, 2012 6:15 pm
Location: Dreiländereck Saar-Lor-Lux

Re: [Solved] Cinnamon 18 - Macbook pro 13" has problems recovering from standby/suspend/sleep

Post by ulusu » Thu Dec 15, 2016 12:12 pm

So after more than a month after editing Grub and /etc/rc.local resume from sleep/suspend continues to work like it should :D

For recap:

Add the right ACPI command for the Macbook to Grub

Code: Select all

sudo nano /etc/default/grub

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=Linux acpi_backlight=vendor quiet splash"
then disable all usb devices which could wake up the Macbook editing /etc/rc.local

Code: Select all

sudo nano /etc/rc.local

Code: Select all

#!/bin/sh -e
#
# rc.local
#
echo "EHC1" > /proc/acpi/wakeup
echo "EHC2" > /proc/acpi/wakeup
echo "XHC1" > /proc/acpi/wakeup
exit 0
The Macbook will be waked up by opening the lid.

ulusu

peterldg
Level 2
Level 2
Posts: 63
Joined: Sat Aug 10, 2013 11:30 am

Re: [Solved] Cinnamon 18 - Macbook pro 13" has problems recovering from standby/suspend/sleep

Post by peterldg » Tue Mar 14, 2017 10:17 pm

Thanks! I've been dealing with this issue for two years and it's now resolved!

Post Reply

Return to “Software & Applications”