Mintupdate: Impossible to install security updates

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Sorensei
Level 4
Level 4
Posts: 257
Joined: Tue Jan 16, 2007 8:24 am
Location: Switzerland

Mintupdate: Impossible to install security updates

Post by Sorensei »

Hi everyone,

A few issues with Mintupdate...

It shows me the updates available (refreshing works) but doesn't ask me for my password and when I try applying the updates after a few seconds I get the message at the bottom of the window: Impossible d'installer les mises à jour de sécurité (Impossible to install security updates).
It doesn't update anything (even non-security related), and then I get the red cross on the shield icon.

Usually doublecklicking one the tray shield opens it - now I need to rightclick and open it that way.

Trying to ask for the sources doesn't work either. I tried reinstalling Mintupdate, no change.

I have a clean install of LM 18, KDE edition...

Any ideas?

Thanks!
I don't have a solution, but I do admire the problem.
deepakdeshp
Level 18
Level 18
Posts: 8848
Joined: Sun Aug 09, 2015 10:00 am

Re: Mintupdate: Impossible to install security updates

Post by deepakdeshp »

In software soures you have to choose the fastest mirror.
Choose a mirror and waIt for some time. You will be shown download speeds pr if the mirror is unreachable.

Choose the fastest mirrors, then update the system.
This is how I do oy in Cinnamon
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 20 Cinnamon 64 bit with AMD A8/7410 / 8GB
Mint 20 Cinnamon AMD Ryzen3500U
User avatar
Sorensei
Level 4
Level 4
Posts: 257
Joined: Tue Jan 16, 2007 8:24 am
Location: Switzerland

Re: Mintupdate: Impossible to install security updates

Post by Sorensei »

Thanks for your reply!

Trying to select sources doesn't work through Mintupdate, but I was able to do it through Synaptic.

Didn't change anything, I'm sorry. What bothers me is that Mintupdate should ask for the password but doesn't.

Might be why the updates are not applied?
I don't have a solution, but I do admire the problem.
marco
Level 1
Level 1
Posts: 7
Joined: Fri Sep 30, 2016 4:14 pm

Re: Mintupdate: Impossible to install security updates

Post by marco »

Dear Sorensei,
I have a similar problem, that I can't solve in a satisfying way :

If I run "sudo mintupdate" from a terminal, the install process executes correctly and end with no problem.

Else, when clicked on "installer les mises à jour", I have the following result in /var/log/auth.log
[The user is "marco"]
May 5 15:01:13 loupgarou2016 polkitd(authority=local): Registered Authentication Agent for unix-process:15120
:1734467 (system bus name :1.104 [pkexec /usr/sbin/synaptic --hide-main-window --non-interactive --parent-wind
ow-id 81788944 -o Synaptic::closeZvt=true --progress-str Veuillez patienter, cela peut prendre un certain temp
s --finish-str La mise à jour est terminée --set-selections-file /tmp/tmp4bw80h0n], object path /org/freedeskt
op/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
May 5 15:01:13 loupgarou2016 polkitd(authority=local): Unregistered Authentication Agent for unix-process:151
20:1734467 (system bus name :1.104, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.
UTF-8) (disconnected from bus)
May 5 15:01:13 loupgarou2016 polkitd(authority=local): Operator of unix-process:15120:1734467 FAILED to authe
nticate to gain authorization for action com.ubuntu.pkexec.synaptic for unix-process:15120:1734467 [<unknown>]
(owned by unix-user:marco)

If I use another user (with similar rights : groups = adm cdrom sudo dip plugdev lpadmin sambashare) it works fine. So I don't know were the authentication configuration for the user "marco" is wrong, but I didn't succeed in solve this annoying problem.

If anybody has a idea, he/she is welcome !

thanks
User avatar
Moem
Level 20
Level 20
Posts: 12343
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Mintupdate: Impossible to install security updates

Post by Moem »

marco wrote:
Sat May 05, 2018 9:11 am
If I run "sudo mintupdate" from a terminal, the install process executes correctly and end with no problem.
Well, that's most likely what cause the problem. Mintupdate is a graphical application and should never be run with sudo; doing so will cause problems with ownership (files written by that application will now be owned by root). If you feel the need to run a graphical application with elevated rights (which is usually not needed because they will generally ask for authenthication if and when they need it) you should always use gksudo. On KDE, that's kdesudo.

Mod note:
I'll leave this in place for now, but as per the forum rules, please refrain from reviving old threads in the future. If you need to reference another thread, use a link to point to it. A new question deserves a new thread. Thanks!
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
marco
Level 1
Level 1
Posts: 7
Joined: Fri Sep 30, 2016 4:14 pm

Re: Mintupdate: Impossible to install security updates

Post by marco »

Lots of thanks Moem, I'll use gksudo or equivalent.
Best regards
User avatar
Moem
Level 20
Level 20
Posts: 12343
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Mintupdate: Impossible to install security updates

Post by Moem »

Right... and I suggest you start a new thread to ask how you can detect and fix the currently existing ownership problems in your system. After that, you should be able to start mintupdate the normal way, by just typing

Code: Select all

mintupdate
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
Post Reply

Return to “Software & Applications”