Compton giving black screen in VirtualBox

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
mingle
Level 3
Level 3
Posts: 136
Joined: Thu May 24, 2012 9:58 pm

Compton giving black screen in VirtualBox

Post by mingle » Sat Oct 29, 2016 12:06 am

Hi fellas,

I'm having a bit of a problem with Compton...

I'm running Linux Mint 18.0 64-bit xfce on a couple of setups:

1: Dell Optiplex 960, Core2 Quad Q9400, 8GB RAM, Intel Q43/Q45 GFX.

2: Virtualbox 5.1.8 (under Windows 10, on the above hardware, with 4GB RAM)

I'm using "Xfwm4 + Compton" as my Windows Manager on the Dell, with a valid compton.conf file and running "compton -b" as one of the Application Auostart settings. Works fine, without issues.

However, when I use the same settings on my VirtualBox installation, the screen stays blank/black when the system boots, even thought the mouse-pointer is visible. The system IS running as, (luckily and quite by chance), I managed to bring up a terminal session, which I then used to "pkill" the Compton process.

Are there any other settings for Compton I can try to see why the screen is not displaying?

Any comments or suggestions greatly appreciated.

Cheers,

Mike.
Last edited by mingle on Sat Oct 29, 2016 4:11 am, edited 1 time in total.

User avatar
trytip
Level 11
Level 11
Posts: 3701
Joined: Tue Jul 05, 2016 1:20 pm

Re: Compton giving black screen in VirtualBox

Post by trytip » Sat Oct 29, 2016 12:56 am

delete your compton.conf (back it up first) and try it without then you'll know if it's the config files or compton. which .conf are you using?
Image

User avatar
mingle
Level 3
Level 3
Posts: 136
Joined: Thu May 24, 2012 9:58 pm

Re: Compton giving black screen in VirtualBox

Post by mingle » Sat Oct 29, 2016 3:48 am

Hi trytip,

I deleted the .conf file, enabled compton on startup (compton -b) with the Windows Manager set to "Xfmw4 + compton".

I rebooted the VM and it came up fine, so it looks like something in the config file is killing the desktop.

See below for my compton.conf file. If there's anything obvious you can see, please let me know :-), otherwise I guess I can comment out each line and do a restart to see what kills it.

Cheers,

Mike.

<EDIT> Turns out that the first line in the .conf file was the cause of the problem: "backend = "glx"; # Enables Opengl backend"

Once I commented that out, it seems to work fine.

-----
(compton.conf)

backend = "glx"; # Enables Opengl backend
paint-on-overlay = true; # These 3 can improve performance, work well in most cases
glx-no-stencil = true;
glx-no-rebind-pixmap = true;
vsync = "opengl-swc"; # Enables one of the vsync methods. Check here for more info: https://github.com/chjj/compton/wiki/vsync-guide

# Shadow
shadow = true; # Enabled client-side shadows on windows.
no-dock-shadow = true; # Avoid drawing shadows on dock/panel windows.
no-dnd-shadow = true; # Don't draw shadows on DND windows.
clear-shadow = true; # Zero the part of the shadow's mask behind the window (experimental).
shadow-radius = 7; # The blur radius for shadows. (default 12)
shadow-offset-x = -7; # The left offset for shadows. (default -15)
shadow-offset-y = -7; # The top offset for shadows. (default -15)
shadow-exclude = [
"! name~=''",
"n:e:Notification",
"n:e:Plank",
"n:e:Docky",
"g:e:Synapse",
"g:e:Kupfer",
"g:e:Conky",
"n:w:*Firefox*",
"n:w:*Chrome*",
"n:w:*Chromium*",
"n:w:*VirtualBox*",
"class_g ?= 'Notify-osd'",
"class_g ?= 'Cairo-dock'",
"class_g ?= 'Xfce4-notifyd'",
"class_g ?= 'Xfce4-power-manager'"
];

# Due to how compton draws shadows, some apps will have "glitchy" shadows. I've added all problem apps I ran into here.
#"! name~=''" excludes shadows on "unkown" windows, which fixes a shadow glitch with XFWM's alt tab switcher.

# Fading
fading = false; # Fade windows during opacity changes.
fade-delta = 4; # The time between steps in a fade in milliseconds. (default 10).
fade-in-step = 0.03; # Opacity change between steps while fading in. (default 0.028).
fade-out-step = 0.03; # Opacity change between steps while fading out. (default 0.03).
#no-fading-openclose = true; # Fade windows in/out when opening/closing

detect-client-opacity = true; #Fixes opacity in some apps, such as xfce4-notifyd

# Window type settings
# Disables shadows on tooltips and enables fading on tooltips

wintypes:
{
tooltip = { fade = true; shadow = false; };
};

User avatar
trytip
Level 11
Level 11
Posts: 3701
Joined: Tue Jul 05, 2016 1:20 pm

Re: Compton giving black screen in VirtualBox

Post by trytip » Sat Oct 29, 2016 1:35 pm

here's the compton i use

Code: Select all

http://twily.info/.compton/compton.conf
it's been around for a while, i seen the one you were using but i'm sticking with the one from http://twily.info/.compton/compton.conf as it gives some really nice minimal effects and a bit of extra info that can be commented/uncommented just like the wiki file depending on hardware
Image

User avatar
mingle
Level 3
Level 3
Posts: 136
Joined: Thu May 24, 2012 9:58 pm

Re: Compton giving black screen in VirtualBox

Post by mingle » Sun Oct 30, 2016 2:24 am

I gave that a try, but it screwed up my system even more than the other!

Post Reply

Return to “Software & Applications”