Page 1 of 1

Need Help With Installing Digital Currency Wallet

Posted: Wed Nov 09, 2016 6:36 pm
by BitTraveler
Hello,

I'm trying to install the Pakcoin digital currency wallet on my laptop. I'm currently running Linux Mint 18.

The wallet package is on this page:

http://www.pakcoin.info/wallets/

I would be grateful to anyone who can give me the right instructions for installing this.

Thank you very much for your help.

Re: Need Help With Installing Digital Currency Wallet

Posted: Wed Nov 09, 2016 7:02 pm
by jimallyn
Save the PakCoin for Linux file to somewhere on your computer. (I saved it to /Progs/PakCoin.) Then navigate to it with the file browser, right click on the .zip file, and click Extract Here. pakcoin-qt will be extracted to the directory you saved the zip file in. Double clicking pakcoin-qt should run it.

Re: Need Help With Installing Digital Currency Wallet

Posted: Wed Nov 09, 2016 8:34 pm
by BitTraveler
jimallyn wrote:Save the PakCoin for Linux file to somewhere on your computer. (I saved it to /Progs/PakCoin.) Then navigate to it with the file browser, right click on the .zip file, and click Extract Here. pakcoin-qt will be extracted to the directory you saved the zip file in. Double clicking pakcoin-qt should run it.

Hello,

Thank you for getting back to me. I did follow the instructions as you posted. When I double click the wallet file it doesn't open. I've tried it several times and it does nothing. I posted a screenshot of it in this post.

Any help you can give would be greatly appreciated.

Thank you very much.

Re: Need Help With Installing Digital Currency Wallet

Posted: Wed Nov 09, 2016 10:06 pm
by jimallyn
OK, let's try something else: right click on the pakcoin-qt file, then click Properties. Click on the Permissions tab. Look to see if the box for Allow executing file as program is checked. If not, check it. Close the Properties dialog then try double clicking the pakcoin-qt file again.

If that doesn't do it, here's something else to try: Open a Terminal window. There should be an icon for Terminal in the panel at the bottom of the screen. It should open in your home directory, which from the picture you posted appears to be chief. Type cd Programs then press the Enter key. That should take the terminal into the Programs directory. You can confirm you're in the right place by typing ls and pressing the Enter key. That will list all the files in that directory, and pakcoin-qt should be one of them. Now enter in the terminal ./pakcoin-qt and press Enter again. Anything happen now? If it starts up OK, great. If not, then please copy any messages displayed in the terminal then paste them into your next post here.

Re: Need Help With Installing Digital Currency Wallet

Posted: Wed Nov 09, 2016 10:17 pm
by BitTraveler
jimallyn wrote:OK, let's try something else: right click on the pakcoin-qt file, then click Properties. Click on the Permissions tab. Look to see if the box for Allow executing file as program is checked. If not, check it. Close the Properties dialog then try double clicking the pakcoin-qt file again.

If that doesn't do it, here's something else to try: Open a Terminal window. There should be an icon for Terminal in the panel at the bottom of the screen. It should open in your home directory, which from the picture you posted appears to be chief. Type cd Programs then press the Enter key. That should take the terminal into the Programs directory. You can confirm you're in the right place by typing ls and pressing the Enter key. That will list all the files in that directory, and pakcoin-qt should be one of them. Now enter in the terminal ./pakcoin-qt and press Enter again. Anything happen now? If it starts up OK, great. If not, then please copy any messages displayed in the terminal then paste them into your next post here.

Thank you for the instructions. I think I made it further along in the terminal window. But it doesn't allow me to install it. I attached a screenshot to this post. Any additional help will be greatly appreciated.

Thank you very much.

Re: Need Help With Installing Digital Currency Wallet

Posted: Wed Nov 09, 2016 10:23 pm
by jimallyn
I think that tells us that the file you downloaded is somehow not compatible with Linux Mint. Did you check in the Properties under Permissions to make sure it is allowed to run as a program?

Re: Need Help With Installing Digital Currency Wallet

Posted: Wed Nov 09, 2016 10:30 pm
by BitTraveler
jimallyn wrote:I think that tells us that the file you downloaded is somehow not compatible with Linux Mint. Did you check in the Properties under Permissions to make sure it is allowed to run as a program?

I attached a screenshot of it to this post. Do I need to chance it's "group" to another choice?

The other choices in that drop down menu are:

adm
cdrom
dip
lpadmin
plugdev
sambashare
sudo

Please let me know.

Thank you.

Re: Need Help With Installing Digital Currency Wallet

Posted: Wed Nov 09, 2016 11:05 pm
by jimallyn
You shouldn't need to do anything with the rest of that stuff. Did you also try starting it from the terminal as I suggested? Usually when a program won't start from terminal, it will give error messages that may help you solve the problem. I'll think on it for a while, and maybe I'll come up with another idea. Or maybe somebody else has some ideas? Feel free to jump in here!

Re: Need Help With Installing Digital Currency Wallet

Posted: Thu Nov 10, 2016 12:28 pm
by BitTraveler
jimallyn wrote:You shouldn't need to do anything with the rest of that stuff. Did you also try starting it from the terminal as I suggested? Usually when a program won't start from terminal, it will give error messages that may help you solve the problem. I'll think on it for a while, and maybe I'll come up with another idea. Or maybe somebody else has some ideas? Feel free to jump in here!

I did try it from the terminal, and it didn't install for me.

I really appreciate your help with this.

If you come up with any other ideas, please let me know.

Thank you again.

Re: Need Help With Installing Digital Currency Wallet

Posted: Thu Nov 10, 2016 7:11 pm
by jimallyn
I don't think it needs to be installed. I think it's a compiled executable, and It just runs (or doesn't). Maybe I will give it a try tonight when I get home. I'm not sure that I trust the application, so I will probably try running it in a virtual machine.

Re: Need Help With Installing Digital Currency Wallet

Posted: Thu Nov 10, 2016 7:22 pm
by jimallyn
I wonder if that file is something other than what we think it is? Try the following command from terminal:

file pakcoin-qt

Then post whatever output that gives you here.

Re: Need Help With Installing Digital Currency Wallet

Posted: Fri Nov 11, 2016 6:49 pm
by BitTraveler
jimallyn wrote:I wonder if that file is something other than what we think it is? Try the following command from terminal:

file pakcoin-qt

Then post whatever output that gives you here.

Hello,

Thank you for following up with me.

I did put that in the command line and I posted a screenshot of the result of it.

Re: Need Help With Installing Digital Currency Wallet

Posted: Fri Nov 11, 2016 7:27 pm
by jimallyn
OK, this is kind of a "shotgun" approach, but I'm not sure what else to try at this point. Open a terminal and enter inxi -Fxz. That will tell us a lot about your processor, your video card, your memory, your kernel, and so on. Copy and paste the output of that command to your next post. Maybe something will stand out that could be a problem with running this program.

One thing that is a little troubling is that the file command says it is for Linux (kernel) 2.6.24. Mint 17 uses kernel 3.13.0-91 and mint 18 uses something even newer. That doesn't absolutely mean that it won't run on the newer kernel, but it could mean that.

Re: Need Help With Installing Digital Currency Wallet

Posted: Fri Nov 11, 2016 9:19 pm
by BitTraveler
jimallyn wrote:OK, this is kind of a "shotgun" approach, but I'm not sure what else to try at this point. Open a terminal and enter inxi -Fxz. That will tell us a lot about your processor, your video card, your memory, your kernel, and so on. Copy and paste the output of that command to your next post. Maybe something will stand out that could be a problem with running this program.

One thing that is a little troubling is that the file command says it is for Linux (kernel) 2.6.24. Mint 17 uses kernel 3.13.0-91 and mint 18 uses something even newer. That doesn't absolutely mean that it won't run on the newer kernel, but it could mean that.

I appreciate your help with this.

I've attached the screenshot to this post.

Re: Need Help With Installing Digital Currency Wallet

Posted: Sat Nov 12, 2016 1:26 am
by ostracized
64-bit binaries can't run in a 32-bit environment.
libdb5.1-dev
Berkley DB is currently on 5.3 and has been for some time. If the admin on the other site gives you compiling instructions, keep this in mind. I can't remember if the runtime is installed by default on Mint. Probably.

And remember, just say "no" to UPnP in these forked Qt wallets.

Re: Need Help With Installing Digital Currency Wallet

Posted: Sat Nov 12, 2016 3:10 am
by jimallyn
ostracized wrote:64-bit binaries can't run in a 32-bit environment.
I had a feeling that's what we were getting to. Should have asked for the inxi output sooner.

Re: Need Help With Installing Digital Currency Wallet

Posted: Sat Nov 12, 2016 9:29 am
by BitTraveler
jimallyn wrote:
ostracized wrote:64-bit binaries can't run in a 32-bit environment.
I had a feeling that's what we were getting to. Should have asked for the inxi output sooner.

So I would need to have a Linux Mint 64 bit OS to install that wallet?

Please let me know.

Thank you.

Re: Need Help With Installing Digital Currency Wallet

Posted: Sat Nov 12, 2016 3:19 pm
by jimallyn
Yes, you need a 64 bit operating system. I Googled for that processor, and it apparently is a 64 bit processor, so install a 64 bit OS and you should (hopefully) be good to go.

Re: Need Help With Installing Digital Currency Wallet

Posted: Sat Nov 12, 2016 8:52 pm
by BitTraveler
jimallyn wrote:Yes, you need a 64 bit operating system. I Googled for that processor, and it apparently is a 64 bit processor, so install a 64 bit OS and you should (hopefully) be good to go.

Thank you very much for all your help. I greatly appreciate it. :D