[CLOSED] problem with installing PHP

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
dehawkinz
Level 2
Level 2
Posts: 75
Joined: Tue Sep 13, 2011 5:09 pm

[CLOSED] problem with installing PHP

Post by dehawkinz »

For various reasons my wife decided to use php to build her website, and I am the local 'tech support'

so I figured it best to get ahead of the curve and install a LAMP stack on my pc first

I got L A M sorted (I think) it is the P that is bugging me because it does not want to work

every time I try to display even a basic phpinfo all I get is a blank page in the browser
Linux is definitely working
Apache is definitely working - I get the default Apache page if I go to localhost
the php file is there, because if I do a view source on the browser page it confirms source code is <?php phpinfo(); ?>

although most tutorials are stuck back at php5 and php is now at 7.0, I think I installed all the necessary components (where it referred to 5 I updated to 7.0 as php5 would not even install)

I know a few years back I managed it on a different machine, so I am sure it is something really blindingly obvious to those wiser in these things but I am stumped
Last edited by dehawkinz on Sat Jan 28, 2017 10:21 am, edited 1 time in total.
deepakdeshp
Level 19
Level 19
Posts: 9000
Joined: Sun Aug 09, 2015 10:00 am

Re: problem with installing PHP

Post by deepakdeshp »

If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

Mint 20.1 Cinnamon 64 bit with AMD A8/7410 / 8GB
Mint 20.1 Cinnamon AMD Ryzen3500U/8gb
dehawkinz
Level 2
Level 2
Posts: 75
Joined: Tue Sep 13, 2011 5:09 pm

Re: problem with installing PHP

Post by dehawkinz »

deepakdeshp, I have just tried that

I still get the same issue - just a blank page generated by the new php file
deepakdeshp
Level 19
Level 19
Posts: 9000
Joined: Sun Aug 09, 2015 10:00 am

Re: problem with installing PHP

Post by deepakdeshp »

If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

Mint 20.1 Cinnamon 64 bit with AMD A8/7410 / 8GB
Mint 20.1 Cinnamon AMD Ryzen3500U/8gb
dehawkinz
Level 2
Level 2
Posts: 75
Joined: Tue Sep 13, 2011 5:09 pm

Re: problem with installing PHP

Post by dehawkinz »

eeeek

that killed my apache :(

now apache will not start - the error log is full of errors :(

it seems that something is out of balance, maybe the best solution is to clear everything out and restart from scratch
deepakdeshp
Level 19
Level 19
Posts: 9000
Joined: Sun Aug 09, 2015 10:00 am

Re: problem with installing PHP

Post by deepakdeshp »

dehawkinz wrote:eeeek

that killed my apache :(

now apache will not start - the error log is full of errors :(

it seems that something is out of balance, maybe the best solution is to clear everything out and restart from scratch
I hope that after making any change you tested for PHP.
The last change you made would have broken Apache.
You can undo the last step or remove LAMP stack and reinstall.
http://askubuntu.com/questions/806538/r ... untu-16-04
The purge option removes packages completely.

Good luck.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

Mint 20.1 Cinnamon 64 bit with AMD A8/7410 / 8GB
Mint 20.1 Cinnamon AMD Ryzen3500U/8gb
dehawkinz
Level 2
Level 2
Posts: 75
Joined: Tue Sep 13, 2011 5:09 pm

Re: problem with installing PHP

Post by dehawkinz »

I tried the option to purge everything and re-install, but still apache wont start.

I think a scorched earth approach may be best, wipe the partition tomorrow and re-install Linux - that way I know there are no nasty fragments lurking upsetting everything.

I suspect I have some bits left that are fighting with each other - there are odd error messages in the installation process about dependencies and the such like, that were not there first time I installed
adamcloud
Level 1
Level 1
Posts: 1
Joined: Sat Jan 28, 2017 9:30 am

Re: problem with installing PHP

Post by adamcloud »

I followed this tutorial and lamp is working perfectly.

https://www.cloudjojo.com/how-to-instal ... ntu-16-04/
dehawkinz
Level 2
Level 2
Posts: 75
Joined: Tue Sep 13, 2011 5:09 pm

[CLOSED] Re: problem with installing PHP

Post by dehawkinz »

I did the scorched earth approach in the end, and reinstalled Linux from scratch as the various attempts to 'fix' the installation were not working

Installing the remainder of the LAMP stack worked fine with a fresh Linux installation

so I did not 'solve' what was causing the issue, but I did acheive the desired end result, so in that sense I solved the problem :)
Post Reply

Return to “Software & Applications”