Install older version of LibreOffice

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Robin2
Level 1
Level 1
Posts: 17
Joined: Thu Dec 29, 2016 12:43 pm

Install older version of LibreOffice

Post by Robin2 » Thu Jan 19, 2017 10:56 am

I am using Mint 18 with Mate and it has version 5.1.2.2 of LibreOffice. When I made a drawing with LO Draw and exported it as an SVG file for Inkscape to send to a Silhouette Portrait cutter it added boxes around the drawings completely screwing up the cut image.

I had previously been using LO 4.3.5.2 on Puppy Tahr and it worked fine. And when I loaded the new drawing into the old LO Draw (using Puppy) and exported the drawing as an SVG file it produced a smaller file and the drawing cut properly using Inkscape both on Puppy and on Mint. So it seems that some of the "improvements" to LO were anything but :)

How can I install LO 4.3.5.2 on Mint 18.

I tried this command

Code: Select all

sudo add-apt-repository ppa:libreoffice/libreoffice-4-3
and I got this message

Code: Select all

Cannot add PPA: ''This PPA does not support xenial''.
I don't know whether that just refers to some quirk in the packaging system or if it means that 4.3.5.2 will not work in Miint 18

I have also downloaded

Code: Select all

LibreOffice_4.3.5.2_Linux_x86_deb.tar.gz
but I would like to be sure it will work before I purge the existing version

Thanks

...R

User avatar
Flemur
Level 17
Level 17
Posts: 7175
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Install older version of LibreOffice

Post by Flemur » Thu Jan 19, 2017 11:52 am

Robin2 wrote:I have also downloaded

Code: Select all

LibreOffice_4.3.5.2_Linux_x86_deb.tar.gz
but I would like to be sure it will work before I purge the existing version
You can try installing that without messing up your current install. I guess there's a .deb file in the archive, which is a bit odd; extract the .deb, rt-click->open with gdebi and it'll tell you if there are problems.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

grumpy_geek
Level 2
Level 2
Posts: 80
Joined: Tue Jan 03, 2017 3:50 am
Contact:

Re: Install older version of LibreOffice

Post by grumpy_geek » Thu Jan 19, 2017 1:43 pm

Robin2 wrote:I would like to be sure it will work before I purge the existing version
From within the extracted archive's folder of deb files, you may want to first simulate the install process:

Code: Select all

sudo dpkg --install --simulate *.deb

Robin2
Level 1
Level 1
Posts: 17
Joined: Thu Dec 29, 2016 12:43 pm

Re: Install older version of LibreOffice

Post by Robin2 » Thu Jan 19, 2017 5:46 pm

Thanks. I took the plunge and removed the "standard" version with

Code: Select all

sudo apt-get remove libreoffice-core
and then, after extracting the tar.gz (which contains a load of .deb files) I did

Code: Select all

sudo dpkg -i *.deb
and now I seem to have a working 4.3.5.2.

And it produced a proper SVG file that cut properly on my Silhouette Portrait

...R

Post Reply

Return to “Software & Applications”