LM17.3 Videos playback of files on network file share stutters

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
chrisonmint
Level 3
Level 3
Posts: 143
Joined: Sun May 03, 2015 10:49 am

LM17.3 Videos playback of files on network file share stutters

Post by chrisonmint » Mon Jan 23, 2017 5:28 am

Playback of files on my local hard disk is fine and smooth, but when playing files from a Samba file share (raspberry pi running LibreElec) I see regular stutters every 5 seconds or so.

I am assuming that this is because the Videos app doesnt have enough cache to keep playback running smoothly. How do i increase it?

I have the gconf editor but cannot see any entries for totem or videos...

any help much appreciated.

Hoser Rob
Level 15
Level 15
Posts: 5605
Joined: Sat Dec 15, 2012 8:57 am

Re: LM17.3 Videos playback of files on network file share stutters

Post by Hoser Rob » Tue Jan 24, 2017 9:32 am

First, the way apps are named in the start menus in Mint (and Ubuntu) is ridiculous. AFAIK it's a Linux thing in general. This issue comes up surprisingly often on beginner forums. If you want to actually know the name of the program, open it , go into the Help menu, click 'About'. The popup window will have the name. Stupid, but that's how it works.

I also run 17.3 though so my 'Videos' is actually Totem and that's probably what you're talking about.

That program is RUBBISH and why it's installed, let alone the default, is completely beyond me. I've seen similar things happen in Ubuntu so this isn't really a Mint issue. That doesn't impove Totem one bit though.

Totem has no useful settings I can find. I think they had a cache setting once but they dropped it ears ago. I looked up how to increase the cache in Totem but the ways were in Ubuntu 12.04 so it's probably out of date info anyway.

And in any case the steps to increase the cache were idiotically comlex, in the sense that only an idiot would do them rather than simply install a decent media playing app.

I've tried Totem. Tried it a couple of days ago. It doesn't even give me decent playback performance with relatively small bit rate files played back from local files. And there are zero useful settings in the menus. Useless.

Actually I use SMplayer by default. I did in Windoze too when I still had it. It has much better performance, and excellent settings. I set local cache size to 8192Kb. VLC is a distant second for me.

User avatar
BG405
Level 7
Level 7
Posts: 1917
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: LM17.3 Videos playback of files on network file share stutters

Post by BG405 » Tue Jan 24, 2017 3:40 pm

Is the playback OK on another machine, if that is an option to try? I wonder if the Raspberry Pi can't keep up with the data rate. I have had no issues with Totem in Cinnamon or Dragon Player in KDE, even the player on my lower spec machines running Xfce (can't remember which player Xfce uses at the moment) works fine whether streaming or playing local files.
Hoser Rob wrote:I use SMplayer by default. ... It has much better performance, and excellent settings.
I've just installed this on Cinnamon and after a quick look at the interface & options I like what I see. Great suggestion! I too was underwhelmed with the lack of options in Totem. I see SMplayer has a built-in YouTube browser, this will be very handy.
Dell Inspiron 1525 - LM17.3 CE 64-------------------Lenovo T440 8GB - Manjaro KDE with Mint VMs
Toshiba NB250 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Dell PII 350 64MB - Puppy 4.3 & Win98-SE

chrisonmint
Level 3
Level 3
Posts: 143
Joined: Sun May 03, 2015 10:49 am

Re: LM17.3 Videos playback of files on network file share stutters

Post by chrisonmint » Tue Jan 24, 2017 5:06 pm

Hoser Rob wrote:First, the way apps are named in the start menus in Mint (and Ubuntu) is ridiculous.
Yes, it simplifies things for new users, but obfuscates what is really going on.

I did the same google searching and also found really old info which didnt seem to help.

I have been using SMPlayer installed from a PPA called rvm/smplayer (17.1.0-1~trusty) and a more up-to-date version of mpv from PPA mc3man/mpv-tests (2:0.23-0~trusty). This combo was working pretty well until a recent set of updates (not sure which, whether it was the new kernel or drivers or a recent change in one of the PPA's). Now, SMPlayer freezes every 10 mins or so, claiming a mpv crash (no info in the log that i can see). Before this set of updates, Totem/Videos had stuttering playback, now it is smooth but only for local files.

What version of SMplayer and mpv/mplayer etc are you using?

I have considered updating VLC and seeing if that helps (playback stutters on my machine with the 17.3 version which is 2.1.xx)

chrisonmint
Level 3
Level 3
Posts: 143
Joined: Sun May 03, 2015 10:49 am

Re: LM17.3 Videos playback of files on network file share stutters

Post by chrisonmint » Tue Jan 24, 2017 5:08 pm

BG405 wrote:Is the playback OK on another machine, if that is an option to try? I wonder if the Raspberry Pi can't keep up with the data rate. I have had no issues with Totem in Cinnamon or Dragon Player in KDE, even the player on my lower spec machines running Xfce (can't remember which player Xfce uses at the moment) works fine whether streaming or playing local files.
Hi BG405 - I dont think its a network issue as other devices stream from the Pi without issue (its connected to the router via 100mb ethernet) and my Linux laptop streams from iPlayer and youtube in HD resolution without stuttering. It also used to work with SMPlayer before that started crashing...

Also question for you - which SMPlayer are you using? is it from a PPA?

any help is very welcome

User avatar
BG405
Level 7
Level 7
Posts: 1917
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: LM17.3 Videos playback of files on network file share stutters

Post by BG405 » Tue Jan 24, 2017 5:46 pm

I just installed it from the repositories using sudo apt-get install smplayer smplayer-themes - not sure the themes are necessary but installed them just in case they may look better. Haven't tested it properly yet and will be down the pub shortly so, when i get there, I'll install it on my Acer and see how it performs. I'll post the results later (probably after 01:00 GMT) when I get back.
Dell Inspiron 1525 - LM17.3 CE 64-------------------Lenovo T440 8GB - Manjaro KDE with Mint VMs
Toshiba NB250 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Dell PII 350 64MB - Puppy 4.3 & Win98-SE

chrisonmint
Level 3
Level 3
Posts: 143
Joined: Sun May 03, 2015 10:49 am

Re: LM17.3 Videos playback of files on network file share stutters

Post by chrisonmint » Thu Jan 26, 2017 2:08 pm

BG405 wrote:I just installed it from the repositories using sudo apt-get install smplayer smplayer-themes - not sure the themes are necessary but installed them just in case they may look better. Haven't tested it properly yet and will be down the pub shortly so, when i get there, I'll install it on my Acer and see how it performs. I'll post the results later (probably after 01:00 GMT) when I get back.
Hi BG405, I removed the PPAs i had for newer versions of mpv and SMplayer and have the mint-supplied versions running. They are very old, but seem to be running fine and I have set the cache to 8192 for local and network files - the occasional buffering is now gone.

Not so sure about the picture quality - a newer mpv with better compatibility with my GPU might be worth trying, but think i will wait until I upgrade the whole system to a more up-to-date OS (Korora maybe, or LM18 if they sort out the bugs)

thanks
chris

Post Reply

Return to “Software & Applications”