kickoff: can't start app as root & some launchers missing

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
slowjogg
Level 1
Level 1
Posts: 2
Joined: Tue Jan 24, 2017 1:47 am

kickoff: can't start app as root & some launchers missing

Post by slowjogg » Tue Jan 24, 2017 2:32 am

I. After a fresh installation of LinuxMint 18.1 I installed some additional programs - among them: atom editor and the XAMPP/LAMPP stack from https://www.apachefriends.org/de/download.html.

Installation worked smoothly but I don't manage to get a launcher for the GUI XAMPP manager to work. Launching the manager via konsole/terminal (sudo /opt/lampp/manager-linux-x64.run) works flawlessly.

This is how I proceeded:

1. Right-klick on the kickoff icon and select "edit applications..."
2. select submenu "Development"
3. click "New Item"
4. insert items name (XAMPP)
5. insert command (sudo /opt/lampp/manager-linux-x64.run) in the appropriate line of the 'General' tab
6. select the 'Advanced' tab and tick 'Run in terminal'
7. save the new settings

If then clicking the corresponding entry a 'starter' named 'XAMPP' appears for less than a second in the panel and then disappears. XAMPP does not start and I do't get any error messages. Under OpenSuSE leap 42.2 you had to enter 'kdesu /opt/lampp/manager-linux-x64.run' instead of 'sudo /opt/lampp/manager-linux-x64.run' to start a GUI application. But under LinuxMint this command (either in terminal or in the kickoff menu) says "kdesu: command not found" or "Could not find the program 'kdesu'".


II. After messing around with the above mentioned settings for some time the 'Development' entries for 'Translation' and 'Web Development' are no longer shown. They are still lined up in the KDE Menu Editor (only names, no corresponding commands or other entries). Could you please tell me which applications were linked to these entries initially?

Best regards
slowjogg

grumpy_geek
Level 2
Level 2
Posts: 80
Joined: Tue Jan 03, 2017 3:50 am
Contact:

Re: kickoff: can't start app as root & some launchers missing

Post by grumpy_geek » Tue Jan 24, 2017 8:50 am

slowjogg wrote:sudo /opt/lampp/manager-linux-x64.run
How about [b]gksudo[/b] /opt/lampp/manager-linux-x64.run ...?

slowjogg
Level 1
Level 1
Posts: 2
Joined: Tue Jan 24, 2017 1:47 am

Re: kickoff: can't start app as root & some launchers missing

Post by slowjogg » Tue Jan 24, 2017 2:42 pm

@ grumpy_geek:

Thx for your reply but: same result. A kind of 'starter' / optical feedback popping up for less than a second and that's it... ;(

slowjogg

dutchenery
Level 1
Level 1
Posts: 24
Joined: Mon Jul 13, 2015 7:00 am

Re: kickoff: can't start app as root & some launchers missing

Post by dutchenery » Sun Feb 05, 2017 3:10 pm

Sounds a bit too complicated to me? The manager should start and is part of the LAMPP directory unless you have installed it somewhere else. I wouldn't do that.
However, there is another way and use a small file called xampp.desktop. Copy the following and save it to the desktop.

[Desktop Entry]
Encoding=UTF-8
Name=Xampp Control Panel
Comment=Start or Stop XAMPP
Exec=gksu python /opt/lampp/share/xampp-control-panel/xampp-control-panel.py
Icon=/opt/lampp/htdocs/favicon.ico
Categories=Application;Development;Web
Version=1.0
Type=Application
Terminal=0

It assumes that you have also installed the usual Python programs (should be loaded as part of Xampp). Save the file to the desktop. Next to make it executable: Right-Click on it, goto Properties, Permissions and set it to Allow executing as program. You're in clover.
Just for those that run Xampp - you need to reset permissions to the htdocs directory - sudo chmod -R yourusername:yourgroupname /opt/lampp/htdocs
Do NOT set permissions to 777 at anytime, bad idea. Also change those lines containing username and groupname in the /opt/lampp/etc/httpd.conf file.

Post Reply

Return to “Software & Applications”