File Permissions Messed Up After Installing VirtualBox

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 19
Joined: Tue Jan 10, 2017 9:32 pm
Location: The Netherlands

File Permissions Messed Up After Installing VirtualBox

Post by Arikania » Thu Feb 23, 2017 8:35 pm

I play World of Warcraft 5.4.8 via Wine 1.6.2 on Cinnamon 17.1. Worked like a charm. Then I installed VBox to play it on a native Windows. Ever since, and even now after sudo apt-get purge virtualbox; sudo apt-get autoremove, my files and directories have 6 digit permissions, and my WoW cannot write to its config file anymore (via Wine of cause). I get no error messages, the data simply will not change, and exitting the game takes forever as WoW attempts to update it.

I should mention that I played on VBox by having the original program folder shared with VBox.

The program folder and subdirs have permits 400777 in some cases and 100777 in others, and the files have 664 with the same digits in front.

How do I remove the first 2 digits from those permissions, and how do I get my WoW to update its config file again?

While I was typing this mail I did sudo -R chown admin:UsersGroup ProgDir and sudo chmod -R a-rwx,ug=rwX,o=rX ProgDir, and now the situation is this:

My files still all have permissions 100666 and my folders have 40777 (I got one digit off! Hooray! :D ), but unlike before, if WoW creates new folders by itself, they get permissions 40755 (still no write rights), and user is the owner rather than admin. But WoW still won't write its configs. :(

Post Reply

Return to “Software & Applications”