Page 1 of 1

Trouble installing Openshot (the QT version)

Posted: Thu Jul 06, 2017 6:52 pm
by blackoutworm
Hi. I've been trying to install the QT version of Openshot, but keep getting errors.
According to this message, it cannot find the sip module, which I indeed have installed.

Code: Select all

Loaded modules from installed directory: /usr/lib/python3/dist-packages/openshot_qt
Traceback (most recent call last):
  File "/usr/bin/openshot-qt", line 9, in <module>
    load_entry_point('openshot-qt==2.3.4', 'gui_scripts', 'openshot-qt')()
  File "/usr/lib/python3/dist-packages/pkg_resources.py", line 351, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2363, in load_entry_point
    return ep.load()
  File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2088, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib/python3/dist-packages/openshot_qt/launch.py", line 53, in <module>
    from classes.app import OpenShotApp
  File "/usr/lib/python3/dist-packages/openshot_qt/classes/app.py", line 34, in <module>
    from PyQt5.QtWidgets import QApplication, QStyleFactory, QMessageBox
ImportError: No module named 'sip'
Any clue? Thanks in advance!