preventing mysqld from starting at boot

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
hstoellinger
Level 2
Level 2
Posts: 54
Joined: Sun Apr 01, 2012 2:06 pm
Location: Salzburg

preventing mysqld from starting at boot

Post by hstoellinger » Wed Jul 26, 2017 1:40 pm

Hello,
I am not sure whether this is the right forum section to ask this question, but...
how can I prevent the mysqld service (daemon)from automatically starting at
boot time. I only need it on rare occasions. I run Mint 18.2-64bit.
Thanks for any hints
Regards
H. Stöllinger

User avatar
JoeFootball
Level 7
Level 7
Posts: 1884
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: preventing mysqld from starting at boot

Post by JoeFootball » Wed Jul 26, 2017 2:35 pm

This article has some ideas.

Joe

User avatar
greerd
Level 6
Level 6
Posts: 1055
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: preventing mysqld from starting at boot

Post by greerd » Wed Jul 26, 2017 4:09 pm

I think on 18.x which has systemd,

to see mysql status

Code: Select all

systemctl status mysqld.service
to stop mysql service

Code: Select all

sudo systemctl stop mysqld.service
to disable at startup

Code: Select all

sudo systemctl disable mysqld.service
[EDIT] edited mysql.service to mysqld.service

hstoellinger
Level 2
Level 2
Posts: 54
Joined: Sun Apr 01, 2012 2:06 pm
Location: Salzburg

Re: preventing mysqld from starting at boot

Post by hstoellinger » Thu Jul 27, 2017 6:57 am

Thanks for the hints! Everything o.k. now. I actually hadn't installed a mysql server separately. The mysqld process shown on the system monitor belonged to Akonadi. It uses over 220MB storage. After installing MySQL-Server 5.7 I now see TWO mysqld processes running.
Regards
H. Stoellinger

Post Reply

Return to “Software & Applications”