Cups and hplip failed. Can't reinstall

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
fernandocabral
Level 2
Level 2
Posts: 56
Joined: Wed Jun 04, 2014 6:15 am

Cups and hplip failed. Can't reinstall

Post by fernandocabral »

All of a sudden, for no apparent reason, my printing system crashed. Nothing works. When I try uninstall or reinstall cups, hplip or any other thing related, I got something like:

Code: Select all

Os pacotes a seguir têm dependências desencontradas: [Following packages have conflicting dependencies]
 cups : Depende [Depends]: libcupscgi1 (>= 1.4.2) mas não está instalado [but will not be installed]
        Depende: [Depends] cups-server-common (>= 2.1.3-4) mas não está instalado [but will not be installed]
        Depende: [depends] cups-client (>= 2.1.3-4)
        
 OR, ELSE, I get the following message:
 
 Depende : libcups2 (= 2.1.3-4ubuntu0.2) mas 2.1.3-4 está instalado
 [Depends on libcups2 (=2.1.3-4ubuntu0.2) but 2.1.3-4 is installed]

Since my machine speaks Portuguese I put a translation between square brackets]

It seems the problem has to do with libcups2. But, no matter what I do, I can't fix using. Using synaptics, apt, dpkg, whatever, I always find this kind of conflict.

Any suggestions besides reinstalling Mint itself? (by the way, I am using Mint 18.2 completely updated)

- fernando
User avatar
kc1di
Level 16
Level 16
Posts: 6386
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Cups and hplip failed. Can't reinstall

Post by kc1di »

Which version of Mint are you using?
Go to a terminal and type this command and post the output here:

Code: Select all

inxi -Fxz
Easy tips : https://easylinuxtipsproject.blogspot.com/ Pjotr's Great Linux projects page.
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608
fernandocabral
Level 2
Level 2
Posts: 56
Joined: Wed Jun 04, 2014 6:15 am

Re: Cups and hplip failed. Can't reinstall

Post by fernandocabral »

I have just solved the problem with a radical measure: I went to synaptics and unsintalled everything the contained "cups" somewhere in the package name. Everything, except for those packages that would entail unstalling most of the system. Then I reinstalled one by one: cups, hplip and a bunch of package I would not suspect were related to cups. This includes things like GIMP, EVINCE and lots of other things. Now it is back at work. Printing is normal again.

Anyway, the inxi -Fxz output follows:

Code: Select all

System:    Host: Inspiron-5537 Kernel: 4.10.0-28-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.4 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.2 Sonya
Machine:   System: Dell product: Inspiron 5537 v: A07
           Mobo: Dell model: 0YK7DY v: A00 Bios: Dell v: A07 date: 11/12/2013
CPU:       Dual core Intel Core i7-4500U (-HT-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9578
           clock speeds: max: 3000 MHz 1: 1180 MHz 2: 1252 MHz 3: 1208 MHz
           4: 1374 MHz
Graphics:  Card-1: Intel Haswell-ULT Integrated Graphics Controller
           bus-ID: 00:02.0
           Card-2: Advanced Micro Devices [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330]
           bus-ID: 03:00.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.04hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card-1 Intel 8 Series HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Haswell-ULT HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-28-generic
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 4000 bus-ID: 01:00.0
           IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
           driver: ath9k bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
           Card-3: Atheros usb-ID: 001-007
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 10002.0GB (58.9% used)
           ID-1: /dev/sdb model: ST1000LM024_HN size: 1000.2GB temp: 34C
           ID-2: USB /dev/sdc model: D3_Station size: 4000.8GB temp: 0C
           ID-3: USB /dev/sda model: Expansion_Desk size: 5001.0GB temp: 0C
Partition: ID-1: / size: 901G used: 317G (38%) fs: ext4 dev: /dev/dm-0
           ID-2: /boot size: 473M used: 121M (27%) fs: ext2 dev: /dev/sdb2
           ID-3: swap-1 size: 17.06GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 54.0C mobo: N/A gpu: N/A
           Fan Speeds (in rpm): cpu: 3200
Info:      Processes: 350 Uptime: 1 day Memory: 10312.3/15926.5MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
fernando@Inspiron-5537 /boot $ 
User avatar
kc1di
Level 16
Level 16
Posts: 6386
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Cups and hplip failed. Can't reinstall

Post by kc1di »

glad you got it fixed. Hope it doesn't happen again.
Cheers!
Easy tips : https://easylinuxtipsproject.blogspot.com/ Pjotr's Great Linux projects page.
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608
Post Reply

Return to “Software & Applications”