Libre Office Writer

Questions about applications and software
Forum rules
Before you post please read how to get help
borgward
Level 5
Level 5
Posts: 521
Joined: Mon Dec 17, 2012 10:18 pm

Libre Office Writer

Postby borgward » Mon Aug 14, 2017 7:06 pm

How do I make my font selection the default font? LibreOffice Writer 5.1.6.2. Mint 18 Cinnamon. Liberation Serif appears to be the default. I select Noto Sans, type text, make a space, tab, or new sentence and Liberation Serif comes back up. This is very annoying. I would be happy if I got the font I select until I crate a new document.

User avatar
catweazel
Level 10
Level 10
Posts: 3475
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Libre Office Writer

Postby catweazel » Mon Aug 14, 2017 7:16 pm

If your problem is fixed, please mark your thread as [SOLVED] by editing the title of the first message in the thread.

User avatar
kyphi
Level 8
Level 8
Posts: 2122
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Libre Office Writer

Postby kyphi » Mon Aug 14, 2017 10:04 pm

Open LibreOffice, click on Tools, Options. LibreOffice Writer, Basic Fonts (Western), click on the arrows next to the listed fonts to get a drop-down list of fonts, make your selection and then click on OK. Do Not click on Default - that will get you back to square one.

The current version of LibreOffice is 5.4.0.3.
Linux Mint 18.3 Cinnamon - 64bit

User avatar
catweazel
Level 10
Level 10
Posts: 3475
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Libre Office Writer

Postby catweazel » Mon Aug 14, 2017 10:09 pm

kyphi wrote:that will get you back to square one.


Performing your first recommendation will also get him back to square one... every time he opens a new document.

The current version of LibreOffice is 5.4.0.3.


The current version for LibreOffice in the standard repos is 5.1.6.2.

HTH
If your problem is fixed, please mark your thread as [SOLVED] by editing the title of the first message in the thread.

User avatar
kyphi
Level 8
Level 8
Posts: 2122
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Libre Office Writer

Postby kyphi » Mon Aug 14, 2017 10:33 pm

As long as you do not opt for Default, the change to your font selection remains. To click on Default will take you back to Liberation Serif.

Another worthwhile customisation, in my opinion, would be to change the standard icon theme from the bleak Human icon theme to Galaxy. This is done in Tools, Options, LibreOffice, View, User Interface, Icon style.
But first you have to install it:

Code: Select all

sudo apt-get install libreoffice-style-galaxy
There are other icon styles available in synaptic.
Linux Mint 18.3 Cinnamon - 64bit

Gladeous
Level 2
Level 2
Posts: 51
Joined: Wed Aug 16, 2017 2:35 pm

Re: Libre Office Writer

Postby Gladeous » Sat Aug 19, 2017 10:26 pm

kyphi wrote:Open LibreOffice, click on Tools, Options. LibreOffice Writer, Basic Fonts (Western), click on the arrows next to the listed fonts to get a drop-down list of fonts, make your selection and then click on OK. Do Not click on Default - that will get you back to square one.

The current version of LibreOffice is 5.4.0.3.

I have Mint 17.3 I followed the steps and still have Liberation serif as default.

User avatar
Schultz
Level 5
Level 5
Posts: 921
Joined: Thu Feb 25, 2016 8:57 pm

Re: Libre Office Writer

Postby Schultz » Sat Aug 19, 2017 11:00 pm

It worked for me. I changed the default to Nimbus Roman No9, closed Writer, opened it back up, and the font was Nimbus.

Gladeous
Level 2
Level 2
Posts: 51
Joined: Wed Aug 16, 2017 2:35 pm

Re: Libre Office Writer

Postby Gladeous » Sat Aug 19, 2017 11:20 pm

Could 17.3 be so different from 18?

I go to tools>options>LibreOffice>Fonts>
Top portion has a replacement table.
Bottom has Font settings
Fonts: URW Gothic (put in)
OK
Default still Liberation.

lmuserx4849
Level 4
Level 4
Posts: 492
Joined: Wed Dec 17, 2014 2:55 am

Re: Libre Office Writer

Postby lmuserx4849 » Sat Aug 19, 2017 11:27 pm



If you want permanent changes to File -> New -> Text Document, follow the procedure on the above link.
Setting a template as the default: Getting Started with LibreOffice - Complete book - Page 75

If you want the change just for the document you are working on now, change the style. You can do this a couple of ways. One way is to expand the "Set Paragraph Style" and click the arrow next to the style (i.e., Default Text) to expand the menu and select Edit Style.

Second way, is to open the Styles and Formatting Toolbar by clicking on View -> Toolbars -> Styles and Formatting (or F11). Sticking with Default Text, just right click and select Modify.

The Styles and Formatting window is described on page 65, Updating a Style on page 67.

Gladeous
Level 2
Level 2
Posts: 51
Joined: Wed Aug 16, 2017 2:35 pm

Re: Libre Office Writer

Postby Gladeous » Sat Aug 19, 2017 11:35 pm

lmuserx4849 wrote:


Second way, is to open the Styles and Formatting Toolbar by clicking on View -> Toolbars -> Styles and Formatting (or F11). Sticking with Default Text, just right click and select Modify.

The Styles and Formatting window is described on page 65, Updating a Style on page 67.

Don't have template option

Second way just gave me a double tool bar. F11 gave me Styles and Formatting but can't do anything with it.

It would take me days to read the full manual. I don't have the time to do that. I guess I will just have to live with the default font as Liberation.

User avatar
Schultz
Level 5
Level 5
Posts: 921
Joined: Thu Feb 25, 2016 8:57 pm

Re: Libre Office Writer

Postby Schultz » Sat Aug 19, 2017 11:50 pm

Gladeous wrote:
I go to tools>options>LibreOffice>Fonts>

That's the wrong place. Look further down for Tools >> Options >> LibreOffice Writer >> Basic Fonts (Western). That's what you're looking for. (Click the image for a bigger view.)

Untitled.jpg

Gladeous
Level 2
Level 2
Posts: 51
Joined: Wed Aug 16, 2017 2:35 pm

Re: Libre Office Writer

Postby Gladeous » Sat Aug 19, 2017 11:56 pm

Schultz wrote:
Gladeous wrote:
I go to tools>options>LibreOffice>Fonts>

That's the wrong place. Look further down for Tools >> Options >> LibreOffice Writer >> Basic Fonts (Western). That's what you're looking for.

Untitled.jpg

Looking at this I see I couldn't find LibreOfficeWriter because I was trying to change the default font for a spreadsheet. :lol:

User avatar
kyphi
Level 8
Level 8
Posts: 2122
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Libre Office Writer

Postby kyphi » Sun Aug 20, 2017 2:08 am

It pays to read the fine print :)

The method I outlined above has worked for me for the past 12 years through all the incarnations and releases of various operating systems (Ubuntu, Debian, Mint), first in OpenOffice and then in LibreOffice.
Linux Mint 18.3 Cinnamon - 64bit

Gladeous
Level 2
Level 2
Posts: 51
Joined: Wed Aug 16, 2017 2:35 pm

Re: Libre Office Writer

Postby Gladeous » Sun Aug 20, 2017 10:34 am

kyphi wrote:It pays to read the fine print :)

Yeh! :oops: something difficult to do late at night with a sinus headache.


Return to “Software & Applications”