Page 1 of 1

Very annoying bug in Mint 18 preventing me from adding PPAs

Posted: Fri Aug 18, 2017 6:00 pm
by blackoutworm
Hi there.
I just upgraded from Mint 17.3 and for some reason, the settings haven't really been changed from trusty to xenial.
When I am trying to add a PPA, it tells me that the PPA is not supported on Trusty.
So how do I fix this? Where is this distro name info stored so I can fix it?

Re: Very annoying bug in Mint 18 preventing me from adding PPAs

Posted: Fri Aug 18, 2017 6:12 pm
by blackoutworm
Nevermind.
I figured it out.
For those who wonder, edit the /etc/lsb-release file.
I hope the LinuxMint team fixes this problem.

Re: Very annoying bug in Mint 18 preventing me from adding PPAs

Posted: Fri Aug 18, 2017 7:17 pm
by catweazel
This isn't caused by the Mint team. You caused it. Upgrades from different major version numbers are not recommended.

Re: Very annoying bug in Mint 18 preventing me from adding PPAs

Posted: Fri Aug 18, 2017 7:46 pm
by phd21
Hi "blackoutworm",

I have both Linux Mint version 17.3 and 18.1 installed, and you can easily add PPA's to either one.

CAUTION: there are PPA's that do not have software that has been updated for Linux Mint 18.x based on Ubuntu 16.04 Xenial.

If there is some software application that you are trying to get into your newly installed Linux Mint 18.x system that used a PPA for Linux Mint 17.x based on "Ubuntu 14.04 Trusty" that now does not work in LM 18.x, then tell us what it is, or search for other options to install that software. Do not try editing system files and such...

Hope this helps ...

Re: Very annoying bug in Mint 18 preventing me from adding PPAs

Posted: Sat Aug 19, 2017 1:57 pm
by jimallyn
catweazel wrote:This isn't caused by the Mint team. You caused it. Upgrades from different major version numbers are not recommended.
Actually, the Mint devs did post a procedure for upgrading from 17 to 18. But enough people had problems with it that I'm going to do a clean install when I upgrade.