Problem with adding special characters in one program

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
kneops
Level 1
Level 1
Posts: 16
Joined: Sun Dec 11, 2011 5:17 am

Problem with adding special characters in one program

Post by kneops »

I'm using LM 18.1 and when adding special characters like é and ü I have no problems at all (and never have for the last ten years) in any of my programs, except for raw editor Aftershot Pro from Corel. I can't add those characters in the metadata fields of my images. I already contacted them but they couldn't help and said I had to contact the Ubuntu forums because it was not a problem in their software, so here I am.

I'm using an keyboard language US international with dead keys and system language US or Dutch.

User avatar
xenopeek
Level 24
Level 24
Posts: 24746
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Problem with adding special characters in one program

Post by xenopeek »

I installed the trial version of Corel Aftershot Pro on Linux Mint 18.1 Cinnamon. I set my keyboard "English (US, international with dead keys)". I can use the dead keys to type ë in the default installed programs that I tried. In Aftershot it just types an 'e'. I can copy the ë from somewhere else and paste it in Aftershot and that works, so it's not a Unicode problem. Looking at the Aftershot binary it shows it is written in Qt5. I additionally installed a few Qt5 programs and also in those I can use the dead keys to type ë. Looking further in the directory /opt/AfterShot3(64-bit)/ where Aftershot installed I notice it ships private Qt5 libraries instead of using the common system libraries.

As it "just works" for all other programs I'm unclear how this would be a problem on Linux Mint end and not with Aftershot software (or the private Qt5 libraries it uses). It almost sounds like they hacked their own keyboard input method or are using a very old private Qt5 libraries (there is an old Qt5 bug about not dead keys not working). I'd suggest you respond to Corel to ask them which Linux distribution release and desktop environment combination they officially support for typing diacritic characters using a keyboard layout with dead keys. So you could retest on that to confirm.
Image

kneops
Level 1
Level 1
Posts: 16
Joined: Sun Dec 11, 2011 5:17 am

Re: Problem with adding special characters in one program

Post by kneops »

Thanks very much for looking into this! I think you gave me valuable information I can send them.
They support Ubuntu 14.04 and later, so that should be no problem.

User avatar
xenopeek
Level 24
Level 24
Posts: 24746
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Problem with adding special characters in one program

Post by xenopeek »

For the record, Linux Mint 18.1 is fully compatible with Ubuntu 16.04.
They support Ubuntu 14.04 and later, so that should be no problem.
To test that I installed Ubuntu 14.04.5 64-bit, updated it fully, set keyboard layout to English (US, international with dead keys) and then installed the Corel Aftershot Pro trial .deb file. Same results as above: it silently discards dead keys so that typing " + e doesn't give you ë but just e. Typing ë in another program and copying it to Aftershot works.
Image

kneops
Level 1
Level 1
Posts: 16
Joined: Sun Dec 11, 2011 5:17 am

Re: Problem with adding special characters in one program

Post by kneops »

The woman from support is using Ubuntu 16.04 via VMware and says she has no problem adding these characters and says it has nothing to do with a bug in ASP. I tend to disagree because it works in all other programs. I wonder... She is going to send me a video capture of what she is doing...

kneops
Level 1
Level 1
Posts: 16
Joined: Sun Dec 11, 2011 5:17 am

Re: Problem with adding special characters in one program

Post by kneops »

The video she sent me clearly shows she is using a german keyboard DE and ofcourse she can then type üëä very quickly because those keys must be on her keyboard :evil:
I totally forgot the option of installing Ubuntu 16.04 myself on my laptop (LM is on my desktop), so I could test it myself. Just did, with a trial of ASP, just like you did, and got the same results.

Post Reply

Return to “Software & Applications”