Characters Not Showing In All Applications [SOLVED]

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
White Phoenix
Level 4
Level 4
Posts: 266
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti

Characters Not Showing In All Applications [SOLVED]

Post by White Phoenix » Wed Sep 20, 2017 7:05 am

Linux Mint 17.3 MATE 64bit
OpenOffice 4.1.3

I am having a problem with some characters being able to be used in some applications, but not others. It has nothing to do with the fonts. The same font in different applications will still not show the characters in one. All the fonts that I have tried are capable of using this Unicode block (Enclosed Alphanumerics). Font Manager has no problem with them or the Unicode blocks. ⒺⒻⒼⒽⒾ Well, Opera has no problem either.

I have searched the Internet for this problem. The only solutions I found were for Windows 7, some of which I was able to find a counterpart on Linux. I tried creating a file with a name using characters from the Unicode block I want to use. That didn’t work. I tried changing the locale to the one that isn’t being displayed (and was supposed to change back to), but that didn’t work either (locale US 1252 from UTF-8 and back).

The only thing that I did find that sounds real close to what the problem is has to do with the Unicode Normalization Forms, NFC and NFD. From what I’ve read, the default is NFC, but there are some applications (OpenOffice was specifically named) that still require NFD. So the only thing to try is activating/enabling NFD, but I cannot find anything about this for Linux. Only that it exists.

Does anyone know how to enable the NFD?
Last edited by White Phoenix on Sat Sep 23, 2017 8:24 am, edited 1 time in total.
Linux Mint 17.3 / MATE
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)

magnus7
Level 3
Level 3
Posts: 176
Joined: Sat Jan 30, 2016 8:46 pm

Re: Characters Not Showing In All Applications

Post by magnus7 » Thu Sep 21, 2017 6:36 am

Libre Office has no problem with these characters.

User avatar
White Phoenix
Level 4
Level 4
Posts: 266
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti

Re: Characters Not Showing In All Applications

Post by White Phoenix » Fri Sep 22, 2017 10:44 am

Neither does OpenOffice on Windows.
Linux Mint 17.3 / MATE
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)

User avatar
White Phoenix
Level 4
Level 4
Posts: 266
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti

Re: Characters Not Showing In All Applications

Post by White Phoenix » Sat Sep 23, 2017 8:24 am

I did a little more research and came across a reference to ICU.

I searched Software Manager and found two packages for developers and two that weren’t. Of the two one had a higher version number.

I installed libicu4j-4.4-java and it solved the problem.
Linux Mint 17.3 / MATE
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)

Post Reply

Return to “Software & Applications”