Page 1 of 1

Characters Not Showing In All Applications [SOLVED]

Posted: Wed Sep 20, 2017 7:05 am
by White Phoenix
Linux Mint 17.3 MATE 64bit
OpenOffice 4.1.3

I am having a problem with some characters being able to be used in some applications, but not others. It has nothing to do with the fonts. The same font in different applications will still not show the characters in one. All the fonts that I have tried are capable of using this Unicode block (Enclosed Alphanumerics). Font Manager has no problem with them or the Unicode blocks. ⒺⒻⒼⒽⒾ Well, Opera has no problem either.

I have searched the Internet for this problem. The only solutions I found were for Windows 7, some of which I was able to find a counterpart on Linux. I tried creating a file with a name using characters from the Unicode block I want to use. That didn’t work. I tried changing the locale to the one that isn’t being displayed (and was supposed to change back to), but that didn’t work either (locale US 1252 from UTF-8 and back).

The only thing that I did find that sounds real close to what the problem is has to do with the Unicode Normalization Forms, NFC and NFD. From what I’ve read, the default is NFC, but there are some applications (OpenOffice was specifically named) that still require NFD. So the only thing to try is activating/enabling NFD, but I cannot find anything about this for Linux. Only that it exists.

Does anyone know how to enable the NFD?

Re: Characters Not Showing In All Applications

Posted: Thu Sep 21, 2017 6:36 am
by magnus7
Libre Office has no problem with these characters.

Re: Characters Not Showing In All Applications

Posted: Fri Sep 22, 2017 10:44 am
by White Phoenix
Neither does OpenOffice on Windows.

Re: Characters Not Showing In All Applications

Posted: Sat Sep 23, 2017 8:24 am
by White Phoenix
I did a little more research and came across a reference to ICU.

I searched Software Manager and found two packages for developers and two that weren’t. Of the two one had a higher version number.

I installed libicu4j-4.4-java and it solved the problem.