java issue with libreoffice solved

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
hhead
Level 3
Level 3
Posts: 133
Joined: Thu Jan 12, 2012 7:01 am

java issue with libreoffice solved

Post by hhead » Wed Sep 20, 2017 10:30 am

On starting libreoffice calc after installing mate 18.2 I get the following message
LibreOffice requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - LibreOffice - Advanced.
any ideas how I can get rid of this irritating message? Calc seems to work ok.

Thanks
Last edited by hhead on Thu Sep 28, 2017 11:45 am, edited 1 time in total.

User avatar
Pjotr
Level 21
Level 21
Posts: 13500
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: java issue with libreoffice

Post by Pjotr » Wed Sep 20, 2017 10:35 am

How does the setting look in Tools - Options - LibreOffice - Advanced?
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

hhead
Level 3
Level 3
Posts: 133
Joined: Thu Jan 12, 2012 7:01 am

Re: java issue with libreoffice

Post by hhead » Tue Sep 26, 2017 4:03 pm

Thanks for your reply there is nothing listed where there should be JRE. Its not installed. All I need to work out is which package I require...

User avatar
Pjotr
Level 21
Level 21
Posts: 13500
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: java issue with libreoffice

Post by Pjotr » Tue Sep 26, 2017 6:19 pm

OpenJDK. Search for it in Synaptic or Software Manager.
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
karlchen
Level 20
Level 20
Posts: 11319
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: java issue with libreoffice

Post by karlchen » Tue Sep 26, 2017 6:23 pm

To be precise the software package which you will need ise openjdk-8-jre.
At least this is what I have got here on Ubuntu 16.04.3.
Selecting it for installation will pull in some more dependent packages.
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

User avatar
Pjotr
Level 21
Level 21
Posts: 13500
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: java issue with libreoffice

Post by Pjotr » Tue Sep 26, 2017 6:37 pm

karlchen wrote:To be precise the software package which you will need ise openjdk-8-jre.
At least this is what I have got here on Ubuntu 16.04.3.
Selecting it for installation will pull in some more dependent packages.
It looks like OpenJDK 9 has already landed in the repo's as well, but that might be a bèta.... So I agree with advising 8. :)
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
karlchen
Level 20
Level 20
Posts: 11319
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: java issue with libreoffice

Post by karlchen » Tue Sep 26, 2017 6:47 pm

Actually I had been tempted to mention openjdk-9-jre as the more recent alternatve as well.
Had not done so, because indeed I still run openjdk-8-jre wherever I have to make use of Java based software.
Not sure whether whatever runs fine on openjdk-8-jre will also go on running fine on openjdk-9-jre.
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

hhead
Level 3
Level 3
Posts: 133
Joined: Thu Jan 12, 2012 7:01 am

Re: java issue with libreoffice solved

Post by hhead » Thu Sep 28, 2017 11:44 am

Cheers thanks for your kind help everyone solved... Pity mate didn't install it in first place though...

Post Reply

Return to “Software & Applications”