LibreOffice extension - will not load. SOLVED

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
beckwith
Level 3
Level 3
Posts: 150
Joined: Wed Sep 30, 2015 3:22 am
Location: australia

LibreOffice extension - will not load. SOLVED

Post by beckwith » Tue Sep 26, 2017 10:03 pm

New install of Mint 18.2. When I try to add the LibreOffice extension "LanguageTool" I get the error
"Could not create Java implementation loader". Never had this problem before, so I presume I have
previously had some java artifact already installed. LibreOffice 5.1.6.2, LanguageTool-3.7.
Any assistance greatly appreciated.
Last edited by beckwith on Sat Jul 21, 2018 3:27 am, edited 1 time in total.
Linux user: 449018, since 1994
Desktop: HP Pavilion 500-315a i54460 Mint 19.2 cinnamon
Laptop: HP 15-bs089TU i7200U Mint 19.1 Xfce & Windows 10
Toy: Raspberry PI 3B RaspEX Ubuntu 18.04 lxde

thanosfrag
Level 3
Level 3
Posts: 105
Joined: Mon Nov 04, 2013 6:23 am

Re: LibreOffice extension - will not load.

Post by thanosfrag » Sun Feb 04, 2018 10:18 am

Hi beckwith,

The following has worked for me.

I installed JRE8

Code: Select all

sudo apt-get install openjdk-8-jre
Optional: the following package may also be needed.

Code: Select all

sudo apt-get install libreoffice-java-common
Then, I reinstalled the LanguageTools extension.

More information can be found on the following link

https://askubuntu.com/questions/794240/ ... ice#794361

Cosmo.
Level 23
Level 23
Posts: 17827
Joined: Sat Dec 06, 2014 7:34 am

Re: LibreOffice extension - will not load.

Post by Cosmo. » Sun Feb 04, 2018 10:31 am

Language Tool needs since version 3.2 Java 8, as stated on the home page.

Post Reply

Return to “Software & Applications”