[SOLVED] Issues with bluetooth and Bose quiet comfort Mint 18.2

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Pauly1980
Level 1
Level 1
Posts: 29
Joined: Mon Feb 17, 2014 1:31 am
Location: Antarctica

[SOLVED] Issues with bluetooth and Bose quiet comfort Mint 18.2

Post by Pauly1980 » Sat Nov 04, 2017 8:57 pm

So I finally packed my desktop away for the long trip home and have gone back to my laptop.
I spent the best part of a day trying to get my Bose Quiet comfort 35 headphones to connect via bluetooth and after an eternity they finally connect.
So now they are connected they only work in HSP/HFP and not in A2DP.
I have read all the posts about A2DP not working properly with Pulseaudio and bluez but that seems to be a fault with all the installs. However my headphones work perfectly fine on the desktop PC with Mint 18.1 installed and Kernel 4.12
That is what I was running on the laptop and it didn't work so I upgraded to kernel 4.13.5 and Mint 18.2 and still no luck.
If I run $pacmd ls it tells me that A2DP is not available on the device so for some reason it's not detecting the headset properly?

Code: Select all

 index: 2
	name: <bluez_card.04_52_C7_0E_94_EA>
	driver: <module-bluez5-device.c>
	owner module: 26
	properties:
		device.description = "Bose QuietComfort 35"
		device.string = "04:52:C7:0E:94:EA"
		device.api = "bluez"
		device.class = "sound"
		device.bus = "bluetooth"
		device.form_factor = "headphone"
		bluez.path = "/org/bluez/hci0/dev_04_52_C7_0E_94_EA"
		bluez.class = "0x240418"
		bluez.alias = "Bose QuietComfort 35"
		device.icon_name = "audio-headphones-bluetooth"
	profiles:
		headset_head_unit: Headset Head Unit (HSP/HFP) (priority 20, available: unknown)
		a2dp_sink: High Fidelity Playback (A2DP Sink) (priority 10, available: no)
		off: Off (priority 0, available: yes)
	active profile: <off>
	ports:
		headphone-output: Headphone (priority 0, latency offset 0 usec, available: unknown)
			properties:
				
		headphone-input: Bluetooth Input (priority 0, latency offset 0 usec, available: unknown)
			properties:
				
0 sink input(s) available.
0 source output(s) available.
0 cache entrie(s) available.
Any ideas.

Paul
Last edited by Pauly1980 on Wed Nov 08, 2017 8:09 am, edited 1 time in total.

User avatar
catweazel
Level 16
Level 16
Posts: 6264
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Issues with bluetooth and Bose quiet comfort Mint 18.2

Post by catweazel » Sat Nov 04, 2017 9:43 pm

Make sure your Mint is fully up to date. There was a recent update of pulseaudio that has changes to better support bluetooth headphones.
There are no silly questions, but there are silly answers.

Pauly1980
Level 1
Level 1
Posts: 29
Joined: Mon Feb 17, 2014 1:31 am
Location: Antarctica

Re: Issues with bluetooth and Bose quiet comfort Mint 18.2

Post by Pauly1980 » Sun Nov 05, 2017 12:59 am

Pulseaudio is already the most recent version and still the problem persists. I'll just keep plugging away at it

Thanks

Pauly1980
Level 1
Level 1
Posts: 29
Joined: Mon Feb 17, 2014 1:31 am
Location: Antarctica

Re: Issues with bluetooth and Bose quiet comfort Mint 18.2

Post by Pauly1980 » Wed Nov 08, 2017 8:08 am

Found the solution by following the guide posted below

https://erikdubois.be/installing-bose-q ... x-mint-18/

Specifically the following

Go to the following location and add a file in the directory.

Code: Select all

/etc/bluetooth
Make a new file in this location with the name audio.conf.

Copy/paste these lines inside. Do not change anything. The order is important.

Code: Select all

	
[General]
Disable=Socket
Disable=Headset
Enable=Media,Source,Sink,Gateway
AutoConnect=true
load-module module-switch-on-connect


Now you will have to edit the following file in the same directory : main.conf

Change the code to this.

Code: Select all

# Restricts all controllers to the specified transport. Default value
# is "dual", i.e. both BR/EDR and LE enabled (when supported by the HW).
# Possible values: "dual", "bredr", "le"
ControllerMode = bredr

winoseti
Level 2
Level 2
Posts: 55
Joined: Sun Jan 22, 2012 12:02 pm

Re: [SOLVED] Issues with bluetooth and Bose quiet comfort Mint 18.2

Post by winoseti » Fri Dec 29, 2017 2:53 am

usually::: sudo apt-get install pulseaudio-module-bluetooth --fixes this type of problem. remember to remove the profile and reconnect bluetooth phones from a search.

you can get ad2p to work no problems.

User avatar
balayya
Level 1
Level 1
Posts: 44
Joined: Thu Feb 18, 2016 8:15 am

Re: [SOLVED] Issues with bluetooth and Bose quiet comfort Mint 18.2

Post by balayya » Wed May 23, 2018 9:23 am

thanks , this post has solved issue with bose headphones :D
Linux Mint 18.3 AMD FX

Post Reply

Return to “Software & Applications”